Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-25-2003, 07:01 AM   #1
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default mounting network drives

hi,

i've got a strange problem with a network drive mounted in ioftpd...

my vfs looks like this:
"\\server\d$\space" /ARCHiVE

it works well for some minutes, but then it fails:

CWD ARCHiVE
550 ARCHiVE: No such file or directory.

now i have to do "site exec dir \\server\d$", and it works again for about 5mins :/

using ioftpd 5.2.2r
noob is offline   Reply With Quote
Old 11-25-2003, 07:11 AM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Never seen such problem... it sounds like link is lost (router?), and password renegotation is required. Are you running daemon as service?

As temporary fix, you could schedule a bat from ioFTPD, to run every 1minute & execute some command on that directory.
darkone is offline   Reply With Quote
Old 11-25-2003, 07:26 AM   #3
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default

hi,

thanks for the reply!

no, there is no router, and yes, it runs as a services (as a domain user which has access).

i will try the batch solution...
noob is offline   Reply With Quote
Old 11-25-2003, 10:40 AM   #4
rabinovd
Junior Member
 
Join Date: Oct 2003
Posts: 3
Default can't have d$

noob, you cannot have "\\server\d$\space" /ARCHiVE

your d drive is not shared in this case. You are probably using WinXP or Win2k3. You have to make a new share for your d drive.
Make sure you are not using simple file sharing.

To disable simple file sharing, go to windows explorer. Go to tools-->view tab-->uncheck simple file sharing at the very bottom, click OK.

Then right click your D drive, click "sharing and security". You will see D$ as shared by default, which does not mean that it's shared. YOu have to click on New Share button at the bottom, and there you can create your share.

Good luck

I hope that helps
rabinovd is offline   Reply With Quote
Old 11-25-2003, 11:19 AM   #5
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

d$ is a valid Windows share.
the $ makes it hidden, but still usable like any other standard share.
all drives are shared as hidden by default.
Mouton is offline   Reply With Quote
Old 11-25-2003, 01:38 PM   #6
rabinovd
Junior Member
 
Join Date: Oct 2003
Posts: 3
Default exactly

so if he has $ which means it's hidden, therefore you cannot access the drive if it's hidden
rabinovd is offline   Reply With Quote
Old 11-25-2003, 04:11 PM   #7
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

the $ makes it hidden from a share listing, not unusable.
You can access all x$ shares if you are admin of that PC.
They are admin shares and they are there by default so admins can remotely access all drives.
Dunno where u heard/red that you can't access a something$ share, but it's not true.
Mouton is offline   Reply With Quote
Old 11-25-2003, 09:11 PM   #8
sCry
Member
 
Join Date: Oct 2003
Posts: 79
Default

I had the similiar problem, as it wasn't dare to post before.

Problem below:
The remote directory is mapped as O:\ in to local machine, and it can be read when computer is up.

in ioFTPD, VFS file sets like that :
"O:\" /archive

ioftpd server is launched as service with administrator user name which can access the remote directory.

but the "/archive" couldn't be load in ioftpd.

But, when io does not be launched as service, but after user log in, the "/archive" is load corroctly.

Can anyone give me a solution ?
sCry is offline   Reply With Quote
Old 11-26-2003, 12:54 AM   #9
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

this has been a historic problem with windows ftpds running as a service...it has to do with how windows connects to shares running as a system service.

You have two options to try:

1. (more secure) on the computer that is hosting the share, add the ioftpd COMPUTER account to the share and file access privileges. this will give system services (ioftpd) access to those sharepoints.

2. create a user account that has rights on both computers, and run the service as that user. the user also has to be a local admin on the ioftpd box. (downside) then give that user account access to the shared dir.

Let me know if this helps/works for you.
Linkster is offline   Reply With Quote
Old 11-26-2003, 06:16 AM   #10
sCry
Member
 
Join Date: Oct 2003
Posts: 79
Default

thank you, i'll try NO.1 , as it is more reasonable
sCry is offline   Reply With Quote
Reply

Tags
archive, directory, ioftpd, network, works

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
glftpd command set (import) (alternative) bigstar Custom Commands 9 03-08-2008 02:19 PM
wont transfer more than 2mb! |Show| General Discussion 2 01-16-2005 06:20 PM
FFXP forgets registration! thop General Discussion 1 09-07-2004 01:15 PM


All times are GMT -5. The time now is 09:07 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)