Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-11-2003, 10:59 PM   #1
rozwellite
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 37
Default having to add hostnames

I am not sure if this is a bug or what but the problem I am having is that io is resolving hostnames and not relating them to the users ips. IE:[6:33:45p] [@****]: -:: ***** error ::- 09-12-2003 03:36:21 Host '*@**.jetstart.maxnet.co.nz' did not match any of user '******' allowed hosts. (parts been left out to protect the innocent) When i dns the address I am getting the same IP as the one the user has already added. The only way these ppl have been able to get on the ftp is if I add there hostname to the list. In beta5 I didn't see an option to disable the hostname lookup. Here is a copy of my network section of the ini.
Network]
Active_Services = FTP_Service Local_FTP_Service Telnet_Service HTTP_Service

Nagle = False # Enable/Disable TCP Nagle algorithm
Ident_Timeout = 15 # Set ident timeout (seconds)
Hostname_Cache_Duration = 1800 # Seconds cached hostname is valid
Ident_Cache_Duration = 120 # Seconds cached ident is valid
Connections_To_Ban = 5 #
Ban_Counter_Reset_Interval = 120 #
Temporary_Ban_Duration = 1200 # Seconds host remains banned
Internal_Transfer_Buffer = 65536 # Internal transfer buffer size

Any I have something configed wrong please let me know or any ideas how I might fix this would be great. Thanks all in advance.
rozwellite is offline   Reply With Quote
Old 09-12-2003, 09:56 AM   #2
Stardog
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Oct 2001
Posts: 236
Default

I had the same issue. In beta 4 the hostname lookup didn't work for me, now all of a sudden it works, and I have to change everyones IPs to hosts...
Stardog is offline   Reply With Quote
Old 09-12-2003, 02:09 PM   #3
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

B4/5 should use both for comparison (however error.log shows only hostnames) Not sure, if there was bug related to it in B4 - noone reported it
darkone is offline   Reply With Quote
Old 09-12-2003, 03:00 PM   #4
rozwellite
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 37
Default

Seems all fixed in 5.0.9. Thanks
rozwellite is offline   Reply With Quote
Old 09-12-2003, 03:34 PM   #5
rozwellite
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 37
Default

nope sadly I got the error again and had to add the hostname instead of the ip.
rozwellite is offline   Reply With Quote
Old 09-12-2003, 08:41 PM   #6
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Multiply ident timeout with 1000.. that fixes the bug temporarily
darkone is offline   Reply With Quote
Old 10-09-2003, 02:52 PM   #7
chimera
Junior Member
 
Join Date: Sep 2003
Posts: 8
Default

nm.. user ident issues.
chimera is offline   Reply With Quote
Reply

Tags
120, ftp, hostname, seconds, user

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:44 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)