Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
Thread Tools Rate Thread Display Modes
Old 11-15-2004, 12:37 PM   #1
Junior Member
Join Date: Nov 2004
Posts: 6
Default Getting list error???

FlashFXP version 3.0.2 build 1045
Compiled on Nov 7, 2004
Evaluation version, on day 2 of 30

NAT Router [NO] Model []
RUnning Firewall [YES] Version [NetScreen 5XP]
Running ANtivirus [Norton Antivirus 2004]

Been getting this error when I try to connect to this FTP site.
Username and Password seems to authenticate just fine but then this happens.
I have tried in both passive and non passive modes, but no joy.
Any suggestions would be most welcome.

WinSock 2.0 -- OpenSSL 0.9.7d 17 Mar 2004
[R] Connecting to slguden.no-ip.com -> DNS=slguden.no-ip.com IP= PORT=21
[R] Connected to slguden.no-ip.com
[R] 220 SLGuden's FTP Server
[R] USER luthius
[R] 331 Password required for luthius.
[R] PASS (hidden)
[R] 230 User luthius logged in.
[R] 215 UNIX Type: L8
[R] 500 Unknown command.
[R] REST 100
[R] 350 REST supported. Ready to resume at byte offset 100.
[R] REST 0
[R] 350 REST supported. Ready to resume at byte offset 0.
[R] CWD /
[R] 250 CWD command successful. "/F:/Servern" is current directory.
[R] 257 "/F:/Servern" is current directory.
[R] 200 Type set to A.
[R] PORT 172,28,1,10,18,230
[R] 200 Port command successful.
[R] 150 Opening data connection for directory list.
[R] 425 Cannot open data connection (10060).
[R] List Error
Wretch is offline  
Old 11-15-2004, 02:36 PM   #2
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
bigstar's Avatar
Join Date: Oct 2001
Posts: 8,012

Active Mode (PORT) isn't gong to work for you because it's returning your internal LAN IP address. The FTP is unable to connect to it. This might work if you had some sort of NAT setup. You can manually configure FlashFXP to use your internet IP address for Active mode. Options > Preferences > Connection Tab.

Passive Mode should of worked unless the FTP server is located on a LAN and it too is returning a LAN IP address. Provided the FTP server is properly configured to accept passive mode connections you can force FlashFXP to use the site ip (Site Manager > Options > use site-ip for passive mode connections)
bigstar is offline  
Old 11-15-2004, 04:12 PM   #3
Junior Member
Join Date: Nov 2004
Posts: 6

Thanks Bigstar,

I thought it might be something to do with NAT, I have tried both the options you have suggested now, but still no joy.
I will try connecting with a non NAT IP address now, but I seem to recall having tried that already. However I had not thought of the possibility that the server may be behind NAT.

Ill let you know the outcome.
Wretch is offline  
Old 11-16-2004, 01:15 PM   #4
Junior Member
Join Date: Nov 2004
Posts: 6

bah still no joy....

not sure what else to do now...?
Wretch is offline  
Old 11-16-2004, 03:39 PM   #5
Super Duper
FlashFXP Beta Tester
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,881

need to see status logs with pasv mode or other configs you tried.
saying 'no joy' isn't exact error
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-01-2005, 02:03 PM   #6
Junior Member
Join Date: Mar 2005
Posts: 3
Default ASWD

try site manager > options STAT - L

this should work to list
chichen is offline  
Closed Thread

flashfxp, ftp, list, rest, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
serv-u jubair General Discussion 8 11-28-2004 02:48 PM

All times are GMT -5. The time now is 11:13 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)