Go Back   FlashFXP Forums > > > >

WarC's scripts ioA, Warchive, ZR-Tools

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-01-2003, 07:17 PM   #1
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default ioA newdate part + symlinks

hi,

I configured ioA to create newdate + TODAY-MP3/0DAY symlinks.. the first day it worked fine, but on the second day the symlinks were not updated... they still linked to the yesterday mp3 directory...


here is my config

Code:
Area=0DAY|0DAY|e:\dmp\0DAY\%M%D|/0DAY/%M%D|0|e:\dmp\TODAY-0DAY
Area=MP3|MP3|e:\dmp\MP3\%M%D|/MP3/%M%D|0|e:\dmp\TODAY-MP3
Area=BOOKS|BOOKS|e:\dmp\BOOKS\%M%D|/BOOKS/%M%D|0|e:\dmp\TODAY-BOOKS
i always have to deleted the symlinks and recreate them with "site newdate"

any1 got a solution?
noob is offline   Reply With Quote
Old 11-01-2003, 07:21 PM   #2
WarC
Senior Member
ioFTPD Scripter
 
Join Date: Sep 2002
Posts: 426
Default

Classic problem it seems for some

Do you get any errors in debug that dir exist or such. If so symlink is not updated(by design).

If you run newdate in a commandline you can see what it prints for ioFTPD to use. If that looks correct I dunno. Its case sensitive If not mistaken darkone said.
WarC is offline   Reply With Quote
Old 11-01-2003, 07:22 PM   #3
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default

you maybe should add newdate in ioftpd scheduler

Ex.: Newday = EXEC 0 0 * * ..\scripts\ioA\ioA.exe NEWDATE


have fun
bounty
bounty is offline   Reply With Quote
Old 11-01-2003, 07:35 PM   #4
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default

@bounty:

it's already added in scheduler.. it creates the newdate directories flawless, it's just the symlink which does not get updated

@WarC:

thats what i found in my logs

Code:
11-02-2003 00:01:58 COMMANDLINE     - NEWDATE
11-02-2003 00:01:58 NEWDATE         - arealine= 0DAY|0DAY|e:\dmp\0DAY\%M%D|/0DAY/%M%D|0|e:\dmp\TODAY-0DAY
11-02-2003 00:01:58 NEWDATE         - !vfs:chattr 1 "e:\dmp\TODAY-0DAY" "/0DAY/1102"
11-02-2003 00:01:58 NEWDATE vfs     - !vfs:add 777 0:0 e:\dmp\0DAY\1102
11-02-2003 00:01:58 NEWDATE         - arealine= MP3|MP3|e:\dmp\MP3\%M%D|/MP3/%M%D|0|e:\dmp\TODAY-MP3
11-02-2003 00:01:58 NEWDATE         - !vfs:chattr 1 "e:\dmp\TODAY-MP3" "/MP3/1102"
11-02-2003 00:01:58 NEWDATE vfs     - !vfs:add 777 0:0 e:\dmp\MP3\1102
11-02-2003 00:01:58 NEWDATE         - arealine= BOOKS|BOOKS|e:\dmp\BOOKS\%M%D|/BOOKS/%M%D|0|e:\dmp\TODAY-BOOKS
11-02-2003 00:01:58 NEWDATE         - !vfs:chattr 1 "e:\dmp\TODAY-BOOKS" "/BOOKS/1102"
11-02-2003 00:01:58 NEWDATE vfs     - !vfs:add 777 0:0 e:\dmp\BOOKS\1102
no error like it seems :/
the directorys are all upper case on my server, so it should work
noob is offline   Reply With Quote
Old 11-01-2003, 07:50 PM   #5
bounty
Senior Member
ioFTPD Scripter
 
Join Date: Aug 2002
Posts: 529
Default

did you followed this documentation ?

http://www.ioftpd.com/documentation/03-vfs.php#symlink
bounty is offline   Reply With Quote
Old 11-01-2003, 07:56 PM   #6
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default

i don't think there is a variable for month&day in ioftpd
eg. site chattr +l "TODAY-MP3" "/MP3/%M%D"

so ioA must do the job :banana:
noob is offline   Reply With Quote
Old 11-10-2003, 04:42 PM   #7
jbeezer
Junior Member
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 5
Default

Any resolution to this? I also have problems with the symlinks getting updated.
jbeezer is offline   Reply With Quote
Old 11-10-2003, 11:06 PM   #8
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default

yes, the problem is still there
also a option to set the owner for newdate directories would be great.. nobody/nogroup doesn't look good
noob is offline   Reply With Quote
Old 11-11-2003, 02:44 AM   #9
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

I've had this before, delete the symlink and it will hopefully recreate it the next day correctly and start updating correctly again.
No idea why, but it worked for me.
EwarWoo is offline   Reply With Quote
Old 11-12-2003, 01:54 PM   #10
MadCowAss
Member
ioFTPD Registered User
 
Join Date: Feb 2003
Posts: 77
Default

Quote:
Originally posted by EwarWoo
I've had this before, delete the symlink and it will hopefully recreate it the next day correctly and start updating correctly again.
No idea why, but it worked for me.
n00b --> it works for you ?
MadCowAss is offline   Reply With Quote
Old 11-12-2003, 02:06 PM   #11
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

This might be due to the usage of UTC where localtime is needed.

Read this thread to know what to change.
Harm is offline   Reply With Quote
Old 11-13-2003, 08:28 AM   #12
noob
Junior Member
 
Join Date: Nov 2003
Posts: 25
Default

no sorry, problem still exists

i own a server in the UK, and i want it to create newdate directories at 0:00 german time...

i tried to use Use_Locale_Time_Instead_of_UTC=1
and set scheduler to 23:00, but no luck so far :/
noob is offline   Reply With Quote
Old 11-13-2003, 09:26 AM   #13
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

Then you have a problem.

To trigger the newdate event at 0:00 GMT+1 (german time), you have to use 0 23 * * in the scheduler.

But, at 23:00 UTC, both UTC and UK times are still "yesterday" (german time).

You might want to setup your server to use GMT+1 as localtime.
Harm is offline   Reply With Quote
Reply

Tags
day, ioa, newdate, solution, symlinks

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:57 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)