Go Back   FlashFXP Forums > > > >

Harm's scripts ioBanana, Readd script, ioVote

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 05-15-2004, 01:02 PM   #1
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default iob20rc1

i have same problem with 100% cpu from !bw/!dn/!up like some else had too

plus bot announces after long time, like 10 secs or sth

other announces like new dir, del dir, nuke dir are working fine

ioftpd 585r and fresh iob20rc1 installation

regards
zpr is offline  
Old 05-15-2004, 02:06 PM   #2
freak007
Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 69
Default Re: iob20rc1

Quote:
Originally posted by zpr
i have same problem with 100% cpu from !bw/!dn/!up like some else had too

plus bot announces after long time, like 10 secs or sth

other announces like new dir, del dir, nuke dir are working fine

ioftpd 585r and fresh iob20rc1 installation

regards
Same problem on my box. Maybe harm could fix this.
I dont find anything what this cause.

Thx

Cya Freak007
freak007 is offline  
Old 05-15-2004, 07:09 PM   #3
iXi
Senior Member
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 220
Default

I found bug on ioB 2.0rc1..

Quote:

05-15-2004 15:10:59 COMPLETE-B1: "/Movies/Tv-RiPS/\Movies\Tv-RiPS" /Movies/Tv-RiPS/\Movies\Tv-RiPS" /Movies/Tv-RiPS/= <Begin-End> # Ports to use for data transfers. May contain comma seperated list of port ranges./Releasename-FRD" "Stats" "8" "1" "298" "0" "30" "Joulek" "iND" "311" "311"
problem is i always get complett & halfways msgs like that:
-:: complete ::- Movies/Tv-RiPS/

... no stats etc anything missing
i use more then 1 hdd i map tv-rips in its on hdd d...
iXi is offline  
Old 05-16-2004, 03:05 AM   #4
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default

ok i'll wait harm, n/p

thx for great script
zpr is offline  
Old 05-16-2004, 05:32 PM   #5
PopWeasel
Senior Member
ioFTPD Scripter
 
Join Date: Feb 2004
Posts: 181
Default

Hmm..I got an odd thing happening. Not sure why it is but.. Ok I have this cmd in my Welcome file:
%[execute(EXEC ..\scripts\ioBanana.20.RC1\ioBanana.exe sitenew)]
..to show the latest dirs when user logs in. It is showing the latest dirs fine in UltraFXP. In FlashFXP it shows the latest dirs fine also. But in FlashFXP if user is in root dir and disconnects then reconnect it shows latest dirs + site rules just below that. Anybody know why it would do that and if it's possible to fix it from showing site rules uneccessarily? It doesn't do this behavior in UltraFXP btw. Thx.
PopWeasel is offline  
Old 05-16-2004, 06:47 PM   #6
PopWeasel
Senior Member
ioFTPD Scripter
 
Join Date: Feb 2004
Posts: 181
Default

Actually, it's unrelated to that
%[execute(EXEC ..\scripts\ioBanana.20.RC1\ioBanana.exe sitenew)]
..line. I just removed that line from the Welcome file and tested with FlashFXP and it still does it when in root dir then disconnect/reconnect. I thought it was that line that caused it cos I'd just added it.

Ok just figured out that ioBanana is now showing section rules when entering sections and since I dont have separate sections configured it's showing rules on entering the root dir.

Is there an option to disable showing section rules in ioBanana because I don't see one. Thx.
PopWeasel is offline  
Old 05-17-2004, 08:16 AM   #7
iXi
Senior Member
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 220
Default

ioB 2.0rc1 made this~ and i dont know why~~

05-17-2004 08:03:13 HALFWAY1: "/ment = ..\etc\ioftpd.env/Movies/Svcd" "xxxxx-STRAiGHT" "Freak" "iND" "386" "27" "100.0" "320"


little bit wrong announce... and config is seted up ok
iXi is offline  
Old 05-17-2004, 09:35 AM   #8
panzerfaust
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 112
Default

i have a little problem with ioBv20rc1, it doesnt output race info after a file is uploaded (and yes, the sfv is there hehe). any tip?
panzerfaust is offline  
Old 05-17-2004, 03:19 PM   #9
PopWeasel
Senior Member
ioFTPD Scripter
 
Join Date: Feb 2004
Posts: 181
Default

Do you mean the "r a c e s t a t s" in the status window or the In/Complete dir tag? Cos both of those are working here. But "site rescan" and "site rescan all" don't seem to be working for me. Can anyone else confirm that..thx.
PopWeasel is offline  
Old 05-17-2004, 08:35 PM   #10
MidasKing
Senior Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 108
Default ioBanana.v20.RC1

Two erros (I think) in ioBanana v20 RC1

1) FlashFXP Command Pack (in ioBananav20rc1) show
Quote:
An internal erros has occurred
Cannot open file \ioFTPD.5.5.plus.ioBanana.v20.and.ioA.fce" when import with ffxp
2) rules for presentation in login root directory (section 0) not shown but in others sections is ok

my rules.cfg:

Quote:
# Sections definitions#
# syntax: section:<section_#>:<vfs_path>:<section_name>
#
# Note: no <vfs_path> can be empty!
##
section:0:/:GENERAL
section:1:/Appz/:Appz
section:2:/Gamez/:Gamez
.
.
.
section:4:/Mp3z/:Mp3z

##
# Rules definitions
#
# syntax: rule:<section_#>:<rule_text>
##
rule:0: blablabla
rule:0: blablabla

rule:1: blobloblo
rule:1: blobloblo
.
.
.
rule:4: blxblxblx
rule:4: blxblxblx
any idea(s)??? :banana:
MidasKing is offline  
Old 05-18-2004, 05:07 AM   #11
panzerfaust
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 112
Default

popweasel: site rescan works here, however, racestats in the status window of my fxp client does not, well it shows on cwd, but not after a file has been uploaded (like it does with glftpd's zipscript for example, altho it has done it with other versions of ioB)


edit: i can confirm that the new flashfxp custom commands wont work with v20rc1, v19 works tho.
panzerfaust is offline  
Old 05-18-2004, 07:18 AM   #12
iXi
Senior Member
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 220
Default

racestats complett msg is bugged
also site rescan commands dont work!
i can confirm this..

cya
iXi is offline  
Old 05-18-2004, 07:29 AM   #13
yogi
Junior Member
ioFTPD Foundation User
 
Join Date: Oct 2003
Posts: 10
Default

ioBanana rc20 rc1..

I think the imdb problem is solved? But if any one upload a nfo in svcd dir the ioBanana.exe thread take 100% cpu time... is that normal or a miss config ?
yogi is offline  
Old 05-18-2004, 11:15 AM   #14
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

PopWeasel: the main rules are shown on 'CWD /'. If your client uses that command on disconnect/reconnect, you'll see the rules.

panzerfaust: please upgrade your board profile.

UNiCHeF: check your ioFTPD.ini and your vfs files. (didn't I told you already ).

yogi: probably some misconfiguration.

MidasKing: the first error comes from your ftp client, not ioBanana.
It show rules on CWD, this means it won't show rules in root if you don't 'CWD /'. You can try to force it using the OnFtpLogIn event.

All: ioBanana v20rc1 isn't marked as stable because it isn't.
It hasn't been released so you can start to test here and there but for those who couldn't wait for the imdb fix.
There are already some "official" beta testers who know how to report bugs the good way (with the needed details, files, etc.). Most "bugs" posted here are misconfigurations or already known problems. To avoid posting loads of crap here, i'll move everything related to the rc1 to a new thread and i'll close it.
Feel free to add your comments on bugs when i'll talk about them with the beta testers in #ioBanana though.
Thanks.

PS:
- make sure you've replaced all your message files with the new ones. If you don't want to do it, make sure all your message files have a new empty line at the end.
- site rescan works here btw.
Harm is offline  
Closed Thread

Tags
announces, del, dir, nuke, sth

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:22 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)