Old 12-25-2005, 06:49 AM   #1
PlaN3t
Member
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 43
Default Problem with dZSbot with !free

why with this command !free bot don't talk?

the error is

[12:47] Tcl error [show_free]: can't read "device(1)": no such element in array

anyone help me?

merry xmas all

bye
PlaN3t is offline   Reply With Quote
Old 12-25-2005, 06:40 PM   #2
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

# !!! THE LOGICAL DRIVE LETTER SHOULD BE WRITED IN UPPER CASE !!!
# !!! Exemple: C: or D: or E: ...but without \ at the end !!!
# !!! OTHER ARGS SHOULD RESPECT $sections variable ABOVE !!!
set device(0) "x: x -x"
set device(1) "x: -x"
set device(TOTAL) 2
set device(COLUMN) 1

You've stuffed up that section somehow.
If you only have 1 drive delete the device(1) entry altogether.
EwarWoo is offline   Reply With Quote
Old 12-25-2005, 06:46 PM   #3
PlaN3t
Member
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 43
Default

i have set this

set device(0) "C: GAMES DIVX MP3 SERIETV APPZ MP3-ARCHIVE"
set device(TOTAL) 5
set device(COLUMN) 5
PlaN3t is offline   Reply With Quote
Old 12-26-2005, 06:51 AM   #4
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

set device(TOTAL) 5
You dont have 5 devices, you only have 1.
You're telling it to expect a device(0), device(1), device(2) etc but they dont exist.
EwarWoo is offline   Reply With Quote
Reply

Tags
array, device1, element, error, free

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:58 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)