Go Back   FlashFXP Forums > > > >

! Requests Need a script or some sort of cool .bat file ? Ask here!

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-10-2005, 01:12 AM   #1
ChipMunk666
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 220
Default good pre helper script

I am searching a good PRE script
Something like site addaffil

But i want that the group only can see their own dir without making a seperate sfv to fix it.
Is there any script out there ???
ChipMunk666 is offline   Reply With Quote
Old 11-10-2005, 06:43 AM   #2
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Default

Yes, look in the scripts section. Harm has made such a script called ioPRECFG
peep is offline   Reply With Quote
Old 11-10-2005, 08:38 AM   #3
ChipMunk666
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 220
Default

Quote:
Originally Posted by peep
Yes, look in the scripts section. Harm has made such a script called ioPRECFG
I know but the owners still can see the others groups
ChipMunk666 is offline   Reply With Quote
Old 11-10-2005, 03:13 PM   #4
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Default

The do [ SITE CHATTR +h "foler_name_here" "=group_name" ] To make folder_name_here private and only viewable for users in group_name
peep is offline   Reply With Quote
Old 11-10-2005, 03:22 PM   #5
ko0ky
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2003
Posts: 28
Default

Quote:
Originally Posted by ChipMunk666
I know but the owners still can see the others groups

Not if it's configured properly. When one of my affils enter the pre dir, all they see if their own, not the 20+ other dirs there.
ko0ky is offline   Reply With Quote
Old 11-11-2005, 04:26 AM   #6
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default

since 4+ kb bug is killing me i prefer separate .vfs files for each group, more secure way if you ask me...
zpr is offline   Reply With Quote
Old 11-11-2005, 06:06 AM   #7
ChipMunk666
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 220
Default

If i get it right if use a script that deletes 4k .ioFTPD than u lose everything.
I thought this only hold idmb and folder structure and racers.Not settings u create with a script.
So thats maybe the reason why it didn't work? The .ioFTPD got deleted but shouldn't the script add it back than to the new .ioFTPD it won't exceed 4k than anymore cause racers etc are gone...
ChipMunk666 is offline   Reply With Quote
Old 11-11-2005, 01:12 PM   #8
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default

also: .ioftpd deleted = chmod 755 = no upload rights
zpr is offline   Reply With Quote
Old 11-12-2005, 11:48 AM   #9
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by zpr
since 4+ kb bug is killing me i prefer separate .vfs files for each group, more secure way if you ask me...
i've just released version 5.8.6r of ioFTPD, which i suspect has a fix for the 4k+.ioFTPD bug. i haven't received any confirmation of this one way or the other. what version of ioftpd are you using? i'd like to hear from a couple people as to whether this bug is still a problem or not.
_panic_ is offline   Reply With Quote
Old 11-12-2005, 03:54 PM   #10
zpr
Senior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 170
Default

im using 586r since yesterday and seems like nasty bug is gone, so huray
zpr is offline   Reply With Quote
Old 11-12-2005, 04:49 PM   #11
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by zpr
im using 586r since yesterday and seems like nasty bug is gone, so huray
sweet. let me know if you do see it, but checking over the code it looked like it had been fixed.
_panic_ is offline   Reply With Quote
Old 01-01-2006, 08:04 PM   #12
CrAcKeR
Junior Member
 
CrAcKeR's Avatar
 
Join Date: Jun 2003
Posts: 19
Default problem

im trying ioPRECFG

when im doing site addaffil..it creates the group folder in ioFTPD/system folder

and not in pre folder i set up
have the right paths in ioprecfg and ioa.cfg
anyone know the problem ?
CrAcKeR is offline   Reply With Quote
Old 01-02-2006, 01:42 AM   #13
ChipMunk666
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 220
Default

Quote:
Originally Posted by CrAcKeR
im trying ioPRECFG

when im doing site addaffil..it creates the group folder in ioFTPD/system folder

and not in pre folder i set up
have the right paths in ioprecfg and ioa.cfg
anyone know the problem ?
Probably u don't
If u have the paths correct than it should create it in the pre dir
ChipMunk666 is offline   Reply With Quote
Reply

Tags
good, making, pre, script, seperate

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:03 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)