Old 08-03-2011, 11:19 AM   #61
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

When i experienced that, it's always been a faulty drive or cable.
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 08-03-2011, 11:33 AM   #62
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

update avalible
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 08-03-2011, 05:12 PM   #63
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

mr.babek: Could you try leaving a login using a new test account (so it won't be logged in a 2nd time) just idling somewhere? If you could make that a M flagged account that would be best. After things lock up see if you do 'site crashnow' to generate a debug dump you can can send me.

Any chance you are using a PRE/POST command on the PASS command? I know ioDELUSER uses one to show banned messages, etc... I doubt anybody using the new OnBannedLogin event yet.

Since the server accepts the new connections and allows the USER command, but dies on PASS it's possible the userfile or a lock in the client array is being held and that is preventing normal operation. That should be relatively easy to spot in the dump file if you can generate one. If site crashnow doesn't work, you can try creating one using 'Create dump file' by right clicking on ioFTPD.exe in the process tab of task manager. However on win2k8 x64 I've had people send me dumps created via taskmanager that are useless because of the 64bit compatibility layer and I'm not sure how to fix that so try crashnow first.

The ioFTPD TCL routines track open userfiles, mountfiles, etc and cleanup after each script. It's entirely possible I missed something now that some of the newer features are being used by ioNinja. No matter what TCL does (except for some waitobject usage) it should clean up after itself correctly but it looks like in the case of an error it might not be. A minidump should probably highlight which lock things are stuck on and we can work from there is that is the problem.
Yil is offline   Reply With Quote
Old 08-03-2011, 06:22 PM   #64
HurricaneHunter
Junior Member
 
Join Date: Aug 2011
Posts: 3
Default

Quote:
Originally Posted by HurricaneHunter View Post
Good Morning all;

I have just recenlty went back to ioftpd after using glftpd for many years and seem to be having a small promblem with the ioniga scripts.

When user upload a file and it scompleted, i get a complete bar that shows like

[ioNiNJA] - ( 874KB 1F - COMPLETE ) - [ioNiNJA]

is there any way to edit that to my likeing. I have searched and searched and seem to be missing it.

Any help would be appreicated.

Thanks
Never mind, i have figured it out, its under the themes', Saw that thought it was part of the bot set up.
HurricaneHunter is offline   Reply With Quote
Old 08-04-2011, 03:32 AM   #65
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Default

Quote:
Originally Posted by Yil View Post
mr.babek: Could you try leaving a login using a new test account (so it won't be logged in a 2nd time) just idling somewhere? If you could make that a M flagged account that would be best. After things lock up see if you do 'site crashnow' to generate a debug dump you can can send me.

Any chance you are using a PRE/POST command on the PASS command? I know ioDELUSER uses one to show banned messages, etc... I doubt anybody using the new OnBannedLogin event yet.

Since the server accepts the new connections and allows the USER command, but dies on PASS it's possible the userfile or a lock in the client array is being held and that is preventing normal operation. That should be relatively easy to spot in the dump file if you can generate one. If site crashnow doesn't work, you can try creating one using 'Create dump file' by right clicking on ioFTPD.exe in the process tab of task manager. However on win2k8 x64 I've had people send me dumps created via taskmanager that are useless because of the 64bit compatibility layer and I'm not sure how to fix that so try crashnow first.

The ioFTPD TCL routines track open userfiles, mountfiles, etc and cleanup after each script. It's entirely possible I missed something now that some of the newer features are being used by ioNinja. No matter what TCL does (except for some waitobject usage) it should clean up after itself correctly but it looks like in the case of an error it might not be. A minidump should probably highlight which lock things are stuck on and we can work from there is that is the problem.
Hi Yil, thanks for the extensive answer. I will try this next weekend. I doubt I will be able to use any command when io expierences the error.
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 08-04-2011, 07:17 AM   #66
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

Have you tried with 7.7.3? Doubtful it would solve your issue but you never know
ArtX is offline   Reply With Quote
Old 08-04-2011, 09:30 AM   #67
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Talking

Quote:
Originally Posted by Carpo View Post
Have you tried with 7.7.3? Doubtful it would solve your issue but you never know
Well actually that is what I just did, and everything is running fine for several hours already.
(I was running 7.7.2)

I am just trying to figure out how to activate the gamespy plugin ? just add an action in ioninja when uploading the nfo? for now it wont work
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 08-04-2011, 11:56 AM   #68
SRH99
Member
 
Join Date: Mar 2010
Posts: 44
Default

o-dog, after updating to ioNiNJA.1.0.ALPHA.1.0.2.2011-08-03 the bot don't announce imdb anymore (it worked with ioNiNJA.1.0.ALPHA.1.0.1.1.2011-07-27)

bot log says
dZSbot warning: Invalid log line: 08-04-2011 18:40:21 IMDB:{The Rebound} http://www.imdb.com/title/tt1205535/ 2009 - - 8******14**** 6.4 9,400 - - {} US A English {Comedy Romance} - - {£360,015} UK {25 July} 2010 306 306 - - Limited

- any advise?
SRH99 is offline   Reply With Quote
Old 08-04-2011, 01:21 PM   #69
HurricaneHunter
Junior Member
 
Join Date: Aug 2011
Posts: 3
Default

o-dag, I have another question i cant seem to figure out, when i upload an .nfo file, it it dissappears and i cant seem to find a the setting for it. Any advice on fixing this, as i checked the .cfg file up and down and not having much luck.

Thanks
HurricaneHunter is offline   Reply With Quote
Old 08-04-2011, 01:56 PM   #70
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Default

Quote:
Originally Posted by SRH99 View Post
o-dog, after updating to ioNiNJA.1.0.ALPHA.1.0.2.2011-08-03 the bot don't announce imdb anymore (it worked with ioNiNJA.1.0.ALPHA.1.0.1.1.2011-07-27)

bot log says
dZSbot warning: Invalid log line: 08-04-2011 18:40:21 IMDB:{The Rebound} http://www.imdb.com/title/tt1205535/ 2009 - - 8******14**** 6.4 9,400 - - {} US A English {Comedy Romance} - - {£360,015} UK {25 July} 2010 306 306 - - Limited

- any advise?
Same problem here , no IMDB output to the bot
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 08-04-2011, 02:05 PM   #71
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Default

Quote:
Originally Posted by mr.babek View Post
Well actually that is what I just did, and everything is running fine for several hours already.
(I was running 7.7.2)

I am just trying to figure out how to activate the gamespy plugin ? just add an action in ioninja when uploading the nfo? for now it wont work
Update: turns out the botchk.ictl is causing the problem, I have got no clue whatsoever why
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 08-04-2011, 03:10 PM   #72
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Hmm. I bet the invalid log line message which is probably causing the imdb announce to fail is because there isn't a space after the IMDB: tag. I'm pretty sure a bunch of the dbzbot uses the "IMDB:" bit to figure out if and where it should do something and without a space it's getting confused.
Yil is offline   Reply With Quote
Old 08-05-2011, 12:43 PM   #73
o_dog
Senior Member
 
Join Date: May 2007
Posts: 692
Default

Sorry, minor bug fix, used wrong source for change of imdb. Should work in new upgrade just replace imdb.itcl and reconfigure it
__________________
ioNiNJA
o_dog is offline   Reply With Quote
Old 08-06-2011, 08:51 AM   #74
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Default

hmm .. I realy really really dont know how to get the gamesspy function to work ? Can someone explain?
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 08-06-2011, 10:15 AM   #75
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

just copy the entries already under the exec on nfo upload and point it towards the gamespy plugin
ArtX is offline   Reply With Quote
Reply

Tags
added, fixes, replace, thread, update

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:15 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)