Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-23-2004, 09:02 AM   #1
dink-puller
Member
ioFTPD Foundation User
 
dink-puller's Avatar
 
Join Date: Sep 2004
Posts: 58
Default detailed permissions for directories

I'm having trouble with this. I don't understand how this works with or against CHMOD either. I've read the examples in Knowledge Base, and Documentation, and can't seem to get what I want. My VFS is like this:

/
/download (anyone can leech & run sanctioned ioFTPD scripts, nobody 'cept M users can mkdir, delete, or upload)
/leech (permissions same as above)
/download2 (permissions same as above))

/upload (anyone can mkdir, upload and run sanctioned ioFTPD scripts, nobody 'cept M users can leech
/upload/request.txt (anyone can leech this file)


Could anyone point me to some more examples of permissions configuration and how exactly to do it in conjunction with CHMOD, or tell me how to fix the example above...any or all three of the above? Thanks in advance.
dink-puller is offline   Reply With Quote
Old 09-23-2004, 01:26 PM   #2
odd
Senior Member
ioFTPD Registered User
 
Join Date: Sep 2003
Posts: 273
Default

Its better if you try to learn it yourself. Most of the ppl here have done so and with the help from the documents. But as your asking I have to belive that you have tryed enoufgh.

Chmod every directories that you want users to be able to upload to 777. In your case directori /upload/. Now regular users can upload to this diractory.

You have a Detailed Premissons for directories in you ioftpd.ini file. Here you can setup more advanced rules. Such as only allowing Master (M) to be able to upload/download/delete/ and mkd in special directories.

To do this...
Quote:
/download (anyone can leech & run sanctioned ioFTPD scripts, nobody 'cept M users can mkdir, delete, or upload)
you can do it in 2 ways.

1th: If you do not chmod /download/ to 777 only Masters (M) can upload/delete/ and mkd.

2th: Chmod to 777 then use Detailed Premissons for directories in you ioftpd.ini and setup these rules.
Quote:
###
# Detailed permissions for directories
#
# priviledge = <virtual path> <rights>
#
Upload = /download/* M !*
Upload = * *
MakeDir = /download/* M !*
MakeDir = * *
Delete = * 1VM
DeleteOwn = /download/* M !*
DeleteOwn = * *
These underlines rules means that Upload in directori /download/ is not allowed if you do not have flag M. You can setup users and groups also. Its mentioned in the documents. I hope i did not make it to difficult.

EDIT: changed the permissions so they are accurate.
odd is offline   Reply With Quote
Old 09-23-2004, 01:57 PM   #3
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

And for the upload dir it should be something like this:
Download = /upload/request.txt *
Download = /upload/* M !*

And if you don't want anyone (except M) deleting the stuff they upload in /upload/:
DeleteOwn = /upload/* M !*

You probably understand how it works now...
Zer0Racer is offline   Reply With Quote
Old 09-23-2004, 03:53 PM   #4
dink-puller
Member
ioFTPD Foundation User
 
dink-puller's Avatar
 
Join Date: Sep 2004
Posts: 58
Default

thanks for the replies
dink-puller is offline   Reply With Quote
Old 09-24-2004, 04:07 PM   #5
dink-puller
Member
ioFTPD Foundation User
 
dink-puller's Avatar
 
Join Date: Sep 2004
Posts: 58
Default

Finally got what I wanted! CHMOD everything to 777, then adding exclusions to ioFTPD.ini was the key.
dink-puller is offline   Reply With Quote
Old 10-26-2004, 07:36 AM   #6
dejn
Junior Member
ioFTPD Foundation User
 
Join Date: Mar 2004
Posts: 7
Default subfolders

How do I change permissions to the subfolders of the folder i made.....
ie

makedir = /test/* !* (now users cant create any dirs after test)

but in the subfolders i want them to be able to do so...
like:

/test/
-------> /test1/
-------> /test2/ etc etc
dejn is offline   Reply With Quote
Old 10-27-2004, 12:00 PM   #7
mr_F_2
Senior Member
 
Join Date: Jan 2004
Posts: 203
Default

you try

/test/test1/* *

?
mr_F_2 is offline   Reply With Quote
Old 10-31-2004, 06:40 AM   #8
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

You should read this thread: http://www.ioftpd.com/board/showthre...&threadid=2926
Zer0Racer is offline   Reply With Quote
Old 10-31-2004, 07:12 AM   #9
Grendel
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Grendel's Avatar
 
Join Date: Jul 2004
Posts: 187
Default

Quote:
Originally posted by Zer0Racer
You should read this thread: http://www.ioftpd.com/board/showthre...&threadid=2926

I only got this:

You do not have permission to access this page.


__________________
- FlashFXP v4.0 BETA (v3.7.9 Build 1401) registered
- Windows 7 x64
- McAfee Antivirus Enterprise 8.7i Patch 2 + Antispyware 8.7i
Grendel is offline   Reply With Quote
Old 10-31-2004, 09:42 AM   #10
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

That's because that thread is in the archive, which means it's content has been made into a KB article.
http://www.ioftpd.com/kb/view.php?kbid=110
Mouton is offline   Reply With Quote
Reply

Tags
ioftpd, leech, permissions, run, upload

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transfer hangs before it starts? Waruwaru General Discussion 0 09-20-2004 04:06 PM


All times are GMT -5. The time now is 12:24 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)