Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-14-2004, 06:30 PM   #1
rocky
Junior Member
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 22
Default Problem with login. Connection refused

Hi.

I've been usig io for some time now, but during at movement i've been gone for at little time.

I've set up my server as I used to, but now I get the following message when i log in.

[R] Connecting to Egen server -> IP=xxx.xxx.xxx.xxx PORT=23000
[R] Connection failed (Connection refused)

If I try to log in throuugh the Lan, the server works just perfect, so I can't understand it.

I have a zyxel 650 R router, and have forwarded port 23000-23999 to 10.0.0.3. I've contacted my ISP and asked if the router worked correctly and he confirmed. The ports are forwarded. Besides I use remote acces on my server, why this port also is forwarded, and that works fine from outside the router so itøs probably io that's causing the problem.

My internal IP is 10.0.0.3 and my .ini and hosts.rules files looks as follows

___________________________
[NAT]
Host = xxx.xxx.xxx.xxx
Ports = 23001-23999
Random = True
;Global_Inbound_Bandwidth = 10000
;Global_Outbound_Bandwidth = 10000
;Client_Inbound_Bandwidth = 100 [*registered version*]
;Client_Outbound_Bandwidth = 50 [*registered version*]
;Bind = 10.0.0.3


[LAN]
Host = 10.0.0.3
Ports = 28001-28999
Random = True
;Global_Inbound_Bandwidth = 10000
;Global_Outbound_Bandwidth = 10000
;Client_Inbound_Bandwidth = 100 [*registered version*]
;Client_Outbound_Bandwidth = 50 [*registered version*]
;Bind =

################## END OF DEVICES ####################



##################### SERVICES #######################

[NAT_FTP_Service]
Type = FTP
Device_Name = NAT
Port = 23000
Description = My FTP Service
User_Limit = 10
Allowed_Users = *
Messages = ..\text\ftp

### Encryption ###
#
Require_Encrypted_Auth = !*
Require_Encrypted_Data = !*
Certificate_Name = xxx.xxx.xxx.xxx
Explicit_Encryption = True
Encryption_Protocol = SSL3
Min_Cipher_Strength = 128
Max_Cipher_Strength = 256

### IDNT command handler ###
#
Get_External_Ident = True

### Traffic Balancing ###
#
;Data_Devices =
;Random_Devices = True

[LAN_FTP_Service]
Type = FTP
Device_Name = LAN
Port = 28000
Description = My FTP Service
User_Limit = 10
Allowed_Users = *
Messages = ..\text\ftp

### Encryption ###
#
Require_Encrypted_Auth = !*
Require_Encrypted_Data = !*
Certificate_Name = xxx.xxx.xxx.xxx
Explicit_Encryption = True
Encryption_Protocol = SSL3
Min_Cipher_Strength = 128
Max_Cipher_Strength = 256

### IDNT command handler ###
#
Get_External_Ident = True

### Traffic Balancing ###
#
;Data_Devices =
;Random_Devices = True


[Network]
Active_Services = NAT_FTP_Service LAN_FTP_Service
____________________________

# Default policy
#
# POLICY ACCEPT CONNECTIONS_PER_IP
# POLICY DENY
#
POLICY ACCEPT 4

# Classes
#
# CLASS CLASS_NAME TOTAL_CONNECTIONS_PER_CLASS
CLASS NORDIC 25
CLASS ADMIN -1

# Rules
#
# ACCEPT I|H IP|HOSTNAME CLASS_NAME CONNECTIONS_PER_IP
# DENY I|H IP|HOSTNAME LOG_STRING
#

ACCEPT I 127.0.0. ADMIN -1
ACCEPT H .fi NORDIC 1
ACCEPT H .se NORDIC 1
ACCEPT H .no NORDIC 1
ACCEPT I xxx.xxx.xxx.xxx ADMIN -1
ACCEPT I 10. ADMIN -1
DENY H .tw "Access from taiwan is prohibited"

Any one who can see what's wrong, cause I can't!!!!
rocky is offline   Reply With Quote
Old 09-15-2004, 02:37 PM   #2
djrob
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 99
Default

I'm behind router myself and have always logged in using local ip. External ip has never worked though...
Ask someone else to try and login using your "real" ip

And remove the ; from ---> ;Bind = 10.0.0.3
djrob is offline   Reply With Quote
Old 09-15-2004, 04:56 PM   #3
rocky
Junior Member
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 22
Default

I'll give it a try, but last time it ran perfectly with this configuration. Or at least i presume this configuration.

Btw. Have removed the ; form Bind. That obviously wasn't the problem
rocky is offline   Reply With Quote
Old 09-15-2004, 04:58 PM   #4
rocky
Junior Member
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 22
Default

Btw djrob.

Have you checked if you have enabled ip nat loopback in your router. That might be why yu can't login with your external ip from inside your router
rocky is offline   Reply With Quote
Old 09-16-2004, 08:57 AM   #5
rocky
Junior Member
ioFTPD Registered User
 
Join Date: Jul 2003
Posts: 22
Default Problem solved

Hi guys.

Problem solved. The conf. posted is correct and working.
It was ofcause my router that was ****ed up, but that the ISP couldn't figure out himself.
But thaks anyway
rocky is offline   Reply With Quote
Reply

Tags
accept, ftp, server, true

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
Flash hangs during transfers slatts General Discussion 5 01-14-2005 07:50 PM
Ident Server Unable To Listen on port 113 bionic General Discussion 1 10-20-2004 05:33 PM
.ioFTPD files bug in 4.5.4 WarC Bug Reports 1 02-27-2003 04:31 AM
CHMOD bug iXi Bug Reports 2 12-23-2002 07:53 AM


All times are GMT -5. The time now is 05:49 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)