Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 11-01-2003, 06:26 PM   #1
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default cap data, but not list?

could someone please explain or show me an example using my config setup below to get downloads capped, but listing dir etc at full speed please..

thanks

[FTP-Listen]

Host = 192.168.1.1
Global_Inbound_bandwidth = 0
Global_Outbound_bandwidth = 0
Client_Inbound_bandwidth = 0
Client_Outbound_bandwidth = 0

[FTP-Data]

Host = 192.168.1.1
Ports = 1401-1500
Global_Inbound_bandwidth = 0
Global_Outbound_bandwidth = 20


################## END OF DEVICES ####################



##################### SERVICES #######################

[FTP_Service]
Type = FTP
Device_Name = FTP-Listen
Data_Devices = FTP-Data
Port = 7777
Description = MIDKNIGHTS LIAR
User_Limit = 100
Allowed_Users = *
Messages = ..\text\ftp
MidKnight is offline   Reply With Quote
Old 11-01-2003, 06:50 PM   #2
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

this is how i would also like to limit my site...suggestions welcome.
Linkster is offline   Reply With Quote
Old 11-01-2003, 07:28 PM   #3
MaistroX
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Jul 2002
Posts: 221
Question

Me allso wondering !?
MaistroX is offline   Reply With Quote
Old 11-01-2003, 07:31 PM   #4
Harm
Too much time...
Ultimate Scripter
 
Join Date: Jul 2003
Posts: 1,430
Default

The example below shows the .ini settings to cap data to 40kbps (both in and outgoing) but not list/commands (0 = unlimited).

Code:
[FTP-Listen]

Host = 192.168.1.1
Global_Inbound_bandwidth = 0
Global_Outbound_bandwidth = 0
Client_Inbound_bandwidth = 0
Client_Outbound_bandwidth = 0

[FTP-Data]

Host = 192.168.1.1
Ports = 1401-1500
Global_Inbound_bandwidth = 40
Global_Outbound_bandwidth = 40

##################### SERVICES #######################

[FTP_Service]
Type = FTP
Device_Name = FTP-Listen
Data_Devices = FTP-Data
Port = 7777
Then you can set per user speed limits using SITE CHANGE <user> SPEEDLIMIT <dn limit> <up limit>.
Harm is offline   Reply With Quote
Old 11-01-2003, 07:40 PM   #5
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

Thanks a lot Harm
Linkster is offline   Reply With Quote
Old 11-01-2003, 07:47 PM   #6
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

yes thankyou very much.

just one more thing... could u show how i would use that example, + have it so LAN users have full speed.

thanks
MidKnight is offline   Reply With Quote
Old 11-01-2003, 09:14 PM   #7
Romad
Junior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Mar 2002
Posts: 22
Default

This is what I use in my settings. The Ftp data is for
outside connection and has BW control. I use Local to
log on for max local transfers.

##################### DEVICES ########################

[FTP-Channel]
Host = romad.homeftp.com
Bind = 192.168.1.200
Global_Inbound_bandwidth = 0 #Unlimited
Global_Outbound_bandwidth = 0 #Unlimited
Client_Inbound_bandwidth = 0 #Unlimited
Client_Outbound_bandwidth = 0 #Unlimited

[FTP-Data]
Host = romad.homeftp.com
Ports = 2080-3020
Bind = 192.168.1.200
Global_Inbound_bandwidth = 342 #5% of total download speed
Global_Outbound_bandwidth = 37 #5% of my total upload speed

[Local-Channel]
Host = 127.0.0.1
Bind = 127.0.0.1
Global_Inbound_bandwidth = 0 #Unlimited
Global_Outbound_bandwidth = 0 #Unlimited
Client_Inbound_bandwidth = 0 #Unlimited
Client_Outbound_bandwidth = 0 #Unlimited

[Local-Data]
Host = 127.0.0.1
Ports = 3040-3080
Bind = 127.0.0.1
Global_Inbound_bandwidth = 0 #Unlimited
Global_Outbound_bandwidth = 0 #Unlimited

################## END OF DEVICES############

##################### SERVICES##############

[FTP_Service]
Type = FTP
Device_Name = FTP-Channel
Port = 3001
Description = My Any FTP Service
User_Limit = 4
Allowed_Users = *
Messages = ..\text\ftp
Require_Encrypted_Auth = !*
Require_Encrypted_Data = !*
Certificate_Name = romad.homeftp.com
Explicit_Encryption = True
Encryption_Protocol = SSL3
Min_Cipher_Strength = 128
Max_Cipher_Strength = 384
;Get_External_Ident = False
Data_Devices = FTP-Data
;Random_Devices = False

[Local_FTP_Service]
Type = FTP
Device_Name = Local-Channel
Port = 3060
Description = My Local FTP Service
User_Limit = 2
Allowed_Users = *
Messages = ..\text\ftp
;Require_Encrypted_Auth = !*
;Require_Encrypted_Data = !*
;Certificate_Name = 127.0.0.1
;Explicit_Encryption = True
;Encryption_Protocol = SSL3
;Min_Cipher_Strength = 128
;Max_Cipher_Strength = 384
;Get_External_Ident = Flase
Data_Devices = Local-Data
;Random_Devices = False
################## END OF SERVICES ###################

[Network]
Active_Services= FTP_Service Local_FTP_Service Telnet_Service
Romad is offline   Reply With Quote
Reply

Tags
192.168.1.1, ftp, global_inbound_bandwidth, global_outbound_bandwidth, host

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:28 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)