Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-18-2003, 06:04 AM   #1
Mavke
Member
 
Join Date: Jun 2003
Posts: 51
Unhappy ioFTPD 5.1.14 behind Router...(Problems)

I have setup a new ioFTPD based on beta 5.1.14.
The new thing here is that the FTP is behind a router.

How can I get the Passive Transfer to work?

Internal IP : 192.168.0.1 (only 1 Network Card)
The Router has the external IP : 213.100.*
And the port is set to : 9127

I opened the Port 9127 on the Router.
But still Passive is not working, Active is working but not that good.

With Active I get regularly :
426 Connection closed: Only one usage of each socket address (protocol/network address/port)
is normally permitted.

Any help?
Mavke is offline   Reply With Quote
Old 10-18-2003, 06:38 AM   #2
Jog
Member
ioFTPD Foundation User
 
Join Date: Jul 2003
Posts: 83
Default

i saw this message since 5.1.8 version ...

i resolved disconnecting from the ftp and reconnecting .. but sometimes is very annoyng!
Jog is offline   Reply With Quote
Old 10-18-2003, 06:58 AM   #3
Mavke
Member
 
Join Date: Jun 2003
Posts: 51
Default

My issue is that I want to get the "PASSIVE" Mode to work...
Mavke is offline   Reply With Quote
Old 10-18-2003, 07:10 AM   #4
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

I could see such error happening, when range of passive mode ports is too small. Reserve atleast 50ports per user online.. more = better
darkone is offline   Reply With Quote
Old 10-18-2003, 07:34 AM   #5
Mavke
Member
 
Join Date: Jun 2003
Posts: 51
Default

D1 Thanks, but how do I get the "PASSIVE" Mode working?
As that is what I am looking for...
Mavke is offline   Reply With Quote
Old 10-18-2003, 07:52 AM   #6
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Ahh.. problems you encountered were with active mode Reason for those errors is badly configured receiving host (using very limited amount of ports to receive...) Anyways, nat should be configured as following:

[Nat]
Host = <internet ip/hostname> (213.x.x.x)
Ports = <from>-<to>
Bind = <local ip> (192.168.0.2)


[Ftp-service]
Device = Nat
Port = <siteport>


Forward port <siteport> and ports <from>-<to> from router to site.
darkone is offline   Reply With Quote
Old 10-18-2003, 07:53 AM   #7
Guardian
Senior Member
 
Join Date: May 2003
Posts: 131
Default

In devices setup...

Host = ur external IP
Ports = ur passive/data ports (u have to open them also in ur router ... 1024-1059 fe, depends on how many users u want simultan on ur ftp)
Guardian is offline   Reply With Quote
Old 10-18-2003, 01:46 PM   #8
megauser
Junior Member
ioFTPD Foundation User
 
Join Date: Nov 2002
Posts: 17
Cool passive

This is true with all NAT or Firewalled servers.. I have mine on an outside address, but still have to open ports because we're running a Firewall on that box as well.. to prevent little kiddies Packet crap, its annoying to have to do, but will save your bacon in the long run.
megauser is offline   Reply With Quote
Old 10-19-2003, 02:49 AM   #9
Mavke
Member
 
Join Date: Jun 2003
Posts: 51
Talking

Thanks to all for helping.
I got is working now with the suggestions for D1 and the others!

THANKS!!!
Mavke is offline   Reply With Quote
Reply

Tags
5.1.14, ftp, ioftpd, passive, router

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
View panes messed up ftpscanner General Discussion 3 11-08-2004 06:42 PM


All times are GMT -5. The time now is 06:21 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)