Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 08-27-2003, 11:18 AM   #1
bleef
Junior Member
 
Join Date: Aug 2003
Posts: 4
Default only master can see directories - new users see nothing

OK I have one user with +1MTH flags. I add grp "TEST" successfully. Then I "gadduser TEST test test *@*" sucessfully.

When he logs in, the default directory is blank, however he can access the directories manually.

257 "/" is current directory.
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (128,125,171,119,5,141)
LIST -al
150 Opening ASCII mode data connection for directory listing.
226- [Ul: 0.0MB] [Dl: 0.0MB] [Speed: 0.0K/s] [Free: 6839MB]
226 [Section: Default] [Credits: 0.0MB] [Ratio: 1:3]
List Complete: 0 bytes in 1.24 (1.00 KBps)

So he logs in fine, but only sees "/" - doesn't see any directories ie. /UPLOADS.
I have to manually type in the field to change to /UPLOADS and hit enter.

CWD /UPLOADS
250 CWD command successful.
PWD
257 "/UPLOADS/" is current directory.
PASV
227 Entering Passive Mode (128,125,171,119,5,20)
LIST -al
150 Opening ASCII mode data connection for directory listing.
226- [Ul: 0.0MB] [Dl: 0.0MB] [Speed: 43.1K/s] [Free: 6839MB]
226 [Section: Default] [Credits: 0.0MB] [Ratio: 1:3]
List Complete: 133 bytes in 1.20 (0.11 KBps)


If I change the dir to /Uploads it can access the directory just fine. Why can't it see the directories (vfs) in root ???

- my default.vfs and admin.vfs are exactly the same.
- the user has VFSFILE ..\etc\default.vfs in his group file.
- the attributes for ALL directories is 777.

My guess would be it has something to do with file owner, but with 777 perms, wtf ???
bleef is offline   Reply With Quote
Old 08-27-2003, 11:27 AM   #2
Mave_2
Member
 
Join Date: May 2003
Posts: 33
Smile rehash

Did you try rehash config and save config? after made those changes
or try to restart io
I did have the same issue and that worked for me
Mave_2 is offline   Reply With Quote
Old 08-27-2003, 11:31 AM   #3
bleef
Junior Member
 
Join Date: Aug 2003
Posts: 4
Default lol nope

hehe I had rehashed and restarted, but didn't save. So I

site config rehash
site config save

then shutdown the baby
and started her back up....


still didn't work :)

Thanks for the reply though!
bleef is offline   Reply With Quote
Old 08-27-2003, 11:36 AM   #4
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

Had same problem once. Turned out the HD was all mixed up.

A "chkdsk /f e:" fixed it.

Worth a try.
Mouton is offline   Reply With Quote
Old 08-27-2003, 11:44 AM   #5
bleef
Junior Member
 
Join Date: Aug 2003
Posts: 4
Default nope hehe

Drive appears to be perfect.


I'm thinking it has to do with something external to the vfs, grp, and user files because I just reinstalled it but saved the vfs, the ini, and the \sfv checker. A clean install shouldn't have this problem so could it somehow be related to something I did in the ioftpd.ini or the sfv checker ini?

thanks for the replies.
bleef is offline   Reply With Quote
Old 08-27-2003, 04:09 PM   #6
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default Re: lol nope

Quote:
Originally posted by bleef
hehe I had rehashed and restarted, but didn't save. So I

site config rehash
site config save

then shutdown the baby
and started her back up....


still didn't work

Thanks for the reply though!

SITE CHMOD 755 /
darkone is offline   Reply With Quote
Old 08-28-2003, 10:52 AM   #7
bleef
Junior Member
 
Join Date: Aug 2003
Posts: 4
Default of course

I knew it had to be my dumbass not realizing something that simple. BTW I've asked around and many peeps have had the same problem - and "can't remember what they did to fix it."

...I'd keep this thread handy.

Thanks a lot man.
bleef is offline   Reply With Quote
Old 10-17-2003, 05:02 AM   #8
cpas
Junior Member
 
Join Date: Sep 2003
Posts: 21
Default

site chmod 755 /
site chattr -h /


Have a nice day
cpas is offline   Reply With Quote
Reply

Tags
/uploads, 0.0mb], directories, directory, list

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to change F8 to something else? Gary King General Discussion 1 11-10-2004 07:03 PM
New Cookies darkone Suggestions 6 01-22-2003 09:06 AM


All times are GMT -5. The time now is 08:10 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)