Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rating: Thread Rating: 5 votes, 4.40 average. Display Modes
Old 06-17-2011, 02:57 AM   #61
mr.babek
Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jul 2005
Posts: 82
Thumbs up

Yil, I just want to tell you again how much I appreciate your work on IOftpd and I think its really amazing than you can manage and code the whole project by yourself.
Kudos
__________________
Current setup:

MS Windows Storage Server 2012R2, ioFTPD 7.7.3, ioNinja, nxTools
mr.babek is offline   Reply With Quote
Old 06-21-2011, 02:45 AM   #62
Dahlia
Member
 
Join Date: Sep 2008
Posts: 33
Default

Well i did update on my server from 'old' v7.0.1 to new version 7.7.2 and i couldnt even start ioFTPD :). I was getting this error: CreateProcess(ioFTPD) failed with error 14001

"running ioFTPD 6.x-7.0.1 on windows 2003 SP2 -probably without any other updates- for years"
Anyway after 1-2h of updating from m$ i could finally start the last version. What exactly ioFTPD need, last updated ms_netframework ?
Dahlia is offline   Reply With Quote
Old 06-21-2011, 05:13 PM   #63
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

ioFTPD back in v7.3.0 changed over to dynamically linked runtime libraries to see if that made a difference in stability. It now requires the VS2008 SP1 runtime be installed which is by default in win7 and possibly vista as well, but not XP/2003. Lots of apps install this as part of their installation, but without a real installer for ioFTPD the best I could do was note the error you'll see in the README and the Changelog file along with a link on how to get it.

Looking up windows error 14001 gives 'The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tools for more detail.'

That's the dynamically linked SxS runtime library having an issue. Not sure if it was because it wasn't installed or you had a version mismatch but looks like you figured it out. It isn't the error I expected you to get if it wasn't installed though.
Yil is offline   Reply With Quote
Old 06-22-2011, 06:18 AM   #64
Dahlia
Member
 
Join Date: Sep 2008
Posts: 33
Default

Ah yea its my bad sorry. I've read the change log but just too many new features and i skip this one line with 'important: VB2008 sp1 required from now on' :-)

Anyway, i asked long time ago about setting up a timezone in ioftpd config. Since im not so good in explanations i made a simple screen. Where you can see the date of dir which i created in ioFTPd (so the date which all users see thru their client) and 'real' date/time of server and date/time details in totalcommander and in attribute manager
http://img52.imageshack.us/img52/5679/timezone.png
- 1600x900 resolution

Question is: why ioFTPD showing different time (doesn't matter what client i choose) and is it possible to add the timezone option ? Did the same test on friends glFTP daemon and date is everywhere same (correct).
Dahlia is offline   Reply With Quote
Old 06-22-2011, 12:34 PM   #65
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

ALL times in the server are UTC (GMT) times and are unconverted as I believe is the case with glftpd as well. Many commands like MDTM even formally require that.

However, CLIENTS often convert server times into local times as does windows explorer and most software showing times to the user. In flash open up the site manager, and check the timezone option for the site. I think it defaults to "attempt to discover". Set it to UTC, or Use Server Time and see what that does. Oh, also check out the RAW directory listing in Flash from the Directory menu to see what the server is actually returning.
Yil is offline   Reply With Quote
Old 06-25-2011, 05:28 PM   #66
Dahlia
Member
 
Join Date: Sep 2008
Posts: 33
Default

Maybe ur right. Just saying what i see. Don't know how the mechanic in such programs work. glFTPd using some 'timezone fix'. Can't force users to 'change' any timezone settings in their clients when its working somwhere else.

Whatever i tried to change it in other client - ftprush (since in flashfxp i could not find such option), but its same as everywhere. In client i see always UTC(GMT), but raw directory listing or any filemanager shows 'server' time (in my case GMT-2).

Well since it looks like i'm the only one who cares about some 'time' thingies, forget it.

Sorry for disturbing. You doing great job.
Dahlia is offline   Reply With Quote
Old 06-26-2011, 02:36 AM   #67
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

Quote:
Originally Posted by Dahlia View Post

Whatever i tried to change it in other client - ftprush (since in flashfxp i could not find such option), but its same as everywhere. In client i see always UTC(GMT), but raw directory listing or any filemanager shows 'server' time (in my case GMT-2).
Try looking under

Sites
Site manager
Your site

You will find it at the bottom of the list
ArtX is offline   Reply With Quote
Old 06-28-2011, 03:45 PM   #68
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

I have a problem with nxmydb and version 772. I keep getting 'Invalid password' using the same nxmydb setup as in 757.

I can't see anything in particular in the logs, except for a SyncTimer error. There is no trace of 'invalid login' in the log anywhere

This is all the log I'm getting:

nxmydb.log

06-28-2011 22:32:31 ------------------------------------------------------------
06-28-2011 22:32:31 SetUuid - Server lock UUID is "abc".
06-28-2011 22:32:32 ConnectionOpen - Connected to nxdb.host via TCP/IP [nxMyDB_Server0], running MySQL Server v5.1.32-community-log.
06-28-2011 22:32:32 DbInit - nxMyDB v2.1.1 loaded, using MySQL Client Library v5.0.51a.
06-28-2011 22:33:03 SyncGetTime - Unable to fetch results:
06-28-2011 22:33:03 DbMapError - Unmapped MySQL result error 0.
06-28-2011 22:33:03 SyncTimer - Unable to retrieve server timestamp (error 1).

ioftpd.log

06-28-2011 22:35:37 SSL: "Found certificate" "name=xxx" "Service=FTP_Service" "(Certificate_name)"
06-28-2011 22:35:37 START: "PID=2128" "CmdLine="
06-28-2011 22:35:37 PRELOAD: "begin" "..\etc\default.vfs"
06-28-2011 22:35:37 PRELOAD: "points=25" "..\etc\default.vfs"

Ideas on what might be wrong here?

Is there any plans to put the io code up on github or something? Would be handy for future in place upgrades, as well as source tracking
pion is offline   Reply With Quote
Old 06-28-2011, 08:01 PM   #69
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

pion: From what I can tell nxMyDB failed to connect or read the userfiles from the database so the reason you aren't seeing any login failures is because none of the people trying to login have accounts as far as ioFTPD is concerned.

Is it possible that the new version can't connect because of a firewall that's treating the new .exe differently?

There honestly weren't that many changes between 7.5.7 and 7.7.2, and the only one that springs to mind that might be important is the OnServerStart event change. Can you first make sure this is in the .ini file and didn't get lost in the upgrade? The change is actually a feature I thought useful to nxMyDB (it's even mentioned in the ChangeLog) but perhaps I missed some interaction.

Update: I just check the nxMyDB source and the SyncGetTime error being reported is just trying to ask the database what time it is and it's failing... Whatever the problem is it isn't related to userfiles, but connectivity and/or permissions.
Yil is offline   Reply With Quote
Old 06-30-2011, 02:02 AM   #70
pion
Senior Member
 
Join Date: Feb 2006
Posts: 138
Default

Turns out the fault was entirely my own

I was missing the libmysql.dll from the system directory in my migration to 772
pion is offline   Reply With Quote
Old 07-07-2011, 05:27 AM   #71
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

man, i Wish that dude @tuff were still active zs scripter. His works were pure php based. Surely ioFTPd is stable ready for some seriuos addons.
Flow is offline   Reply With Quote
Old 07-18-2011, 10:22 PM   #72
mr-b
Junior Member
 
Join Date: Mar 2004
Posts: 20
Default

Yil, Thanks for your hard work on keeping ioFTPD up to date. I just want to confirm that I upgraded from 7.7.1 to 7.7.2 today and I am happy to report all is working well.
mr-b is offline   Reply With Quote
Old 07-21-2011, 03:04 PM   #73
paja1
Member
ioFTPD Registered User
 
Join Date: Jul 2005
Posts: 43
Default

Hi Yil,
i found an error in 7.7.2, if i use NTFS SYMLINKs, and methods SYMLINK or SHARE, i'm not able to delete any file, always just error "500 - .. No such file or directory.".
If i switch back to "IGNORE" (old way), directory cache will be not updates as before, but i'll be able to delete any file i want.

Please can you check it out?

Thanks for all your work!
paja1 is offline   Reply With Quote
Old 07-21-2011, 09:21 PM   #74
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

paja1: Hmm, I can confirm that manual deletion of a NTFS directory junction as a file delete isn't being handled correctly under SYMLINK mode. FlashFXP issues a FILE delete command which is correct since it treats symbolic links as a file, but ioFTPD is only testing to see if it's an ioFTPD symbolic link and not a NTFS junction when deciding to turn the file deletion into a directory deletion at the filesystem level. Thus it tries to delete a file but it's really a directory and it fails. However, in this situation I get a permission denied and not a file not found error......

However, I think you are experiencing a different problem. Can you see if the default 'VFS_Exported_Paths_Only = True' is set? If this is true then you cannot have the target of any directory link be outside of normally exported directories. Examples .vfs:
c:\site /
d:\Games /Games

A link like c:\site\Latest\Game1 -> d:\Games\Game1 would be OK because the target dir is also visible in the .vfs file, but c:\site\Bad -> c:\windows would not because the windows dir isn't exported.

This is a safety feature. However, you can try turning it off to see if it makes a difference in the problem you are seeing. Also, can you double check the target of the link?
Yil is offline   Reply With Quote
Old 07-22-2011, 02:33 AM   #75
paja1
Member
ioFTPD Registered User
 
Join Date: Jul 2005
Posts: 43
Default

Hi Yil,
thanks you for your answer.
I do have a folder /FOO/ and only symlinks below (as replacement of VFS merge becouse you cant upload or change anything within next lines in vfs file).
So imagine this situation:
/FOO/FOLDER1/subfolder2/file1.ext

FOO = real folder mapped in VFS file
FOLDER1 = SYMLINK to a different drive (which is not accessible via any other normal VFS path!)
subfolder1 = real folder in linked folder (different drive)
file1.ext = real file in subfolder1.ext

Now, the strange is that i'm able to delete empty folders or ioFTPD's links, but not a files!

Yes, i do have "VFS_Exported_Paths_Only = True" set as you described.

So i tried to switch it to "VFS_Exported_Paths_Only = False" in SHARE mode nothing changed... in SYMLINK mode.. still the same. I'm notable to delete any file.

In addition if i switch VFS_Exported_Paths_Only to False, all my iTCL sripts are not able to access or see any file or folder behind NTFS SYMLINK.

Any idea?

Thx

Last edited by paja1; 07-22-2011 at 02:42 AM.
paja1 is offline   Reply With Quote
Reply

Tags
bug, code, directory, release, user

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:08 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)