Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 06-30-2007, 03:36 PM   #1
AssassiNBG
Junior Member
 
Join Date: Jun 2007
Posts: 4
Default Need help with upload permission.

So I created a user, but one can't upload when logged in with that user.

The folder is chmod 777 and my ioFTPD.ini looks like this (nothing changed):
Quote:
# Detailed permissions for directories
#
# priviledge = <virtual path> <rights>
#
Upload = * *
Resume = * *
Download = * *
MakeDir = * *
RemoveOwnDir = * *
RemoveDir = * 1VM
Rename = * 1VM
RenameOwn = * *
Overwrite = * 1VM
Delete = * 1VM
DeleteOwn = * *
NoStats = * =lSpeed !*
Also for some strange reason when you log in with that user I don't see a file that's supposed to be there. I haven't changed the flags of the user, and they're '3' by default.

I know I'm missing something obvious here, I'm just too tired to go through the documentation again. I'd really appreciate it if someone could just let me know what I'm forgetting.

Thank you!
AssassiNBG is offline   Reply With Quote
Old 07-01-2007, 05:51 AM   #2
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

# This defines everything else as Read Only for regular users.
Upload = /* 13VM
Resume = /* 13VM
MakeDir = /* 13VM
RemoveOwnDir = /* 13VM
RemoveDir = /* 1VM
Rename = /* 1VM
RenameOwn = /* 13VM
Delete = /* 1VM
DeleteOwn = /* 13VM


is how i have mine set out - near enough deafult settings really and it works fine
ArtX is offline   Reply With Quote
Old 07-01-2007, 06:26 AM   #3
AssassiNBG
Junior Member
 
Join Date: Jun 2007
Posts: 4
Default

Hello,

That doesn't really solve my problem, which is that I'd like to be able to upload with a regular user. I can't give out the master account login to anyone who would like to put something on the ftp.

I really don't understand what could the problem be, permissions Upload = * * means for any status in any virtual path uploading is enabled, right?

Then what's the problem? The folder is chmod 777 (writable), user doesn't have +f (fxp upload denied) either.
AssassiNBG is offline   Reply With Quote
Old 07-01-2007, 01:28 PM   #4
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

with mine you dont have to give master account to anyone - it just shows that M can do everything where as anyone with 3 can upload make and delete their own folders and files and no one elses

have you checked that its not a script causing the error - if you have any scripts loaded that is
ArtX is offline   Reply With Quote
Old 07-02-2007, 03:53 PM   #5
AssassiNBG
Junior Member
 
Join Date: Jun 2007
Posts: 4
Default

Ok, I tried adding those before the settings I currently have, and it didn't work. I even tried replacing those with the lines in my file but still no use.

By the way, I have no scripts loaded. It's the basic setup.
AssassiNBG is offline   Reply With Quote
Old 07-03-2007, 12:56 AM   #6
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

An error msg could help. What does ioftpd say when you try to upload with a regular user?

/ZR
Zer0Racer is offline   Reply With Quote
Old 07-15-2007, 05:23 PM   #7
AssassiNBG
Junior Member
 
Join Date: Jun 2007
Posts: 4
Default

The Error.log file doesn't register this error, while FlashFXP gives out a 550 ***: Permission denied. Transfer failed!
AssassiNBG is offline   Reply With Quote
Old 07-15-2007, 09:07 PM   #8
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Several things to keep an eye on.

1) Can the master account create a file in the directory? If you give the user the M flag for a second can they also create a file? If so then it isn't an NTFS permission issue.

2) Do the user and master account use the same VFS file? If so then it probably isn't a vfs file issue. [NOTE: I think ioGUI has trouble creating a new user with a non-default .vfs file, you need to create the user using the default then edit the vfs field after creation].

3) Does the user have permission via ioftpd.ini file? I.e. "Upload /* 31VM". As pointed out above the order of the matching entry matters.

4) Does the virtual filesystem grant permission? I.e. "site chmod 777 ." on the directory fix it?

That's pretty much the checklist... You wrote "Also for some strange reason when you log in with that user I don't see a file that's supposed to be there." One case where this happens is when you have a real directory being obscured by a virtual directory. I.e. c:\site is \ and a c:\site\Incoming directory exists and in one VFS you mount d:\myftp\Incoming onto /Incoming. One user will see the D drive incoming and the other the C one... Or if you're using different .vfs files mounting different dirs especially if one is misspelled! Take a look at your vfs files...
Yil is offline   Reply With Quote
Reply

Tags
1vm, changed, download, upload, user

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:45 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)