Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-07-2007, 05:57 AM   #1
PlaN3t
Member
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 43
Exclamation Problem with SSL and TLS .. upload crash

hi
i have this problem

someone can help me ?


[i] ppv7-mvm.r37 47,7 Mbytes/01:54(s)/439,86Kbps
[1] PRET RETR ppv7-mvm.r36
[1] 200 OK, will use *****-5 for upcoming transfer
[1] CPSV
[1] 227 Entering Passive Mode (****************).
[2] PORT ****************
[2] 200 PORT command successful.
[2] STOR ppv7-mvm.r36
[2] 150 Opening BINARY mode data connection for ppv7-mvm.r36.
[1] RETR ppv7-mvm.r36
[1] 150 File status okay; about to open data connection from *****-5.
[1] 426- Connection reset by peer: socket write error
[1] 426 Connection reset by peer: socket write error



i have make the certificate with this command

C:\ioFTPD\makecert.exe -r -n "CN=SITE" -b 01/10/2006 -e 01/10/2016 -eku 1.3.6.1.5.5.7.3.1 -ss my -sr CurrentUser -a md5 -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12 C:\ioFTPD\ioftpd.cer


is correct ?

thanks all
PlaN3t is offline   Reply With Quote
Old 05-07-2007, 11:41 AM   #2
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

make this a .bat file and execute:

cd \cert
makecert.exe -r -n "CN=ioFTPD" -b 05/07/2007 -e 01/01/2100 -eku 1.3.6.1.5.5.7.3.1 -ss my -sr CurrentUser -a md5 -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12 C:\ioFTPD\ioFTPD.cer

Then goto your C:\ioFTPD\ioFTPD.cer file and dubble click on it (Open it, and choose install)

in ioFTPD.ini search for;

#
# >>>>>>>>>>>> SSL CHANGE THIS <<<<<<<<<<<<<<
#
# After you have created your certificate, change this to the name you used
# which should be your dynamic DNS name, your fixed external IP address, or
# if you have neither of those a made up descriptive name for you server.
# Since all locally generated certificates will report as being unverified
# you might as well get rid of clients also complaining your cert name doesn't
# match your DNS name or IP address.
Certificate_Name = ioFTPD

When you changed that to according, restart iOFTPD, try login again.

Hope this give you a hint.
Flow is offline   Reply With Quote
Old 05-14-2007, 01:34 PM   #3
PlaN3t
Member
ioFTPD Foundation User
 
Join Date: Mar 2005
Posts: 43
Default

always same problem

[2] 426 Connection closed: The network connection was aborted by the local system.
[2] 226 ABOR command successful.


sometime crash upload and download watch.. i cant kick the user need only to restart..



PlaN3t is offline   Reply With Quote
Old 09-06-2007, 03:35 PM   #4
John.H
Junior Member
 
Join Date: Sep 2007
Posts: 1
Default

Quote:
Originally Posted by Flow View Post
make this a .bat file and execute:

cd \cert
makecert.exe -r -n "CN=ioFTPD" -b 05/07/2007 -e 01/01/2100 -eku 1.3.6.1.5.5.7.3.1 -ss my -sr CurrentUser -a md5 -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12 C:\ioFTPD\ioFTPD.cer

Then goto your C:\ioFTPD\ioFTPD.cer file and dubble click on it (Open it, and choose install)

in ioFTPD.ini search for;

#
# >>>>>>>>>>>> SSL CHANGE THIS <<<<<<<<<<<<<<
#
# After you have created your certificate, change this to the name you used
# which should be your dynamic DNS name, your fixed external IP address, or
# if you have neither of those a made up descriptive name for you server.
# Since all locally generated certificates will report as being unverified
# you might as well get rid of clients also complaining your cert name doesn't
# match your DNS name or IP address.
Certificate_Name = ioFTPD

When you changed that to according, restart iOFTPD, try login again.

Hope this give you a hint.

hello.

i am new in using ioftpd. everytime when try to install ssl i got this error:

[R] 200-Error: Invalid issuer store location

maybe somebody can help me.

thanks for your help.

regards john.h
John.H is offline   Reply With Quote
Old 09-24-2007, 06:22 AM   #5
panzerfaust
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 112
Default

@ John.H: i'd say you got problems with your vfs then
panzerfaust is offline   Reply With Quote
Old 09-24-2007, 06:10 PM   #6
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

plan3t: First off it looks like you can login fine. Assuming this was done via SSL/TLS this proves the cert is somewhat OK. Second, it looks like you are FXPing which introduces a bunch of other variables.

You obscured the IP addresses (which is good) but I just want to make sure they are actually valid and not 192.168.1.x or something else which is clearly incorrect and happens ALL THE TIME when people don't setup the HOST= option in ioftpd.ini and are behind NAT firewalls... When you say crash and then say you can't kick the user I'm a bit confused. The connection may be dropped, and/or the user stuck logged in or something but ioftpd didn't crash and completely exit.

John H: Error: Invalid issuer store location - that sounds like the cert isn't installed into the proper location or something else is wrong with it. Download certmgr.exe which should come with makecert.exe from MS (you'll need to search a bit as I'm not sure its released outside of the platform download now) so you can examine the certificate store...

Makecert in my experience makes AND installs the certificate. You don't need to click on the .cer file and install it.
Yil is offline   Reply With Quote
Reply

Tags
connection, ppv7-mvm.r36, upload, [1], [2]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:18 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)