Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 05-07-2007, 01:17 AM   #46
rolan
Member
 
Join Date: Jul 2006
Posts: 72
Default

i set it (6.1.3):
Compute_CRC = True

i upload a sfv file, but never happened,how can i do it work fine? thx all.
rolan is offline  
Old 05-07-2007, 03:02 AM   #47
Flow
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Flow's Avatar
 
Join Date: Dec 2001
Posts: 306
Default

# Set this to false if you don't have an onUploadComplete event or the
# script/executable you are using ignores the computed value.
Compute_CRC = True

Do you have a zipscript or anything under the [Events] ??

[Events]
# NOTE: You can list more than one event and all will be called.
;OnUploadComplete =
;OnUploadError =
Flow is offline  
Old 05-07-2007, 04:25 PM   #48
Nasq
Junior Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 8
Default

Installed 6.1.3 and everything is looking fine so far. A few remarks:

README file:

edit the files etc\default.vfs and etc\admin.vfs to configure the virtual
file system. -> There is no etc/admin.vfs

by default, both of these files
are configured to use ..\site as the "/" directory for ioFTPD. this
directory contains a basic site layout to start from.
-> only one file which is configured to C:\ioFTPD\FTP-ROOT-DIR

ip address
127.0.0.1 port 9999 -> port 5420

in the basic configuration, you just need to uncomment one line
to permit incoming connections. -> untrue


ioFTPD.ini:
MessageCache_Size = 1000 # Number of .message files to cache
# (min 10, default 100)
-> default = 1000 ?

Under NETWORK: What does (10), (1800) and (5) stand for?



It seems that site chmod changes doesn't show directly sometimes, even though it is registered. Looks like a directory caching thing.
Nasq is offline  
Old 05-07-2007, 05:55 PM   #49
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Nasq: The README file is actually a relic from the 5.x builds but it contains the instructions on how to install SSL certs. I probably should just remove the non-SSL parts and rename it SSL-config or something. The README-FIRST file is the one I wrote and contains the real instructions to follow. Now that both README's are in the same directory with the 6.1.x builds I can see where that might be confusing to a new user


Numbers in parens from ioFTPD.ini are the defaults for unspecified values taken from the source code itself. They are just for reference.

site chmod: Are you refreshing the directory listing in your FTP client? If on a new listing the change isn't showing up but does show up if you create a directory or make some other modification then the internal ioFTPD cache is stale and that's a bug... If you confirm it what is the No_SubDir_Sizing option set to in your config file?


rolan: The crc option only computes the crc and passes it to scripts. It's the job of whatever zipscript you choose to run to verify files and take action.
Yil is offline  
Old 05-07-2007, 08:59 PM   #50
rolan
Member
 
Join Date: Jul 2006
Posts: 72
Default

thx Yil and Flow,its works for ioSFV2.0beta1.55.
rolan is offline  
Old 05-08-2007, 12:47 AM   #51
Nasq
Junior Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 8
Default

Yes I refresh the directory listing and making a directory doesn't trigger an update either. I have No_SubDir_Sizing = True
Nasq is offline  
Old 05-08-2007, 04:38 PM   #52
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

Yil, a bug with the new tcl crc command

As you know im using this in ioSFV, the new 1.55 beta, anyhow heres the scenario.

If you have a release which has a bad file, ie. that aint complete, and i use the site rescan
command, the new crc command works fine for the valid/passed crc files, but once it
reaches the failed file, if my ioSFV settings tell the zs to delete the failed file, ioSFV
attempts to delete the file

this is where the problem occurs, ioSFV cant delete the file, and you cant physically delete
the file from io yourself, you end up getting the following error

[2] DELE test-test12.r81
[2] 550 test-test12.r81: No such file or directory.

You can delete it from windows, or when you shutdown io, restart it, the file will be gone
__________________
#iotools #ioftpd (both on efnet)
tuff is offline  
Old 05-08-2007, 04:59 PM   #53
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

actually Yil,

ive done some more testing, and this bug is not only effecting incomplete files, it also causing
problems with complete/crc passed files!

you can no longer delete a complete release that has been rescanned, ie, once you use the crc itcl command on a file, its locked, be it passed, faileded etc.

it doesnt seem to be closing the files once it computes the crc

this needs fixed asap!
__________________
#iotools #ioftpd (both on efnet)
tuff is offline  
Old 05-08-2007, 05:01 PM   #54
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Updated entry: Yup, I forgot to close a file handle for the tcl version of the command. The new code to handle uploaded files is fine.

New version coming real soon.
Yil is offline  
Old 05-08-2007, 05:23 PM   #55
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default v6.1.4

Fixed crc command:

ioFTPD-v6.1.4.zip

Code:
v6.1.4 Release Notes:

1) Merged the original README file and my README-FIRST file and updated
   the links slightly to indicate the forum as the place to look for help.

2) Fixed the crc32 itcl command not closing file handles.
Yil is offline  
Old 05-08-2007, 06:36 PM   #56
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Nice =)

/ZR
Zer0Racer is offline  
Old 05-09-2007, 12:25 AM   #57
l.d.m
Member
 
Join Date: Feb 2007
Posts: 31
Default

hi Yil!
I have got a problem with rename command:

Quote:
[R] MKD A
[R] 257 "A" created.
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] PASV
[R] 227 Entering Passive Mode (192,168,1,3,21,66)
[R] Opening data connection IP: 192.168.1.3 PORT: 5442
[R] LIST -al
[R] 150 Opening ASCII mode data connection for directory listing.
[R] List Complete: 466 bytes in 0,19 seconds (2,4 KB/s)
[R] RNFR A
[R] 350 Directory exists, ready for destination name.
[R] RNTO B
[R] 550 B: No such file or directory.
Rename Failure!

(ioFTPD 6.1.4, clean install, no scripts, Windows Server 2003)
l.d.m is offline  
Old 05-09-2007, 01:44 AM   #58
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

l.d.m: The most likely cause is real filesystem permissions. Running as the same user as ioFTPD can you rename the directory in windows? I run ioFTPD under a limited rights account and sometimes I forget to set the permissions on files/directories I move into the VFS and I see the same thing.

The other possibility (highlighted by tuff's issue with the itcl crc) is that the error reason isn't always accurate. If someone is under the directory tree transferring a file, etc windows may prevent any renaming of parent directories. Try the command when the server doesn't have anyone online and see if that makes a difference.
Yil is offline  
Old 05-09-2007, 02:27 AM   #59
l.d.m
Member
 
Join Date: Feb 2007
Posts: 31
Default

I found my error

I set relative path in my \etc\default.vfs:
"..\FTP-ROOT-DIR\" /

now I set full path and no more rename problems
l.d.m is offline  
Old 05-09-2007, 02:55 AM   #60
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Quote:
Originally Posted by l.d.m
I found my error

I set relative path in my \etc\default.vfs:
"..\FTP-ROOT-DIR\" /

now I set full path and no more rename problems
I can confirm this. Though I don't think you're supposed to use that trailing backslash in vfs files. Anyhow, I tried a clean 6.1.4 install, with minor changes, and had root set to "..\site" / which gave me the same error on RNTO for dirs. Changing the root to "c:\ioftpd\site" / made the problem go away.

Imo setting the root to a relative path should work. ioFTPD.ini is full of relative paths. Also handy for easier use if someone wants to install their ioFTPD on another drive than C:\. And the fact that RNFR finds the directory and is ready for the new name but RNTO fails.

/ZR

P.S. Renaming files works just fine if root is set to a relative path. D.S.
Zer0Racer is offline  
Closed Thread

Tags
download, fxp, news, release, support

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:22 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)