Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 04-02-2007, 02:56 PM   #46
panzerfaust
Senior Member
ioFTPD Foundation User
 
Join Date: Jun 2003
Posts: 112
Default

but then again, ioB is an all-in-one solution, except that it needs ioA ofc
panzerfaust is offline  
Old 04-02-2007, 03:16 PM   #47
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Carpo: Site shutdown issue, got it. Not sure why I didn't see it before but I do now. This is further proof that ioFTPD never knew how to gracefully exit as I haven't changed anything related to that thread except to skip even giving it work in some cases. Either way, I'll get that fixed in a jiffy. It's a shutdown only issue though, shouldn't effect normal operations.

Flow: ZR I think answered your question. You need to enable Secure Site to Site in FlashFXP if your going to use "Require_Encrypted_Data = !-sitebot *" FlashFXP I think always checks for FEAT command and will see that 6.0 supports SSCN which should mean that it can talk to any other FTP server. I've tried it with ioFTPD/raiden/serv-u and it worked without having to do anything.

ZR: HP_FUNCTION(io_group_list_seek) is indeed missing. I guess you're the first person to EVER try that function hehe. Added, and bonus points for providing the solution!

oldhouse: Idle_Ignore is broken for all but single word uppercase commands. Yup, I goofed up and was checking the original command line instead of just the looked up command name. Thus Idle_Ignore = NOOP PWD would work but CWD because it's sent as "CWD ." wouldn't match and would reset the counter because it is a valid command. Fixed.

LordM: going to need a bunch more data to help you... just not enough to go on there.

peep: OnServerStart appears to be working for me.
OnServerStart = EXEC ..\scripts\args.exe
pops up a window. I did use just EXE the first time though so perhaps it's a simple typo for you as well...

Tuff: I haven't "found" the TCL issue yet, but I know where to look. The change is actually because I updated the lib/tcl directory. I couldn't believe reverting the .dll wouldn't fix things after I looked at the code again until I realized the library changed as well. I included all the good stuff a normal TCL install has but I don't think that has anything to do with it. Temp fix is just to revert your lib dir as well.

oldhouse: Verified. You cannot set permissions of a drive root (i.e. d:\). I'll get this fixed for you. For right now you don't have to change the default permissions, just create a subdirectory on the drive, move the files in there, and mount that instead. Did I mention that I think mounting raw drives is a bad idea

FTPServerTools: Not anytime real soon, I need to create a sourceforge account and all that stuff. In a few days I'll put out the source as a zip file. I was hoping to include the tcl/php build instructions, and various other tweaks into the distribution so it would be point and click compile for people. Right now, I'm juggling debug/optimized libraries/etc and my test environment is my real environment so I want to split that apart

Mave: Perhaps after things settle down on the credit thingy. Typo fixed.

Expect a new version later today.

-Yil
Yil is offline  
Old 04-02-2007, 03:21 PM   #48
peep
Senior Member
FlashFXP Scripter
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 132
Exclamation

I haven't been able to pin it down yet but I seem to be getting random io-crashes for no apparent reason (not logged in, might be the eggdrop tho). io won't even restart even tho running as service. I'll disable all the scripts and see if this still is the case.

Running io v6.0.1 as service w/ ssl, ioA and ioBv2. I guess this is most likely a script problem but I'll try to hunt down that command that yields the crash.

Code:
Unhandled exception 3221225477 at address 0x0040269f (0x00000000)
0x00000000 0xa0023f65 
Unhandled exception 3221225477 at address 0x7c92ae22 (0x00000000)
0x00000000 0x00000000

Last edited by peep; 04-02-2007 at 03:47 PM.
peep is offline  
Old 04-02-2007, 03:39 PM   #49
en3rmax
Junior Member
 
Join Date: Jul 2005
Posts: 27
Default

Quote:
Originally Posted by Zer0Racer View Post
Usually this question would be answered with "read docs and knowledge base" but for 6.0.x it could be the "new" VFS settings/examples in ioFTPD.ini. Don't know if you installed a clean new io 6.0.x or upgraded from 5.8.x. If it's a new install you could replace the settings under [VFS] and ### PERMISSONS ### (not the stuff you pasted) with this (from 5.8.5):
Code:
Upload    = * *
Resume    = * *
Download   = * *
MakeDir       = * *
RemoveOwnDir  = * *
RemoveDir     = * 1VM
Rename    = * 1VM
RenameOwn     = * *
Overwrite     = * 1VM
Delete    = * 1VM
DeleteOwn   = * *
NoStats       = * !*
And then you need to use site chmod 777 once on every directory you want to make available for uploads by regular users.

You could also simply create a dir in FTP-ROOT-DIR called Incoming to match the settings in ioFTPD.ini for 6.0.x. See documentation and kb for more info.
/ZR

thanks for the quick reply Zer0Racer, i am using a fresh install of 6.0.1 my old install seems to work fine

i changed the info in ### PERMISSIONS ### to

Code:
Upload          = * *
Resume		= * *
Download	= * *
MakeDir         = * *
RemoveOwnDir    = * *
RemoveDir       = * 1VM
Rename		= * 1VM
RenameOwn       = * *
Overwrite       = * 1VM
Delete		= * 1VM
DeleteOwn	= * *
NoStats         = * =lSpeed !*
but i still can't write data to my ftp

Last edited by en3rmax; 04-02-2007 at 03:47 PM.
en3rmax is offline  
Old 04-02-2007, 03:52 PM   #50
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

little update as i have been trying to see which scripts will work

nxtools has some issue with nxclose - if thats in ioftpd ini i cant even log in

04-01-2007 08:50:02 "..\scripts\nxTools\nxClose.tcl" terminated abnormally
--------------------------- ErrorInfo ----------------------------
can't find package sqlite3
while executing
"package require $name"

i have tried putting the libs folder in c:\ioftpd\libs and ioftpd/ioftpd/libs - still no luck

iob - that seems to stick when i make a dir - error log just says that iodupe has terminated abnormally but give no reason as to why, remove all dupe lines leave sfv check all works fine

iosfv - all seems to go - untill i try to up a release of 94 x 50 meg files - seems only 74 only ever want to make it there - any thing after that will say its fine but no actually turn up
(tuff i know this sounds like the bug you found and sqaushed - poss io related this time )

Yil any chance of a md5sum with your rls from now on - if i stick them on my site, mirror if you will, just incase everyone tries to d/l it from you and get errors, timeouts and such (untill/if your get to sourceforge) ppl will be able to verify the rls
ArtX is offline  
Old 04-02-2007, 03:55 PM   #51
ArtX
Senior Member
FlashFXP Beta Tester
ioFTPD Foundation User
 
Join Date: Jan 2004
Posts: 301
Default

Quote:
Originally Posted by en3rmax View Post
thanks for the quick reply Zer0Racer, i am using a fresh install of 6.0.1 my old install seems to work fine

i changed the info in ### PERMISSIONS ### to

Code:
Upload          = * *
Resume		= * *
Download	= * *
MakeDir         = * *
RemoveOwnDir    = * *
RemoveDir       = * 1VM
Rename		= * 1VM
RenameOwn       = * *
Overwrite       = * 1VM
Delete		= * 1VM
DeleteOwn	= * *
NoStats         = * =lSpeed !*
but i still can't write data to my ftp
if your not a user with 1 V or M try adding a 3




Upload = /* 13VM
Resume = /* 13VM
MakeDir = /* 13VM
RemoveOwnDir = /* 13VM
RemoveDir = /* 1VM
Rename = /* 1VM
RenameOwn = /* 13VM
Delete = /* 1VM
DeleteOwn = /* 13VM

that should work
ArtX is offline  
Old 04-02-2007, 04:21 PM   #52
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Quote:
Originally Posted by Yil
[...]
ZR: HP_FUNCTION(io_group_list_seek) is indeed missing. I guess you're the first person to EVER try that function hehe. Added, and bonus points for providing the solution!
[...]

-Yil
Hehe. Glad I can help. Well, I did function as first beta tester for darkone for a while and he dubbed me "Santa's Little Helper" here lol. Apart from bug hunting I've renamed options in ioFTPD.ini and I wrote the documentation (with no other alternatives present). But note that I can't code C++, or anything else (almost) for that matter (yet). I'm just thorough and understand logic and good structure. And I've always had an eye for how stuff should work. I'm actually studying Interaction Design atm with usability and user interfaces etc.

I really hope ioFTPD's php support will be alot better in the future, like ability to monitor (and interact with) ftp service through http (like darkone had planned a couple of years ago, see Scripting, Web Interface), more built-in extensions and docs on how to build php modules for ioFTPD etc. Maybe possible to have an extra version compiled for php5 even?

As I understand it php is very powerful, and supporting it in a serious way in ioFTPD would be a big step closer to equally powerful webadmin interfaces and more.

/ZR
Zer0Racer is offline  
Old 04-02-2007, 04:28 PM   #53
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

Yil

I think the problem exists in the libs/tcl8.4/encoding/ascii.enc file, as it only references the frist 127 characters of ascii

Problem confirmed, by simply renaming said encoding directory, everything is well again
__________________
#iotools #ioftpd (both on efnet)

Last edited by tuff; 04-02-2007 at 05:05 PM.
tuff is offline  
Old 04-02-2007, 04:49 PM   #54
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

en3rmax, you chmodded any dirs to 777 and tried? What errors do you get?

/ZR
Zer0Racer is offline  
Old 04-02-2007, 05:04 PM   #55
en3rmax
Junior Member
 
Join Date: Jul 2005
Posts: 27
Default

Thx for the info Zer0Racer & Carpo, i started from fresh and installed it again and its fine now, weird!!! must of been a typo error by me, thx again guys for the help

Last edited by Zer0Racer; 04-02-2007 at 05:31 PM. Reason: removed quote
en3rmax is offline  
Old 04-02-2007, 05:39 PM   #56
tuff
Senior Member
FlashFXP Registered User
ioFTPD Scripter
 
Join Date: Jan 2003
Posts: 277
Default

Unhandled exception 3221225477 at address 0x77b22086 (0x00000000)
0x00000000 0x7b6b22e4

This occured when attemping to rename a Directory

Something else strange too

i attempted to rename TEMP to TEMP1, it had 4.5gig of rars in it

io crashed, it was the same drive obviosuly, when i restarted io, it see`s the old TEMP dir with some files missing, but doesnt see TEMP1

but TEMP1 exists in windows itself, and if i attempt to mkdir TEMP1 i get an error saying its there

UPDATE: if im correct, this is whats happening on a rename now

create new dir, hide new directory, move data, unhide new directory, delete old directory?

this seems totally pointless for a rename on the SAME drive

i think your not checking the rename is on the same drive/directory?
__________________
#iotools #ioftpd (both on efnet)

Last edited by tuff; 04-02-2007 at 05:59 PM.
tuff is offline  
Old 04-02-2007, 05:44 PM   #57
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Quote:
Originally Posted by tuff
Unhandled exception 3221225477 at address 0x77b22086 (0x00000000)
0x00000000 0x7b6b22e4

This occured when attemping to rename a Directory
I actually got a strange error in ffxp first time I logged in on io 6.0.0 - when I tried to rename a file ffxp thought it was a dir and failed on RNTO. Couldn't reproduce it though and didn't report it. Sounds like it could be something wrong with rename.

/ZR
Zer0Racer is offline  
Old 04-02-2007, 06:06 PM   #58
oldhouse
Member
 
Join Date: Sep 2005
Posts: 60
Default

Just to clarify, I didn't mount root drive, but I had problems chmodding root dir of ftp site.
Let's just say I call d:\Section1 as /Section1 on my ftp. I couldn't upload anything there with flag3 user until I set default permission to 777. And CHMOD didn't work on that dir too, so I don't think it's related to mounting whole hard disk.
oldhouse is offline  
Old 04-02-2007, 07:46 PM   #59
Yil
Too much time...
FlashFXP Beta Tester
ioFTPD Administrator
 
Join Date: May 2005
Posts: 1,194
Default

Tuff: looks like that's the ticket. The ascii encoding isn't defined for >127. That appears to be proper TCL behavior as it's in the official distribution that way and the only reason nobody noticed before was the entire encoding directory wasn't included with ioFTPD releases so without a proper encoding file it just left everything alone...

Carpo: great info on script compatibility. Just for kicks try reverting to the old minimal TCL dir to see if that affects anything. The encoding issue may be affecting more than just iputs.

Tuff: Grr, I must have broken something when trying to determine if the move was a move or a rename when I fixed it to handle network shares (I hope). And yes, you guessed the behavior for a filesystem move. Create the new dir as an NTFS hidden dir, start copying everything over recursively deleting the source only after a successful copy. This prevents any permission race condition because ioFTP won't let you access a hidden NTFS dir and thus you can't enter any directory in the process of being copied. The fact that it died isn't good news either, so perhaps I'll have to test larger sized moves...

oldhouse: There are lots of permissions in ioFTPD: First, you must have access via the VFS section of ioFTPD. It appears that you have done that. Then you must have file/directory permission. Try creating a directory FOO, and using "site chmod 777 FOO". Users should be able to upload to that directory now. You may find setting the default directory permission to 775 is what you want so that people in the same group can upload but others can't. 755 allows only the owner to upload and 777 allows anyone. With appropriate VFS settings in ioFTPD that may be OK, but for the default I chose the more restrictive setting and you can then open up the sections you want. New dirs inherit the parents permissions so once you open up a tree it should stay open. I'm pretty sure this is a pure configuration issue on your part but I've been wrong a lot today so can you cut/paste a LIST -al of the directory showing the permissions and verify the flags of the user who can't upload? And if chmod fails any error you get?
Yil is offline  
Old 04-02-2007, 08:46 PM   #60
K-LiNeD
Junior Member
ioFTPD Foundation User
 
Join Date: Oct 2004
Posts: 7
Default

YiL, great job BTW.
K-LiNeD is offline  
Closed Thread

Tags
fxp, ioftpd, recursive, test, v6.0

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:48 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)