Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 04-19-2006, 05:41 AM   #1
lucaz
Member
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 77
Default ioFTPD-beta5-8-8r

Hi all =)

A couple days ago, i had an email that there was a new version availble,
so i downloaded it and tried it.

but...

It keeps crashing everytime i try to start it

AppName: ioftpd.exe AppVer: 0.0.0.0 ModName: ioftpd.exe
ModVer: 0.0.0.0 Offset: 0001c171

Can anyone help me with this... ?

thank you
lucaz is offline   Reply With Quote
Old 04-19-2006, 07:06 AM   #2
LordM
Senior Member
ioFTPD Foundation User
 
LordM's Avatar
 
Join Date: Jul 2005
Location: Germany
Posts: 138
Default

if you update your profile...

...maybe we can
__________________
I'm using:

ioFTPD 7.7.2
ioNiNJA BETA Stable v0.8.9.6
LordM is offline   Reply With Quote
Old 04-19-2006, 11:41 AM   #3
lucaz
Member
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 77
Default

Quote:
Originally Posted by LordM
if you update your profile...

...maybe we can
what profile ?
lucaz is offline   Reply With Quote
Old 04-19-2006, 01:46 PM   #4
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

LordM is probably referring to the fact that your vb user isn't connected with your portal account so we can see your registered status. If you will send an email to support via the contact page with all the information (both user accounts, reg verification, etc), we will merge your accounts so you get better support here.

Thanks!
Linkster is offline   Reply With Quote
Old 04-19-2006, 01:57 PM   #5
lucaz
Member
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 77
Default

Hmm strange i did that a long time ago... :S
lucaz is offline   Reply With Quote
Old 04-20-2006, 03:42 AM   #6
PNC
Junior Member
 
PNC's Avatar
 
Join Date: Nov 2004
Posts: 14
Default

Quote:
Originally Posted by lucaz
Hi all =)

A couple days ago, i had an email that there was a new version availble,
so i downloaded it and tried it.

but...

It keeps crashing everytime i try to start it

AppName: ioftpd.exe AppVer: 0.0.0.0 ModName: ioftpd.exe
ModVer: 0.0.0.0 Offset: 0001c171

Can anyone help me with this... ?

thank you

I have the same problem.....Hoping to get a answer how to resolve this problem. its pretty anoying....with 5.8.5r , there was no such problem..
PNC is offline   Reply With Quote
Old 04-20-2006, 07:55 AM   #7
lucaz
Member
ioFTPD Foundation User
 
Join Date: Sep 2003
Posts: 77
Default

Quote:
Originally Posted by PNC
I have the same problem.....Hoping to get a answer how to resolve this problem. its pretty anoying....with 5.8.5r , there was no such problem..
Yeah i know, i never had problems with ioFTPD, only with this one and the previous releases.
The previous release crashed everytime i used a scripts
and the new script crashes when i start it...
lucaz is offline   Reply With Quote
Old 04-20-2006, 11:33 AM   #8
m4r3z
Junior Member
ioFTPD Foundation User
 
Join Date: Sep 2004
Posts: 24
Default

5.8.5r is like teh shit.

all versions after thatone dont work for me neither. error when I try to start the ftpd.. *sigh*
but 5.8.5r works like a charm
m4r3z is offline   Reply With Quote
Old 04-20-2006, 01:40 PM   #9
ADDiCT
Senior Member
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: Aug 2003
Posts: 517
Default

I tested 5.8.8r and it works fine out of the box on my machines with WinXP SP1/SP2 and visual studio 2005 installed (including .NET framework 1.1 and 2.0). It crashes on my HTPC with WinXP SP1 and no visal studio or .NET framework installed (exception c0000005 on address 0041C171). People where io doesn't start can check their system event log for errors, it doesn't show a regular "crash" window with the red icon.

noelek told me on IRC that my 'sitewho' utility didn't work anymore. It seems ioFTPD doesn't respond to a SHMEM query like it used to do in 5.8.8r. My only documentation ever was ...\source\Window.Messages.And.Shared.Memory\Old\s itewho.cpp. If i compile that file, it works fine on 5.8.5r but hangs on 5.8.8r. More specifically it loops endlessly in the main for (;bLoop;dwUsers++)-loop (when there are users online, otherwise it just shows nothing). The call to QueryDaemon() should return '0' if the message was received, but now it returns nonzero.

Perhaps an updated working example on how to use SHMEM would be nice
ADDiCT is offline   Reply With Quote
Old 04-21-2006, 12:30 PM   #10
_panic_
Senior Member
Ultimate Scripter
 
Join Date: Jul 2005
Posts: 153
Default

Quote:
Originally Posted by ADDiCT
I tested 5.8.8r and it works fine out of the box on my machines with WinXP SP1/SP2 and visual studio 2005 installed (including .NET framework 1.1 and 2.0). It crashes on my HTPC with WinXP SP1 and no visal studio or .NET framework installed (exception c0000005 on address 0041C171). People where io doesn't start can check their system event log for errors, it doesn't show a regular "crash" window with the red icon.

noelek told me on IRC that my 'sitewho' utility didn't work anymore. It seems ioFTPD doesn't respond to a SHMEM query like it used to do in 5.8.8r. My only documentation ever was ...\source\Window.Messages.And.Shared.Memory\Old\s itewho.cpp. If i compile that file, it works fine on 5.8.5r but hangs on 5.8.8r. More specifically it loops endlessly in the main for (;bLoop;dwUsers++)-loop (when there are users online, otherwise it just shows nothing). The call to QueryDaemon() should return '0' if the message was received, but now it returns nonzero.

Perhaps an updated working example on how to use SHMEM would be nice
it looks like i linked to a library that is updated by visual studio, so if visual studio isn't installed it uses an old and non-working version. grrr.

i'm not linking this library directly, either something i'm using needs it or i've got a wayward compiler flag set somewhere.

i didn't know about the shmem issue, i'll add that one to the bug list.
_panic_ is offline   Reply With Quote
Old 04-21-2006, 12:47 PM   #11
helenoksen
Member
ioFTPD Foundation User
 
Join Date: Oct 2005
Posts: 75
Default

can you make a short 'walkthrough' on how to compile and run a simple hello world program using shared mem in vs2005?
helenoksen is offline   Reply With Quote
Old 04-28-2006, 03:02 PM   #12
DR. GiGa BYTe
Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 80
Default

I got the same problem. Everytime I start ioFTPD.exe it crash immediately without a ioFTPD.crash.log entry.

Here is the M$ DrWatson, perhaps it helps:
Code:
Microsoft (R) DrWtsn32
Copyright (C) 1985-2001 Microsoft Corp. Alle Rechte vorbehalten.



Anwendungsausnahme aufgetreten:
        Anwendung: c:\ioFTPD\system\ioFTPD.exe (pid=3676)
        Wann: 28.04.2006 @ 21:53:58.812
        Ausnahmenummer: c0000005 (Zugriffsverletzung)

*----> Systeminformationen <----*
        Computername: Computername
        Benutzername: Benutzername
        Terminalsitzungskennung: 0
        Prozessoranzahl: 1
        Prozessortyp: x86 Family 6 Model 8 Stepping 1
        Windows-Version: 5.1
        Aktuelles Build: 2600
        Service Pack: 2
        Aktueller Typ: Uniprocessor Free
        Firma: Firma
        Besitzer: Besitzer

*----> Modulliste <----*
(0000000000330000 - 00000000003c3000: c:\ioFTPD\system\tcl84t.dll
(0000000000400000 - 000000000046d000: c:\ioFTPD\system\ioFTPD.exe
(0000000010000000 - 0000000010171000: c:\ioFTPD\system\php4ts.dll
(0000000020000000 - 0000000020019000: C:\WINDOWS\system32\odbcint.dll
(000000005d450000 - 000000005d4e7000: C:\WINDOWS\system32\COMCTL32.dll
(0000000062e10000 - 0000000062e19000: C:\WINDOWS\system32\LPK.DLL
(0000000071a00000 - 0000000071a08000: C:\WINDOWS\system32\WS2HELP.dll
(0000000071a10000 - 0000000071a27000: C:\WINDOWS\system32\WS2_32.dll
(0000000071a30000 - 0000000071a3a000: C:\WINDOWS\system32\WSOCK32.dll
(00000000745d0000 - 000000007460d000: C:\WINDOWS\system32\ODBC32.dll
(0000000075790000 - 00000000757fb000: C:\WINDOWS\system32\USP10.dll
(0000000075f40000 - 0000000075f5f000: C:\WINDOWS\system32\Apphelp.dll
(0000000076330000 - 000000007634d000: C:\WINDOWS\system32\IMM32.DLL
(0000000076350000 - 000000007639a000: C:\WINDOWS\system32\comdlg32.dll
(00000000770f0000 - 000000007717c000: C:\WINDOWS\system32\OLEAUT32.dll
(00000000773a0000 - 00000000774a2000: C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2180_x-ww_a84f1ff9\comctl32.dll
(00000000774b0000 - 00000000775ed000: C:\WINDOWS\system32\ole32.dll
(0000000077a50000 - 0000000077ae5000: C:\WINDOWS\system32\CRYPT32.dll
(0000000077af0000 - 0000000077b02000: C:\WINDOWS\system32\MSASN1.dll
(0000000077bd0000 - 0000000077bd8000: C:\WINDOWS\system32\VERSION.dll
(0000000077be0000 - 0000000077c38000: C:\WINDOWS\system32\msvcrt.dll
(0000000077d10000 - 0000000077da0000: C:\WINDOWS\system32\USER32.dll
(0000000077da0000 - 0000000077e4a000: C:\WINDOWS\system32\ADVAPI32.dll
(0000000077e50000 - 0000000077ee1000: C:\WINDOWS\system32\RPCRT4.dll
(0000000077ef0000 - 0000000077f37000: C:\WINDOWS\system32\GDI32.dll
(0000000077f40000 - 0000000077fb6000: C:\WINDOWS\system32\SHLWAPI.dll
(000000007c340000 - 000000007c396000: C:\WINDOWS\system32\MSVCR71.dll
(000000007c800000 - 000000007c906000: C:\WINDOWS\system32\kernel32.dll
(000000007c910000 - 000000007c9c7000: C:\WINDOWS\system32\ntdll.dll
(000000007c9d0000 - 000000007d1ef000: C:\WINDOWS\system32\SHELL32.dll

*----> Statusabbild für Threadkennung 0x2f8 <----*

eax=0041c100 ebx=0012fde0 ecx=0012fb30 edx=0012fb41 esi=0015232f edi=0012fdf1
eip=0041c171 esp=0012fb30 ebp=0012ff20 iopl=0         nv up ei pl zr na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246

*** ERROR: Module load completed but symbols could not be loaded for c:\ioFTPD\system\ioFTPD.exe
Funktion: ioFTPD
        0041c157 f8               clc
        0041c158 0f84f2feffff     je      ioFTPD+0x1c050 (0041c050)
        0041c15e 8bcb             mov     ecx,ebx
        0041c160 8a01             mov     al,[ecx]
        0041c162 8802             mov     [edx],al
        0041c164 83c101           add     ecx,0x1
        0041c167 83c201           add     edx,0x1
        0041c16a 84c0             test    al,al
        0041c16c 75f2             jnz     ioFTPD+0x1c160 (0041c160)
        0041c16e 8b4df8           mov     ecx,[ebp-0x8]
FEHLER ->0041c171 f30f7e057c994400 movq xmm0,qword ptr [ioFTPD+0x4997c (0044997c)] ds:0023:0044997c=2e445054466f695c
        0041c179 2bcb             sub     ecx,ebx
        0041c17b 8d4439ff         lea     eax,[ecx+edi-0x1]
        0041c17f 660fd600         movq    qword ptr [eax],xmm0
        0041c183 8b1584994400     mov     edx,[ioFTPD+0x49984 (00449984)]
        0041c189 895008           mov     [eax+0x8],edx
        0041c18c 33db             xor     ebx,ebx
        0041c18e becce84400       mov     esi,0x44e8cc
        0041c193 8b7d08           mov     edi,[ebp+0x8]
        0041c196 85ff             test    edi,edi
        0041c198 7406             jz      ioFTPD+0x1c1a0 (0041c1a0)

*----> Stack Back Trace <----*
WARNING: Stack unwind information not available. Following frames may be wrong.
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\WINDOWS\system32\kernel32.dll - 
ChildEBP RetAddr  Args to Child              
0012ff20 0041c3ba 00000001 00438bd1 00400000 ioFTPD+0x1c171
0012ffc0 7c816d4f 00320037 00320035 7ffde000 ioFTPD+0x1c3ba
0012fff0 00000000 00438c3a 00000000 78746341 kernel32!RegisterWaitForInputIdle+0x49

*----> Raw Stack Dump <----*
000000000012fb30  63 3a 5c 69 6f 46 54 50 - 44 5c 73 79 73 74 65 6d  c:\ioFTPD\system
000000000012fb40  00 ff ff ff 32 07 92 7c - ab 06 92 7c eb 06 92 7c  ....2..|...|...|
000000000012fb50  c4 fd 12 00 bc fd 12 00 - 00 00 00 00 90 1e 15 00  ................
000000000012fb60  50 fb 12 00 48 00 00 00 - 94 fd 12 00 18 ee 91 7c  P...H..........|
000000000012fb70  38 07 92 7c ff ff ff ff - 32 07 92 7c ab 06 92 7c  8..|....2..|...|
000000000012fb80  eb 06 92 7c 04 01 00 00 - 02 00 00 00 e0 fd 12 00  ...|............
000000000012fb90  02 03 02 03 20 01 02 03 - 04 05 06 07 08 09 0a 0b  .... ...........
000000000012fba0  0c 0d 0e 0f 10 11 12 13 - 14 15 16 17 18 19 1a 1b  ................
000000000012fbb0  1c 1d 1e 1f 00 00 00 00 - 00 d0 fd 7f 1c fc 12 00  ................
000000000012fbc0  2a 26 80 7c d8 fb 12 00 - 00 26 80 7c f1 fd 12 00  *&.|.....&.|....
000000000012fbd0  10 fd 12 00 e0 fd 12 00 - 14 00 00 00 01 00 00 00  ................
000000000012fbe0  00 00 00 00 00 00 00 00 - 10 00 00 00 f8 db fd 7f  ................
000000000012fbf0  00 00 00 00 00 e0 fd 7f - 00 d0 fd 7f 00 00 00 00  ................
000000000012fc00  00 00 00 00 cc fb 12 00 - e1 f4 80 7c b0 ff 12 00  ...........|....
000000000012fc10  f3 99 83 7c 08 26 80 7c - ff ff ff ff 00 26 80 7c  ...|.&.|.....&.|
000000000012fc20  42 25 80 7c 48 00 00 00 - ff ff ff ff 00 00 00 00  B%.|H...........
000000000012fc30  20 ff 12 00 26 c1 41 00 - 00 26 80 7c 51 c1 41 00   ...&.A..&.|Q.A.
000000000012fc40  ff 1b 92 7c 00 00 bb 00 - e8 2f bb 00 00 00 bb 00  ...|...../......
000000000012fc50  e8 2f bb 00 01 00 bb 00 - 8c fc 12 00 00 00 bb 00  ./..............
000000000012fc60  32 07 92 7c 11 00 00 00 - b8 09 bb 00 00 00 bb 00  2..|............
DR. GiGa BYTe is offline   Reply With Quote
Old 05-01-2006, 04:23 PM   #13
mexxim
Junior Member
ioFTPD Foundation User
 
Join Date: Feb 2004
Posts: 5
Default

Seems I am not the only one having the problem then getting the same crash error. Should we update some external files panic ?

[edit] I also checked in this thread http://www.inicom.net/forum/showthread.php?t=16512 for the solution but that file is present so I am stuck... [/edit]
mexxim is offline   Reply With Quote
Old 05-05-2006, 06:52 PM   #14
ioUSER
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Jul 2004
Posts: 98
Default

Quote:
Originally Posted by _panic_
i didn't know about the shmem issue, i'll add that one to the bug list.
would be nice if this shmem issue would be fixed soon (it was there before too)... thanks
ioUSER is offline   Reply With Quote
Old 09-21-2006, 08:33 AM   #15
Jackalicek
Junior Member
ioFTPD Foundation User
 
Join Date: Sep 2006
Posts: 1
Default

Any ideas now how to solve this problem? I bought ioFTPD and i want it to work ... thanks.
Jackalicek is offline   Reply With Quote
Reply

Tags
0.0.0.0, appver, ioftpd.exe, modname, start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:01 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)