Go Back   FlashFXP Forums > > > >

ioFTPD General New releases, comments, questions regarding the latest version of ioFTPD.

Reply
 
Thread Tools Rate Thread Display Modes
Old 02-02-2006, 07:45 AM   #1
oslike
Member
 
Join Date: Dec 2003
Posts: 90
Default KB down: 426 Connection closed error

Hi,

the KB link doesnt work on this Question
What does this error message mean?

426 Connection closed: The specified network name is no longer available.

oslike
oslike is offline   Reply With Quote
Old 05-20-2006, 03:28 PM   #2
danielstinebaugh
Junior Member
ioFTPD Foundation User
 
Join Date: May 2006
Posts: 3
Default

I wish someone would comment on this as I too recieve the same error. I am not behind a router that would give me the error that the KB explains so I'm at a loss. What's worse, is I can begin a download and everything works great, but half way through I recieve:

Code:
[13:05:42] 426 Connection closed: The specified network name is no longer available.
[13:05:42] Transfer failed.
danielstinebaugh is offline   Reply With Quote
Old 05-20-2006, 05:05 PM   #3
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

It’s a generic message meaning “network connectivity problems”.

When the NT kernel was originally developed, Microsoft decided to create an entire new set of error codes used by NT, called “NT status codes”. To maintain backwards compatibility in the Windows Base API, NT status codes had to be translated back to the older style of error codes. Generally, this approach works quite well, but there are cases where the meaning is lost in translation (i.e. several NT status codes map to the same Windows error code).

The error code for this message, as defined in WinError.h is as follows:
Quote:
//
// MessageId: ERROR_NETNAME_DELETED
//
// MessageText:
//
// The specified network name is no longer available.
//
Which means absolutely nothing to a user trying to figure out the cause of this error.

Here is where things get “fun”, the following NT status codes are mapped to ERROR_NETNAME_DELETED:
  • STATUS_NETWORK_NAME_DELETED
  • STATUS_LOCAL_DISCONNECT
  • STATUS_REMOTE_DISCONNECT
  • STATUS_ADDRESS_CLOSED
  • STATUS_CONNECTION_DISCONNECTED
  • STATUS_CONNECTION_RESET
Each of these errors on their own explains the problem better, but we only get to see a generic one encompassing all of them.

In short, there is no single explanation for your problem – it could be caused by a number of things:
  • Unreliable network cards
  • Unreliable drivers for network cards (try updating them)
  • Incorrect duplex settings
  • Misconfigured firewall, router, or some other network device
  • Internet service provider (not likely, but don't rule it out)

Here's a guide to troubleshooting network problems, probably won't be of much help but it is worth a shot. What brand and model is your network card, what kind of interface does it use (PCI, PCI-X, USB, etc.)?
neoxed is offline   Reply With Quote
Old 05-23-2006, 12:22 AM   #4
danielstinebaugh
Junior Member
ioFTPD Foundation User
 
Join Date: May 2006
Posts: 3
Default

So your saying that this is a hardware based issue and not the actual client. Cool that's at least a step for me in the right direction. Thanks for your promt reply
danielstinebaugh is offline   Reply With Quote
Old 05-23-2006, 02:48 AM   #5
neoxed
Too much time...
FlashFXP Beta Tester
ioFTPD Scripter
 
Join Date: May 2003
Posts: 1,326
Default

No no...I'm saying it could be anything.

I was just curious about which network cards you're using.
neoxed is offline   Reply With Quote
Old 05-23-2006, 04:12 AM   #6
EwarWoo
Senior Member
FlashFXP Registered User
ioFTPD Registered User
 
Join Date: Oct 2002
Posts: 462
Default

Yup, this is one of the hardest issues to fix. If its not a constant thing you'll make your life much easier by ignoring it.
Unfortunately thats what I had to do when I had it. Did seem to clear up of its own accord strangely but.
EwarWoo is offline   Reply With Quote
Old 05-25-2006, 11:54 PM   #7
danielstinebaugh
Junior Member
ioFTPD Foundation User
 
Join Date: May 2006
Posts: 3
Default

Currently I'm using a WPN311 RangeMax(TM) Wireless PCI Adapter and connecting to the rangemax netgear router (WPM824). However I'm just about ready to move so I'll be wired again soon. Been waiting for this day
danielstinebaugh is offline   Reply With Quote
Reply

Tags
426, closed, connection, error, network

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:25 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)