Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 10-01-2003, 03:12 PM   #1
Unique
Senior Member
 
Join Date: Jan 2003
Posts: 231
Default Userfile ****up after a while?

Hi i had been having probs getting iogroups addon from addict to work.
After debugging with him we saw that problem was my master user account.
It had bogus values for the 3rd number of wkup alup etc.

I then replaced all values back to 0. Causing ioggroups to work correct again.
Since im testing io today ive been throwing lots of files over locally at 20~30 meg/sec, and now my stats are dead again
Example:
wkup 263 1366473 -4550293571894178478 0 0 0

Im using latest iozs, ioa, gaybar, and dzsbot and iogroups.
Im not yet sure if a script caused it, or if io causes it.
If i have time i can try without any scripts if you cant find anything wrong in your ioftpd sources.

:banana:

Since i got my first ever transfer fail on local tests (believe me i transferred some 100000 files or so this year on testing io and none ever failed )
150 Opening BINARY mode data connection for 03-after_forever_-_my_pledge_of_allegiance_nr1_(the_sealed_fate)-qtxmp3.mp3.
426 Connection closed: Connection timed out.
Transfer Failed!
This was after about 20kb of upping according to ffxp..

Im starting to wonder if its maybe my memory making errors... havent had any weird crashes though, so id hope these r 2 real bugs instead of my comp ;(


Unique is offline   Reply With Quote
Old 10-01-2003, 03:52 PM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

For the problem #1, I'll try transfering some large batch... but I doubt it's ioftpd that is breaking those stats (more likely it's some script)


For #2 ioftpd might have bound itself to socket that is already used by some other program... and client has sent those 20kbytes there
darkone is offline   Reply With Quote
Old 10-01-2003, 03:57 PM   #3
Unique
Senior Member
 
Join Date: Jan 2003
Posts: 231
Default

mhm fixed my port range to something thats surely not used, at least accoring to active ports, and netstat -a.

and got another timeout today.
I attached some logs so you can see.. Could this also be a ffxp bug?

And the overflowing time thing in the user files, i got it after delling some dir today, gonne try to locate the prob later today, only got iozs as delfile script, and gaybar for removedir. So should be easy to sort it out i hope
(btw i saw your using full seconds as timer value? most of my transfers are below 0 sec...)

Quote:
Thu Oct 2 13:07:03 2003 0 127.0.0.1 1440754 /Requests/0day-test/fu-ps912.zip b _ i r test ftp 1 * l
Thu Oct 2 13:07:03 2003 0 localhost 1440754 /0-dayz/1001/0day-test/fu-ps912.zip b _ o r Unique ftp 1 * l
Thu Oct 2 13:07:03 2003 0 127.0.0.1 1440779 /Requests/0day-test/fu-ps913.zip b _ i r test ftp 1 * l
Thu Oct 2 13:07:03 2003 0 localhost 1440779 /0-dayz/1001/0day-test/fu-ps913.zip b _ o r Unique ftp 1 * l
Thu Oct 2 13:07:23 2003 19 127.0.0.1 0 /Requests/0day-test/fu-ps914.zip b _ i r test ftp 1 * l
Thu Oct 2 13:07:23 2003 19 0.0.0.0 0 /0-dayz/1001/0day-test/fu-ps914.zip b _ o r Unique ftp 1 * l
Thu Oct 2 13:07:24 2003 0 localhost 1440754 /0-dayz/1001/0day-test/fu-ps915.zip b _ o r Unique ftp 1 * l
Thu Oct 2 13:07:24 2003 0 127.0.0.1 1440754 /Requests/0day-test/fu-ps915.zip b _ i r test ftp 1 * l
Thu Oct 2 13:07:24 2003 0 127.0.0.1 1440779 /Requests/0day-test/fu-ps916.zip b _ i r test ftp 1 * l
Thu Oct 2 13:07:24 2003 0 localhost 1440779 /0-dayz/1001/0day-test/fu-ps916.zip b _ o r Unique ftp 1 * l

Transferred: fu-ps913.zip 1.440.779 bytes in 0,23 (1.407,01 KB/Sec)
PASV
227 Entering Passive Mode (127,0,0,1,32,87)
PORT 127,0,0,1,32,87
200 PORT command successful.
STOR fu-ps914.zip
150 Opening BINARY mode data connection for fu-ps914.zip.
RETR fu-ps914.zip
150 Opening BINARY mode data connection for fu-ps914.zip.
426 Connection closed: Connection timed out.
426 Connection closed: Connection timed out.
Transferred: fu-ps914.zip 1.440.754 bytes in 19,97 (70,46 KB/Sec)
PASV
227 Entering Passive Mode (127,0,0,1,31,255)
Just checked my logs, and previous failed transfer had also 0.0.0.0 as ip :S
Unique is offline   Reply With Quote
Old 10-02-2003, 11:22 AM   #4
Unique
Senior Member
 
Join Date: Jan 2003
Posts: 231
Default

Tested a bit more on the userfile ****up.
Using a clean ioftpd, with no scripts it still ****s it up!
Only changed vfs, commented certificate and enabled change stats on delete.

As in how to reproduce:
Up a shitload of files.
Then delete all the files, and it will **** up my user file.. either giving insane high values or even negative ones :P

So im pretty sure its ioftpd doing it...
Its not always doing it though :/
But quite frequent id say..
Unique is offline   Reply With Quote
Old 10-02-2003, 04:09 PM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Actually, it happends when deleting file smaller than 1kb (causes divide by zero) Only happends if you have set Modify_Stats_On_Delete to true.
darkone is offline   Reply With Quote
Old 10-02-2003, 04:17 PM   #6
Unique
Senior Member
 
Join Date: Jan 2003
Posts: 231
Default

Teh time should be in ms too or so i think, otherwise stats will suck if using fast site/small files.:banana:
Unique is offline   Reply With Quote
Old 10-02-2003, 04:27 PM   #7
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Changing that would break the compatability between other io versions :/ I'd prefer accuracy of 10ms over 1ms tho
darkone is offline   Reply With Quote
Old 10-04-2003, 05:16 PM   #8
Unique
Senior Member
 
Join Date: Jan 2003
Posts: 231
Default

ioFTPD-beta5-1-5r results:
After fxping some 6000 files im 99% sure you fixed the transfer timeout bug
See you put active ports to login -1 also again, nice!

The userfile ****up problem is still there though
Super fresh install ioftpd, no scripts, upped 2000 files-> deleted 2000 files again -> timer overflowed and eventually got negativ
(you can try yourself, windows has a nice inf dir with shitloads of files...)
Unique is offline   Reply With Quote
Old 10-04-2003, 08:10 PM   #9
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Will check.. might be something that I overlooked
darkone is offline   Reply With Quote
Reply

Tags
connection, failed, files, transfer, values

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:33 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)