Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-14-2003, 03:43 PM   #1
kbello
Junior Member
 
Join Date: Sep 2003
Posts: 9
Unhappy bug in fxp uploads

in ioftpd 5.0.12r when i tried fxp uploading to another site (io and raiden) result this msg '426 Connection closed: The specified network name is no longer available'. The file is correct, but never give the "transfer ok".

Only give me this error when fxp uploading to another io and raiden, with another ftp server no problems.

windows xp sp1
kbello is offline   Reply With Quote
Old 09-14-2003, 04:13 PM   #2
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

I need logs with timestamps to determinate what is going wrong... some ~20lines should be enough.
darkone is offline   Reply With Quote
Old 09-14-2003, 04:53 PM   #3
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Actually nm.. I was able to replicate this (new routine that allows freeing up resources faster, had minor error [shutdown() was not called for receiving socket])
darkone is offline   Reply With Quote
Old 09-14-2003, 05:05 PM   #4
kbello
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

here

[17:45:40] TYPE I
[17:45:40] 200 Type set to IMAGE.

[17:45:40] PASV
[17:45:40] 227 Entering Passive Mode (200,50,xx,xx,6,83)

[17:45:40] PORT 200,50,xx,xx,6,83
[17:45:41] 200 Port command ok.
[17:45:41] STOR test.rar
[17:45:41] 150 Opening BINARY data connection for /-- ++ UpLoadz ++ --/test/test.rar

[17:45:41] RETR test.rar
[17:45:41] 150 Opening BINARY mode data connection for test.rar.

[17:47:30] 226-Automatic RAR verification : PASSED.
[17:47:30] 226-Ba: 0 bytes Su: 2953251 bytes en esta sesion
[17:47:30] 226-Ultima Velocidad de Subida : 27 kb/sec , tienes Unlimited kb creditos
[17:47:30] 226-+================================================= ==================-.
[17:47:30] 226- Directory Info for test |
[17:47:30] 226-+================================================= ==================-|
[17:47:30] 226- Uploader | Group |Files| Total Size (Bytes) | % of Upload |
[17:47:30] 226-+-------------+-----------+-----+--------------------+---------------|
[17:47:30] 226- 01.xxx | xxxxx | 1f | 2953251 | 100.00% |
[17:47:30] 226-+-------------+-----------+-----+--------------------+---------------|
[17:47:30] 226- Total : 01 | | 1f | 2.82 mb | 100.00% |
[17:47:30] 226-+================================================= =================+-'
[17:47:30] 226 Transfer finished successfully. Data connection closed.

[17:49:28] 426 Connection closed: The specified network name is no longer available.
[17:49:28] Transfer Failed!
[17:49:28] TYPE A
[17:49:28] 200 Type set to A.
[17:49:28] PASV
[17:49:28] 227 Entering Passive Mode (200,50,xx,xx,5,143)
[17:49:28] LIST -al
[17:49:28] 150 Opening ASCII mode data connection for directory listing.
[17:49:28] 226-[Dl: 1763.5MB]-[Up: 8419.4MB]-[Speed: 198380.6kb/s]-[Free: 73GB]
[17:49:28] 226 [Section: REQUEST]-[Credits: 0.0 Mb]-[Ratio: Unlimited]
[17:49:28] List Complete: 604 bytes in 0,11 (0,59 KBps)

[17:49:28] TYPE A
[17:49:29] 200 Type set to ASCII.
[17:49:29] PASV
[17:49:29] 227 Entering Passive Mode (200,68,xx,xx,4,179)
[17:49:29] LIST -al


Blue= io
green= raiden
kbello is offline   Reply With Quote
Old 09-14-2003, 05:39 PM   #5
kbello
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

i'm update to 5.0.13r
now, don't give me error, but the transfer ok show 2 min later.

[18:36:08] 226 Transfer finished successfully. Data connection closed.
[18:38:07] 226-[Dl: 1763.8MB]-[Up: 8419.4MB]-[Speed: 0.7kb/s]-[Free: 73GB]
[18:38:07] 226 [Section: REQUEST]-[Credits: 0.0 Mb]-[Ratio: Unlimited]

[18:38:07] Transferred: 1.jpg 87 KB in 02:03 (0,71 KBps)
kbello is offline   Reply With Quote
Old 09-14-2003, 06:09 PM   #6
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Sounds like raiden wasn't shutting down socket properly by sending SD_SEND signal. Does this problem occur with io<->serv-u/io<->gl?
darkone is offline   Reply With Quote
Old 09-14-2003, 08:44 PM   #7
kbello
Junior Member
 
Join Date: Sep 2003
Posts: 9
Default

I test with 5.0.11r, work fine with raiden
kbello is offline   Reply With Quote
Old 09-14-2003, 10:49 PM   #8
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

5.0.11 used more brute-force approach to close socket, where os was responsible of freeing resources:

closesocket(Socket);

5.0.12+ uses nicer implementation, which frees resources immeaditely:

shutdown(Socket, FD_SEND);
WSARecv(Socket, ...); // This is where it waits with raiden
setsockopt(Socket, SO_LINGER, ...); // Disable lingering
closesocket(Socket);
darkone is offline   Reply With Quote
Old 09-15-2003, 07:00 AM   #9
Tradah
Junior Member
 
Join Date: Feb 2003
Posts: 15
Default problem listing

i've got a problem with ioftpd 5.0.12r when i try to list every dir, i always get this error although it lists ok. The problem comes when i try to del a dir and when the client gets the error doesnt delete the files inside. Something like this:

426 Connection closed: The specified network name is no longer available.
CWD /ReQuEsT/test
250 CWD command successful.
PWD
257 "/ReQuEsT/test/" is current directory.
PORT 212,xxx,xxx,xxx,14,229
200 PORT command successful.
LIST -al
150 Opening ASCII mode data connection for directory listing.
426 Connection closed: The specified network name is no longer available.
CWD /ReQuEsT/
250 CWD command successful.
PWD
257 "/ReQuEsT/" is current directory.
PORT 212,xxx,xxx,xxx,14,230
200 PORT command successful.
LIST -al
150 Opening ASCII mode data connection for directory listing.
426 Connection closed: The specified network name is no longer available.
Deleted 0 Folders and 0 Files in 00:03

I've tried with and without passive mode activated...
Tradah is offline   Reply With Quote
Old 09-15-2003, 07:57 AM   #10
alturismo
Senior Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Nov 2001
Posts: 265
Default

get u the latest regged version from members section,

should be fixed there
alturismo is offline   Reply With Quote
Old 09-17-2003, 03:49 PM   #11
ConnaZ
Junior Member
ioFTPD Foundation User
 
Join Date: Feb 2003
Posts: 10
Angry 426 Connection closed: The specified network name is no longer available.???

Hey i get this error everytime I log into ioFTPD : 426 Connection closed: The specified network name is no longer available. , any ideas why I get this? I have scripts installed and I cant get !bw or !speed to work I assume this is why, I had this error before any script was installed, so i now its not the scripts, heres what my .vfs looks like :
"d:\ioFTPD\site" /
"c:\0-DAY" /0-DAY
"c:\ISO-APPZ" /ISO-APPZ
"c:\MOVIES" /MOVIES
"c:\MP3" /MP3
"c:\MV" /MV
"c:\PS2" /PS2
"c:\REQUESTS" /REQUESTS
"c:\XXX" /XXX
D:\ioFPD\ is where I have ioftpd installed, and my C:\ drive is where i put all my FTP stuff. please help ,thx
ConnaZ is offline   Reply With Quote
Old 09-17-2003, 04:27 PM   #12
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

I merged a couple of threads on the same problem/bug.

Question: did upgrading to 5.0.13r fix this problem?
Zer0Racer is offline   Reply With Quote
Old 09-17-2003, 04:42 PM   #13
Tradah
Junior Member
 
Join Date: Feb 2003
Posts: 15
Default fixed

i've updated to 5.0.13r and it's fixed
Tradah is offline   Reply With Quote
Old 09-17-2003, 04:55 PM   #14
Zer0Racer
Senior Member
ioFTPD Scripter
 
Join Date: Oct 2002
Posts: 703
Default

Let's close this mofo then.
Zer0Racer is offline   Reply With Quote
Old 09-19-2003, 06:50 PM   #15
Superblue
Member
ioFTPD Registered User
 
Join Date: May 2003
Posts: 78
Default Reopen: 426 Connection closed: The specified network name is no longer available

This is still happening in 5.0.13r when transferring to raiden sites.

Others in the thread also expressed that it happened to them with v5.0.13r as well, it shouldn't have been closed.
Superblue is offline   Reply With Quote
Reply

Tags
426, ftp, fxp, give, uploading

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM


All times are GMT -5. The time now is 07:50 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)