Go Back   FlashFXP Forums > > > >

Bug Reports If you discover any bugs that we are not aware of, please post it here so it may be corrected.

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-25-2003, 05:32 PM   #1
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default 4.9.0 - Bug reports in this thread

[+] CHANGE <user> FLAGS <new flags> removes all flags (except M) from user without setting <new flags>. Status: FIXED
[+] Who incorrectly reports all users as idle. Status: FIXED
[-] FTP/HTTP service does not start. Solution: Install proper certificate, or disable config line that specified certificate
[+] Overwriting does not work. Status: FIXED
[+] Cookies did not work properly as script parameters. Status: FIXED
[+] Process exit code (external scripts) read wrong. Status: FIXED
[+] Mode 0777L was incorrectly translated to 0 on !vfs:add. Status: FIXED
darkone is offline   Reply With Quote
Old 05-25-2003, 11:11 PM   #2
Q3aiml
Junior Member
 
Join Date: Oct 2002
Posts: 16
Default

Seems io doesn't want to overwrite files at all

STOR admin.vfs
550 admin.vfs: No error
Transfer Failed!

Always same error, tried with other files aswell...
Q3aiml is offline   Reply With Quote
Old 05-25-2003, 11:55 PM   #3
Giant
Member
FlashFXP Registered User
ioFTPD Foundation User
 
Join Date: Aug 2002
Posts: 71
Default

530 Error reading VFS file: No error.
When the vfs contains a wrong / dir.
Mebe not a bug but perhaps something a bit more clear then no error should be displayed.
Giant is offline   Reply With Quote
Old 05-26-2003, 12:15 AM   #4
Q3aiml
Junior Member
 
Join Date: Oct 2002
Posts: 16
Default

There seems to be some corruption occuring when using the % before filename option to parse cookies. In the ini under Post I have:

mkd =%test.exe MKD %[$user]|%[$group]|%[$pwd]|

That is parsed fine and passes, as an example
MKD ioFTPD|ioftpd|/ioFTPD/system/|
(Newline)
MKD test.dir

With what would normally be passed on the command line sent after a newline and a space. At first it seemed fine but then it started sending semi-random stuff after the newline, with the rest still coming after it without any cut off.

A few examples...

MKD ioFTPD|ioftpd|/ioFTPD/system/|
unters MKD gggggggggggggg

MKD ioFTPD|ioftpd|/ioFTPD/system/|
msg MKD hh

MKD ioFTPD|ioftpd|/ioFTPD/system/|
oFTPD MKD hohumhohum

- For the rest the format was, without the ending |:
mkd =%test.exe MKD %[$user]|%[$group]|%[$pwd]

MKD ioFTPD|ioftpd|/ioFTPD/system/
rnal MKD 30l0skgg

MKD ioFTPD|ioftpd|/ioFTPD/system/
ioFTPD\system\hello MKD hello

MKD ioFTPD|ioftpd|/h/
%[$pwd MKD yeah

MKD ioFTPD|ioftpd|/h/
%[$pwd MKD yeaaahhh
Q3aiml is offline   Reply With Quote
Old 05-26-2003, 03:30 AM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

I will check this.. sounds like there could be bug in my string 'concat' algorithm
darkone is offline   Reply With Quote
Old 05-26-2003, 07:19 AM   #6
Flare2
Member
 
Join Date: Feb 2003
Posts: 91
Default

BLARGH!

Yeah, had the certificate bug myself.
Flare2 is offline   Reply With Quote
Old 05-26-2003, 08:27 AM   #7
Riddlah
Junior Member
 
Join Date: May 2003
Posts: 2
Default

When I'm doing a !speed command it says that the user is not logged in alltho he is and uploading like crazy. But maybe this is connected with the !who command reporting all as idle.
When doing a site who or a !who in channel it reports him as online but idle as stated above.
Riddlah is offline   Reply With Quote
Old 05-26-2003, 08:42 AM   #8
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Already listed (& fixed)
darkone is offline   Reply With Quote
Old 05-26-2003, 10:29 AM   #9
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

[-] FTP/HTTP service does not start. Solution: Install proper certificate, or disable config line that specified certificate

im having this problem. i have installed the new cert correctly (i think), but it io wont run, but if i use ; on the cert name in ini, io will start to work. any ideas?
MidKnight is offline   Reply With Quote
Old 05-26-2003, 11:00 AM   #10
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Make sure that certificate name in config matches with the one that certificate manager shows.. (& that certificate type is: Server Authentication)
darkone is offline   Reply With Quote
Old 05-26-2003, 11:26 AM   #11
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

no stats seem to be working at all. im not using the new line nostats in the ini either?
MidKnight is offline   Reply With Quote
Old 05-26-2003, 11:42 AM   #12
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

NoStats must be defined.. otherwise stats aren't recorded

NoStats = * !*
darkone is offline   Reply With Quote
Old 05-26-2003, 11:47 AM   #13
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

yep i had it to begin with, and have it back in as you have it written, but still nothing. what there be any problems because i use other stat message files?
MidKnight is offline   Reply With Quote
Old 05-26-2003, 12:18 PM   #14
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Shouldn't be
darkone is offline   Reply With Quote
Old 05-26-2003, 08:04 PM   #15
MidKnight
Senior Member
FlashFXP Beta Tester
ioFTPD Registered User
 
Join Date: Oct 2001
Posts: 857
Default

darkone i put the latest version you sent out this morning, and the stats are working again. but something else that was a problem and still is, if site who is run, the dir list still says

p: /

no matter where a user is
MidKnight is offline   Reply With Quote
Reply

Tags
fixed, flags, status, work, [+]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:19 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)