Go Back   FlashFXP Forums > > > >

General Discuss anything and everything related to FlashFXP

 
 
Thread Tools Display Modes
Old 02-10-2003, 12:48 AM   #1
ScaledWyrm
Junior Member
 
Join Date: Feb 2003
Posts: 2
Default Failure to transfer

I am trying to FTP files, but some files just don't work.

For example:

WinSock 2.0
Connecting to MySite
Connected to xxx.xxx.x.xxx Port 21
220 Please enter your login name now.
USER ____
331 Password required for ____.
PASS (hidden)
230 User ____ logged in , proceed.
SYST
215 UNIX Type: L8
REST 100
502 rest is not implemented.
This site may not allow file resuming
*Repeats some things*
PASV
502 pasv is not implemented.
PORT 192,168,1,100,14,119
200 Port command ok.
LIST
150 Opening ASCII data connection for ls /F/file/.
226 Transfer finished successfully. Data connection closed.
PASV
502 pasv is not implemented.
PORT 192,168,1,100,14,120
200 Port command ok.
STOR Movie1.avi
426 Connection closed , file opening failed.
Transfer Failed!
PASV
502 pasv is not implemented.
PORT 192,168,1,100,14,121
200 Port command ok.
STOR Movie2.avi
426 Connection closed , file opening failed.
Transfer Failed!
CWD /F/
250 "/F/" is current directory.
PWD
257 "/F/" is current directory
List (cached)
List Complete.
Transfer queue completed
2 Files failed to transfer

The .avi files are DivX format, but I don't think that's the problem.

Running XP with Service Pack 1.
FlashFXP v. 2.0 build 906.

If you need any more info, post.
ScaledWyrm is offline  
Old 02-10-2003, 01:00 AM   #2
Linkster
Moderator
Administrator
 
Join Date: Oct 2001
Location: New Mexico, USA
Posts: 1,070
Default

the site you are connecting to does not support passive mode...disable pasv and it should work. Note that if you are behind a router you will have to do some tweaking to get non-pasv mode to work.
Linkster is offline  
Old 04-07-2003, 11:41 PM   #3
ScaledWyrm
Junior Member
 
Join Date: Feb 2003
Posts: 2
Default

Now it simply says that the file opening failed.
What tweaking do I need to do.
I am behind a Linksys router.

~ScaledWyrm

P.S. Yes, I know that this reply is incredibly long after the question.
ScaledWyrm is offline  
Old 04-08-2003, 03:13 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The listing was successful so I suspect the router isn't the problem, perhaps you don't have permission to upload files into this folder?


To use PORT behind a router.

You need to open a range of ports on your router/firewall, depending on your ftp activity the more the better. I recommend starting with 10 and opening more later if needed. When deciding on the port number it must be a port above 1024, most ftp servers will reject attempts from lower port numbers. I use 7000-7010 and that works well for me.

Now that you have the port forwarding configured on the firewall you need to configure FlashFXP. Options -> Preferences > Firewall Tab. Check the option "Limit local port range to" and enter the same range of ports that you entered in your router 7000-7010.

If you still encounter problems you may need to use the "Bind sockets to this address" option, in the address field you need to enter the IP address assigned to you by your isp.
bigstar is offline  
 

Tags
connection, failed, pasv, port, transfer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:22 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)