Go Back   FlashFXP Forums > > > >

FlashFXP 4.0 RC 2 Use this forum to ask questions, make suggestions, or provide feedback for FlashFXP 4.0 RC 2.

 
 
Thread Tools Display Modes
Old 10-24-2010, 10:18 AM   #1
ronny.perinke
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 5
Exclamation Problem while Establishing TLSv1 Connection

I'm having a problem with Build 1488 when I try to connect to a ftp server using explicit SSL (Auth TLS). The connection process hangs when negotiating the TLSv1 connection.

The problem seems to occur randomly but when it won't go away for a while once it occurred.

I had no such problem with the previous build (1486).
ronny.perinke is offline  
Old 10-24-2010, 05:54 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,881
Default

connection hangs or whole flashfxp?
post session log
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 10-25-2010, 02:34 PM   #3
ronny.perinke
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 5
Default

connection hangs/times out and there seems to be no reason for the timeout

I've attached the logs of two sessions where the connectioned worked and then times out at the next reconnect for no reason. here is what happend on the server side of the second session.

Code:
Oct 25 21:25:46 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] New connection from 94.134.218.245
Oct 25 21:25:47 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-SHA, 256 secret bits cipher
Oct 25 21:25:47 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] XXXXXX is now logged in
Oct 25 21:25:50 ds83-169-61-112 pure-ftpd: (XXXXXX@94.134.218.245) [INFO] Logout.
Oct 25 21:25:56 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] New connection from 94.134.218.245
Oct 25 21:26:15 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [ERROR] SSL/TLS [/etc/ssl/private/pure-ftpd.pem]: error:00000000:lib(0):func(0):reason(0)
Oct 25 21:26:25 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] New connection from 94.134.218.245
Oct 25 21:26:26 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] SSL/TLS: Enabled TLSv1/SSLv3 with AES256-SHA, 256 secret bits cipher
Oct 25 21:26:26 ds83-169-61-112 pure-ftpd: (?@94.134.218.245) [INFO] XXXXXX is now logged in
Oct 25 21:27:01 ds83-169-61-112 pure-ftpd: (XXXXXX@94.134.218.245) [INFO] Logout.
Attached Files
File Type: txt session.txt (6.7 KB, 253 views)
File Type: txt session 1.txt (7.0 KB, 335 views)
ronny.perinke is offline  
Old 10-25-2010, 05:56 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I reviewed my development repository of all changes made between builds 1486 and 1489 and there are no changes to the FTP SSL/TLS routines.

Is it possible that maybe a 3rd party program such as anti-virus or firewall is conflicting with FlashFXP?
bigstar is offline  
Old 10-28-2010, 04:18 PM   #5
ronny.perinke
Junior Member
FlashFXP Registered User
 
Join Date: Jul 2005
Posts: 5
Default

Hm, could be possible because I've changed my complete router-pc. Maybe I can find something in the logs. :|
ronny.perinke is offline  
Old 10-29-2010, 11:47 AM   #6
Blubi
Member
FlashFXP Beta Tester
 
Join Date: Oct 2007
Posts: 86
Default

I had such issue at work and solved it by forwarding the necessary ports (server was FileZilla) in hardware and software firewall.
Blubi is offline  
 

Tags
build, connection, ftp, problem, tlsv1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:06 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)