Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 03-22-2005, 12:23 PM   #1
Oti
Junior Member
 
Join Date: Mar 2005
Posts: 3
Question ASCII transfers



* FlashFXP v[3.0.2] build [1045 ], [X ]registered, [ ]unregistered, [ ]pirated
* OS [X] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [X] Yes & Model [Gigabyte], [ ] No, [ ] Not sure
* Running firewall [ ] Yes, Name [ ], Ver. [ ], or [X] No
* Running Antivirus [X] Yes, Name [Norton Antivirus] or [ ] No
* Network [X] xDSL, [ ] CABLE, [ ] Dail-Up, [ ] Other


Hi,

When using ftp-software WS_FTP PRO and uploading my perl-script in ASCII mode the CR+LF (DOS) is changed to LF (UNIX), and when downloading back the file in ASCII-mode it is converted back from LF (Unix) to DOS (CR+LF).

Can't get that to work in FlashFXP (v.3.0.2. build 1045). My uploaded files with CR+LF seems to be stored that way on the remote site too, even though FlashFXP transfer the file in ASCII-mode.

Please help me out. I'm I doing anything wrong?

It works fine in WS_FTP PRO, though.

With best regards
Stefan In Sweden
Oti is offline  
Old 03-22-2005, 03:31 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

post status log to make sure that it is actually sending/recieving in ASCII..
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-23-2005, 01:06 AM   #3
Oti
Junior Member
 
Join Date: Mar 2005
Posts: 3
Default Log

Here's the log.


WinSock 2.0 -- OpenSSL 0.9.7d 17 Mar 2004
[R] Connecting to Glidecom -> DNS=ftp2.glidecom.se IP=212.85.69.21 PORT=21
[R] Connected to Glidecom
[R] 220 "Welcome to FTP server on ftp2.glidecom.se."
[R] USER jaha
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful. Have fun.
[R] SYST
[R] 215 UNIX Type: L8
[R] REST 100
[R] 350 Restart position accepted (100).
[R] REST 0
[R] 350 Restart position accepted (0).
[R] CWD /public_html/
[R] 250 Directory successfully changed.
[R] PWD
[R] 257 "/public_html"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,22,12)
[R] Opening data connection IP: 212.85.69.21 PORT: 5644
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
[R] List Complete: 4_068 bytes in 0,19 seconds (21,2 KB/s)
[R] CWD test
[R] 250 Directory successfully changed.
[R] PWD
[R] 257 "/public_html/test"
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,68,206)
[R] Opening data connection IP: 212.85.69.21 PORT: 17614
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
[R] List Complete: 115 bytes in 0,19 seconds (0,6 KB/s)
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,206,71)
[R] Opening data connection IP: 212.85.69.21 PORT: 52807
[R] STOR bilder.htm
[R] 150 Ok to send data.
[R] 226 File receive OK.
Transferred: bilder.htm 26_767 bytes in 0,25 seconds (104,6 KB/s)
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,206,62)
[R] Opening data connection IP: 212.85.69.21 PORT: 52798
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
[R] List Complete: 181 bytes in 0,14 seconds (1,3 KB/s)
Transfer queue completed
Transferred 1 file totaling 26_767 bytes in 0,58 seconds (104,6 KB/s)
Oti is offline  
Old 03-23-2005, 03:49 AM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

interesting.
ok, try this
F6, transfer tab, uncheck 'smart mode handling' and see if that makes any difference
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 03-23-2005, 05:55 AM   #5
Oti
Junior Member
 
Join Date: Mar 2005
Posts: 3
Default

This forced FlashFXP to send the mode-command on each transfer, but the result is the same. On the remote ftp-server the file is saved WITH CR+LF (DOS) and not with LF (UNIX).

Perhaps this is the remote ftp-server's setup causing this? What do you think?

//Stefan


WinSock 2.0 -- OpenSSL 0.9.7d 17 Mar 2004
[R] Connecting to Glidecom -> DNS=ftp2.glidecom.se IP=212.85.69.21 PORT=21
[R] Connected to Glidecom
[R] 220 "Welcome to FTP server on ftp2.glidecom.se."
[R] USER jaha
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful. Have fun.
[R] SYST
[R] 215 UNIX Type: L8
[R] REST 100
[R] 350 Restart position accepted (100).
[R] REST 0
[R] 350 Restart position accepted (0).
[R] CWD /public_html/
[R] 250 Directory successfully changed.
[R] PWD
[R] 257 "/public_html"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,65,121)
[R] Opening data connection IP: 212.85.69.21 PORT: 16761
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
[R] List Complete: 4_068 bytes in 0,17 seconds (23,1 KB/s)
[R] CWD test
[R] 250 Directory successfully changed.
[R] PWD
[R] 257 "/public_html/test"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,144,92)
[R] Opening data connection IP: 212.85.69.21 PORT: 36956
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
[R] List Complete: 115 bytes in 0,23 seconds (0,5 KB/s)
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,113,76)
[R] Opening data connection IP: 212.85.69.21 PORT: 29004
[R] STOR tagbox.pl
[R] 150 Ok to send data.
[R] 226 File receive OK.
Transferred: tagbox.pl 8_534 bytes in 0,25 seconds (33,3 KB/s)
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (212,85,69,21,186,246)
[R] Opening data connection IP: 212.85.69.21 PORT: 47862
[R] LIST -al
[R] 150 Here comes the directory listing.
[R] 226 Directory send OK.
[R] List Complete: 180 bytes in 0,19 seconds (0,9 KB/s)
Transfer queue completed
Transferred 1 file totaling 8_534 bytes in 0,67 seconds (33,3 KB/s)
Oti is offline  
Old 03-23-2005, 05:41 PM   #6
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

ya, sounds like it..since i can't remember anybody else complain their ascii not being transfered as such
try regular windows ftp.exe and see what will happen.
if same result then it is server issue
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Closed Thread

Tags
cr+lf, flashfxp, pro, running, [x]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
W32/Sobig-F bigstar News 9 09-10-2003 11:01 PM


All times are GMT -5. The time now is 07:41 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)