Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 11-20-2015, 10:11 AM   #1
andreas
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2002
Posts: 484
Default SiteManager not loading bookmarks

Today I have started flashfxp and it didnt load my bookmarks!
I attach two images.

Capture2.png shows the site but the structure on the left is missing!

Capture.png After many restarts it loaded the bookmarks but names didnt appear!


The problem still appears so I can provide you any info you might want
The problem is the same in English / Greek language
Attached Thumbnails
SiteManager not loading bookmarks-capture-png   SiteManager not loading bookmarks-capture2-png  

Last edited by andreas; 11-24-2015 at 03:35 PM.
andreas is offline  
Old 11-20-2015, 05:34 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I wonder if this is an OS related issue, could you please try restarting Windows and see if it solves the problem.
bigstar is offline  
Old 11-24-2015, 03:03 AM   #3
andreas
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2002
Posts: 484
Default

It doesnt

I will keep a copy of files and I will reinstall Flashfxp on top of the current installation
andreas is offline  
Old 11-24-2015, 03:31 AM   #4
andreas
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2002
Posts: 484
Default

After doing a clean install everything seems to be fine.

Additionally, I had copied sites.dat, ca_root.pem , cert.dat & deleted Sites.dat
(I had to move all settings from an other installation)
Again no problem
andreas is offline  
Old 11-24-2015, 02:48 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hmm. Do you have back ups of all the data files from the broken installation?

It would be extremely helpful if we could determine exactly which data file was causing this problem

Even more specifically if we could determine what malformed or corrupt value/data resulted in this problem.

If you have a backup of the data files could you please install the portable edition into a custom location and test with the original data files, removing one by one until the problem is solved.

The files used by the Site Manager are cert.dat, bookmarks.dat, stats.dat, quick.dat, and sites.dat

I would test them in that order if possible.

I am still investigating this issue to determine what lead to this problem.

BTW you back easily backup/restore your whole ffxp config from within FlashFXP under the main menu > Tools > Backup/Restore Configuration
bigstar is offline  
Old 11-24-2015, 03:34 PM   #6
andreas
Senior Member
FlashFXP Beta Tester
 
Join Date: Jul 2002
Posts: 484
Default

Quote:
Originally Posted by bigstar View Post
BTW you back easily backup/restore your whole ffxp config from within FlashFXP under the main menu > Tools > Backup/Restore Configuration
Does this work even if sites.dat is encrypted?
I think I will have to encrypt again after moving to the new PC.
However, if I manually copy the above files, from now on I have only to copy only sites.dat to keep them in sync.
andreas is offline  
Old 11-24-2015, 04:30 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by andreas View Post
Does this work even if sites.dat is encrypted?
I think I will have to encrypt again after moving to the new PC.
However, if I manually copy the above files, from now on I have only to copy only sites.dat to keep them in sync.
Yes this is compatible with the Application Password Protection feature.

When restoring from the backup you'll be prompted to re-enter the original password used when the backup was created, and Application Password Protection will remain enabled.

If you copy the sites.dat between machines with Application Password protection enabled on machine #1 you need to make sure that it is also enabled on machine #2 as well, before you copy over the file, otherwise the sites.dat will be encrypted and the other other data files will not be encrypted, this will most likely lead to unexpected problems.

In fact it just dawned on me that this type of situation might explain some customers reported issues I've dealt with in the past where some data files were not encrypted even though application password protection was active.
(This is something I will need to look into for future reference)
bigstar is offline  
Closed Thread

Tags
flashfxp, bookmarks, names, problem, loaded, restarts, capture.png, appears, info, provide

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:24 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)