Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 09-27-2015, 06:43 PM   #16
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Did i miss something ?
It sounds like the webroot isn't properly setup in the Site Manager for the site, if it was then /public_html/ would be stripped, are you 100% sure that /public_html/ is the correct?

Connect to the server and see if the file uploaded into the correct location, if not you may need to change the remotepath and the webroot

The url will be copied to the clipboard on success and even on a failure, if it failed to upload you'll still end up with the url on the clipboard.

Last edited by bigstar; 09-27-2015 at 07:30 PM.
bigstar is offline  
Old 09-27-2015, 11:17 PM   #17
mitch
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2006
Posts: 20
Default

Quote:
Originally Posted by bigstar View Post
It sounds like the webroot isn't properly setup in the Site Manager for the site, if it was then /public_html/ would be stripped, are you 100% sure that /public_html/ is the correct?

Connect to the server and see if the file uploaded into the correct location, if not you may need to change the remotepath and the webroot

The url will be copied to the clipboard on success and even on a failure, if it failed to upload you'll still end up with the url on the clipboard.
100%

Copy URL mapping says the following (screenshot program not working at the moment)

HTTP URL:: Web Design & IT Support for Small Businesses in Sydney
Server Web Root Path: /home/menkomco/public_html/

Screenshot working again... see the following as confirmation of the path when i access the path via ftp:
http://i.imgur.com/1pGEHZW.jpg

Arguments:
/tray /overwrite /upload \Menkom Server\menkom.com.au /localpath="{0}" /remotepath="/public_html/" /gs=cb /quit

I think it has something to do with the remotepath overriding the settings.

Last edited by bigstar; 09-28-2015 at 07:53 AM. Reason: More info
mitch is offline  
Old 09-28-2015, 07:55 AM   #18
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Try this, change /remotepath="/public_html/" to /remotepath="/home/menkomco/public_html/"
bigstar is offline  
Old 09-28-2015, 09:05 AM   #19
mitch
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2006
Posts: 20
Default

Quote:
Originally Posted by bigstar View Post
Try this, change /remotepath="/public_html/" to /remotepath="/home/menkomco/public_html/"
No that didnt work, see screenshot... not a valid path
http://i.imgur.com/pYYs4bi.jpg

The reason that the /home/menkomco/public_html wont work is because the login credentials are user level not root level, if i was loging in as root then that might work.

As suspected it did work when i used the root login details, which i really dont want to do if possible as im not sure what is transmitted.

However, with root the full home directory path works with the above settings. Here is the end result of the file uploaded.

http://www.menkom.com.au/2015_09_29_...3_Films_TV.jpg

Hopefully we can get it to work at a user level

Last edited by mitch; 09-28-2015 at 05:52 PM. Reason: More info:
mitch is offline  
Old 09-29-2015, 05:45 AM   #20
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I just created a new site entry to test and verify that this is working as expected and with my new entry here's what I got



And in Greenshot I am using this

Command:
Code:
C:\Program Files (x86)\FlashFXP 5\FlashFXP.exe
Argument:
Code:
/quit /tray /overwrite /upload "\test server" /localpath="{1}" /remotepath="/public_html/" /gs=cb
The screenshot in my post was taken with this configuration.

The only other thing I can think of is maybe you need to quote the site name like I did above when using "\test server" since it contains a space. "\Menkom Server\menkom.com.au"

You could omit the /quit and check the server session log window to see whats going on.

Last edited by bigstar; 09-29-2015 at 07:32 AM.
bigstar is offline  
Old 09-29-2015, 09:13 AM   #21
mitch
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2006
Posts: 20
Default

Quote:
Originally Posted by bigstar View Post
I just created a new site entry to test and verify that this is working as expected and with my new entry here's what I got



And in Greenshot I am using this

Command:
Code:
C:\Program Files (x86)\FlashFXP 5\FlashFXP.exe
Argument:
Code:
/quit /tray /overwrite /upload "\test server" /localpath="{1}" /remotepath="/public_html/" /gs=cb
The screenshot in my post was taken with this configuration.

The only other thing I can think of is maybe you need to quote the site name like I did above when using "\test server" since it contains a space. "\Menkom Server\menkom.com.au"

You could omit the /quit and check the server session log window to see whats going on.
Workssssssssssssssssssss.

Was probably the "" around the server name..... so it could've been that.

You have been a great help i will notify Greenshot author of your instructions to get Greenshot to work with Flashfxp and hopefully the do a blogpost out of it like they did for Winscp as i think it will benefit other users.
mitch is offline  
Closed Thread

Tags
flashfxp, ftp, upload, achieve, cheers, give, time, clear, instructions, paypal

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:26 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)