Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 03-02-2014, 10:51 AM   #1
roboticsguy
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2010
Posts: 9
Default No longer works after update! Where can I download an older version?

I believe I installed an update for FlashFXP yesterday and now it no longer works. Is there somewhere that I can download the previous release from? I *really* need to get a lot of work done today and I'm totally stuck without a working FTP client.

At first I was getting the error "Data Socket Error: Connection timed out," then it wouldn't connect to my server at all, and now it connects after trying for a *very* long time, but says:

":44:57] [R] 227 Entering Passive Mode...
[10:44:57] [R] Opening data connection IP: ... PORT: 39024
[10:45:18] [R] Data Socket Error: Connection timed out
[10:45:19] [R] List Error
[10:45:19] [R] PASV mode failed, trying PORT mode.
[10:45:19] [R] Listening on PORT: 3358, Waiting for connection.
[10:45:19] [R] PORT ...
[10:45:19] [R] 200 PORT command successful
[10:45:19] [R] MLSD
[10:45:19] [R] 150 Connecting to port 3358
[10:45:19] [R] 226-Options: -a -l
[10:45:19] [R] 226 14 matches total
[10:45:19] [R] List Complete: 1 KB in 0.10 second (1.5 KB/s)
[10:45:19] [R] PORT mode was successful, Please update the data connection mode in your site profile."

Nothing changed on my end and my hosting company said that the server was working perfectly fine.

Please help!
roboticsguy is offline  
Old 03-02-2014, 10:56 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Hello,

Previous releases can be downloaded from our web archive located at
http://down1.opensightsoftware.com/archives/

I understand that it is critical that you get FlashFXP back up and working but I do have a few questions that will help us resolve the problem.

What version of Windows OS are you using?

What version of FlashFXP did you upgrade to?

Please verify that the version of FlashFXP installed is in fact the latest, do a manual update check (Main menu > Help > Check for new version) or compare against the version listed on the website https://oss.azurewebsites.net/download

What version of FlashFXP did you upgrade from?

Are you using a software firewall, if so which one?

Some firewalls require re-authorization to allow FlashFXP to work after an update.

--
Update:
Also since Active mode is working you might consider changing the "Data connection mode" in the site manager from "Passive mode" to "Active mode"

One thought is that perhaps the firewall or the firewall configuration changed on the machine running the FTP server and it is now blocking passive mode FTP connections.
bigstar is offline  
Old 03-02-2014, 11:13 AM   #3
roboticsguy
Junior Member
FlashFXP Registered User
 
Join Date: Sep 2010
Posts: 9
Default

Thank you for such a quick response!

Quote:
Originally Posted by bigstar View Post
What version of Windows OS are you using?
Windows 7 Professional.

Quote:
Originally Posted by bigstar View Post
What version of FlashFXP did you upgrade to?
V4.4.4, build 2035.

Quote:
Originally Posted by bigstar View Post
Please verify that the version of FlashFXP installed is in fact the latest, do a manual update check (Main menu > Help > Check for new version) or compare against the version listed on the website https://oss.azurewebsites.net/download
"There is no upgrade available at this time"


Quote:
Originally Posted by bigstar View Post
What version of FlashFXP did you upgrade from?

Are you using a software firewall, if so which one?

Some firewalls require re-authorization to allow FlashFXP to work after an update.

--
Update:
Also since Active mode is working you might consider changing the "Data connection mode" in the site manager from "Passive mode" to "Active mode"

One thought is that perhaps the firewall or the firewall configuration changed on the machine running the FTP server and it is now blocking passive mode FTP connections.
I believe just the previous version, whatever that was (4.4.3?)


Quote:
Originally Posted by bigstar View Post
Are you using a software firewall, if so which one?

Some firewalls require re-authorization to allow FlashFXP to work after an update.
I'm using the Windows Firewall. I also have Avast! IS installed, but I have it's firewall disabled.

Yes, the usual Firewall box did pop up. I checked for it to allow access on both public and private networks.

Quote:
Originally Posted by bigstar View Post
Also since Active mode is working you might consider changing the "Data connection mode" in the site manager from "Passive mode" to "Active mode"
From what I understand (which isn't much), that could create another slew of problems.

Quote:
Originally Posted by bigstar View Post
One thought is that perhaps the firewall or the firewall configuration changed on the machine running the FTP server and it is now blocking passive mode FTP connections.
Hosting company said nothing changed on the server.

I will try installing a previous version and see if that fixes it. I really hope it does..
roboticsguy is offline  
Old 03-02-2014, 01:10 PM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

If that doesn't work you may want to try upgrading to the latest very latest version (4.4.4 build 2038)
https://oss.azurewebsites.net/download

(This release is only available via LiveUpdate when the release type is set to beta and stable updates.)
bigstar is offline  
Old 03-02-2014, 01:18 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by roboticsguy View Post
From what I understand (which isn't much), that could create another slew of problems.
From my point of view.. FlashFXP is configured to use passive mode, when attempting to use passive mode it fails, FlashFXP then attempts to use active mode which is then successful. This is basically telling you that active mode is working where passive mode is failing. To get around the delays every time you connect to the server you need to change the data connection mode from passive mode to active mode...

Based on your log we already know that this should work without any issues, however if it does somehow create some other issues you can switch back to passive mode. In the site manager there's a notes section, you could make a note for example "2014-03-02 :: Switched data connection mode from passive mode to active mode"
bigstar is offline  
Closed Thread

Tags
download, flashfxp, ftp, [104519], [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:20 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)