Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 04-19-2008, 11:59 AM   #1
codeseven
Junior Member
 
Join Date: Apr 2008
Posts: 6
Default Site To Site Transfer Problem

I'm trying to transfer one file of folders from one server to another. When I try it comes up with messages like:

[L] 500 I won't open a connection to xx.x.x.x.x. (only to xx.xx.xx.xx)
Site to Site Transfer Failed! (Attempting alternative method)
[L] 227 Entering Passive Mode
[R] 550 (done!) 60mb in 18 files: Permission denied.


And then when I go back to where I was uploading to, the directory name is there, but when I go inside there are no files except one that looks like this: .pureftp-upload.xx.xx.xx.xx. Does anybody have any clue on what's going on?
codeseven is offline  
Old 04-19-2008, 01:55 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

seems like fxp transfer is disabled on both servers.
post more of the log before and after
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 04-26-2008, 06:56 PM   #3
codeseven
Junior Member
 
Join Date: Apr 2008
Posts: 6
Default

Code:
[R] TYPE I
[R] 200 Type set to I.
[L] TYPE I
[L] 200 Type set to IMAGE.
[L] MODE S
[L] 200 MODE set to stream.
[R] PROT C
[R] 200 Protection set to Clear
[R] PASV
[R] 227 Entering Passive Mode (xx.xx.xx.xx.xx.xx)
[L] PORT xx.xx.xx.xx.xx.xx
[L] 200 Port command ok.
[L] STOR readme.mp3
[L] 150 Opening BINARY data connection for /readme.mp3 (STREAM)
[R] RETR readme.mp3
[R] 150 Opening BINARY mode data connection for readme.mp3 (1 bytes).
[R] 522 You have to turn on secure data connection.
[R] ABOR
[R] 225 ABOR command successful.
[L] ABOR
[L] Transfer Failed!
[L] TYPE A
[L] 502 ÿô is not implemented.
[L] MODE Z
[L] 200 Type set to ASCII.
[L] PASV
[L] 200 MODE set to ZLIB.
[L] 227 Entering Passive Mode (xx.xx.xx.xx.xx)
[L] Listening on PORT: xxx, Waiting for connection.
[L] PORT xx.xx.xx.xx.xx
[L] 425 Cannot open data connection .
[L] List Error
[R] TYPE A
[R] 200 Type set to A.
[R] PROT P
[R] 200 Protection set to Private
[R] PASV
[R] 227 Entering Passive Mode (xx.xx.xx.xx.xx.xx)
[R] Opening data connection IP: xx.xx.xx.xx.xx PORT: xxx
[R] LIST -al
[R] Connected. Negotiating TLSv1 session..
[R] 150 Opening ASCII mode data connection for directory listing using SSL/TLS.
[R] TLSv1 negotiation successful...
[R] TLSv1 encrypted session using cipher DHE (256 bits)
[R] List Complete: 1 KB in 0.49 seconds (3.1 KB/s)
Transfer queue completed
1 File failed to transfer
codeseven is offline  
Old 04-26-2008, 07:08 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

session log you pasted doesn't have any useful errors
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 04-26-2008, 07:11 PM   #5
codeseven
Junior Member
 
Join Date: Apr 2008
Posts: 6
Default

hmmm, that's the log.

what about "522 You have to turn on secure data connection". does that mean anything?
codeseven is offline  
Old 04-26-2008, 07:27 PM   #6
codeseven
Junior Member
 
Join Date: Apr 2008
Posts: 6
Default

one site is using tsl and the other is using nothing. could that be a problem?
codeseven is offline  
Old 04-29-2008, 11:03 AM   #7
codeseven
Junior Member
 
Join Date: Apr 2008
Posts: 6
Default

any input?
codeseven is offline  
Old 04-29-2008, 04:43 PM   #8
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

need to see more of the session log
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 04-29-2008, 04:49 PM   #9
DayCuts
Senior Member
FlashFXP Beta Tester
 
Join Date: Dec 2003
Posts: 421
Default

Quote:
[R] 150 Opening BINARY mode data connection for readme.mp3 (1 bytes).
[R] 522 You have to turn on secure data connection.
This server is indicating that is REQUIRES a secure data connection, that means you MUST use ssl/tls for the upload/download/fxp (whichever it is you are trying to do).

In order for this to work for fxp, you must have 'secure site to site transfers' turned on for BOTH servers involved in the fxp transfer. (assuming they both support it)

Depending on the configurations of the two servers, you may also need to toggle the 'turn off fingerprint checking on data connection' setting on or off to get it working.
DayCuts is offline  
Closed Thread

Tags
directory, files, site, transfer, [l]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:07 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)