Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 02-02-2008, 04:49 AM   #1
Warlord2k
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2008
Posts: 7
Thumbs down Vista Ultimate x64

Oki. Here we go..

I got XP 32 and Vista 64 on dualboot.

XP can download and upload, Vista can't..
Servicepack 1 is installed for Vista.

[R] TYPE I
[R] 200 Type set to I.
[R] PROT P
[R] 200 Protection set to Private
[R] PASV
[R] 425 Can't open passive connection: Cannot assign requested address.
[R] PORT 192,168,0,100,206,13
[R] 200 PORT command successful.
[R] RETR babylon-podcast-live-20071107.mp3
Transfer Timed Out
[R] ABOR
[R] Transfer Failed!

I've tried all different settings in site-manager..

Done the check 1 and try.. Nothing solved..
Warlord2k is offline  
Old 02-02-2008, 01:29 PM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

what does the ftp session log look like when running from XP?
bigstar is offline  
Old 02-02-2008, 02:54 PM   #3
Warlord2k
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2008
Posts: 7
Default

[R] List Complete: 276 bytes in 5,24 seconds (0,1 KB/s)
[R] TYPE I
[R] 200 Type set to I.
[R] PASV
[R] 425 Can't open passive connection: Cannot assign requested address.
[R] PORT 192,168,0,100,15,156
[R] 200 PORT command successful.
[R] RETR sample.avi
[R] Connected. Negotiating TLSv1 session..
[R] 150 Opening BINARY mode data connection for sample.avi (15001600 bytes) using SSL/TLS.
[R] TLSv1 negotiation successful...
[R] TLSv1 encrypted session using cipher DHE-DSS-RC4-SHA (128 bits)
[R] 226- [Ul: 53502.0MB] [Dl: 1035574.8MB] [Speed: 27737.28K/s] [Free: 808802MB]
[R] 226 [Section: DEFAULT] [Credits: 9.8MB] [Ratio: Unlimited]
Transferred: sample.avi 14,31 MB in 0,52 seconds (27,78 MB/s)
Warlord2k is offline  
Old 02-02-2008, 02:55 PM   #4
Warlord2k
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2008
Posts: 7
Default

hmmm.

When thinking about it.. Vista's a ***** about security..

R] PROT P
[R] 200 Protection set to Private
I guess that's Vista-related?
Warlord2k is offline  
Old 02-02-2008, 03:04 PM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

PROT P has nothing to do with vista.
however it looks like vista's firewall is blocking data channel connections.
another thing, server you are connecting to is broken
Quote:
[R] 425 Can't open passive connection: Cannot assign requested address.
tell server administrator to fix his server and then flashfxp will work in xp and vista, w/o you having to make any changes on your end.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 02-02-2008, 03:39 PM   #6
Warlord2k
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2008
Posts: 7
Default

Well, as u see in XP, it works smoothly..(check the speed).

but that it can be the cause in Vista, that might be... I'll bug the admin to see if he can change the settings so it will work on LAN too..
Warlord2k is offline  
Old 02-02-2008, 03:47 PM   #7
Warlord2k
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2008
Posts: 7
Default

Dohh!! I feel soo n00b... Vista Firewall.. Thank you soo much MxxCon
*rams head into wall*

U can delete this topic.
Warlord2k is offline  
Old 02-02-2008, 11:16 PM   #8
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

Quote:
Originally Posted by Warlord2k View Post
Well, as u see in XP, it works smoothly..
it doesn't work smoothly.
in both xp and vista when you send PASV command you get an error message
Quote:
[R] 425 Can't open passive connection: Cannot assign requested address.
in both cases flashfxp fall back on PORT command.
all properly configured servers should support PASV command, so admin needs to fix his server.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 02-03-2008, 05:55 AM   #9
Warlord2k
Junior Member
FlashFXP Registered User
 
Join Date: Jan 2008
Posts: 7
Default

It is fixed now. Problem was trivial. IP on the server on the LAN had changed. It only affected me as a user, not the WAN-users.
Warlord2k is offline  
Closed Thread

Tags
200, download, upload, vista, [r]

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:50 AM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)