Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 01-10-2008, 10:35 AM   #1
jekki
Junior Member
 
Join Date: Jan 2008
Posts: 4
Question error message: 425

A better day for everybody & happy new year.

My OS is WinXP pro. Having tried to reach a device behind a router in my home network from the Inet via fxp, i always got this error message (s. attachment), although the connection seems to be alright. I myself tried to solve the problem, and looked for information in the net (there are many about this subject), but i am not an expert at all and so the lingo couldn't help me much.

I hope somebody here can tell me what to do.

Thanks in advance.
Best regards.
Attached Thumbnails
error message: 425-ftp-jpg  
jekki is offline  
Old 01-10-2008, 11:47 PM   #2
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

enable pasv mode and try again
and next time instead of making a screenshot, just copy/paste text
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-11-2008, 08:58 AM   #3
jekki
Junior Member
 
Join Date: Jan 2008
Posts: 4
Default

Thank you for the answer.
It is weird. There wasn't any change (s. log):

[R] Connecting to dream -> DNS=j IP= PORT=1952
[R] Connected to dream
[R] 220 Welcome to the OpenDreambox FTP service.
[R] USER root
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,31,96)
[R] Opening data connection IP: PORT: 8032
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,200,250)
[R] Opening data connection IP: PORT: 51450
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV mode failed, trying PORT mode.
[R] Listening on PORT: 1319, Waiting for connection.
[R] PORT
[R] 200 PORT command successful. Consider using PASV.
[R] LIST -al
[R] 425 Failed to establish connection.
[R] List Error
[R] NOOP
[R] 200 NOOP ok.

I marked (by accident or by test) "Use 'Stat -L' to list directory" AND I GOT THE CONNECTION (s. log.):

[R] Connecting to dream -> DNS= IP= PORT=1952
[R] Connected to dream
[R] 220 Welcome to the OpenDreambox FTP service.
[R] USER root
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] STAT -la
[R] List Complete: 1 KB in 0,23 seconds (5,3 KB/s)


I was on my remote device, i could rename files etc. BUT up- and download still don't work (s.log):

[R] TYPE I
[R] 200 Switching to Binary mode.
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,119,70)
[R] Opening data connection IP: PORT: 30534
[R] Data Socket Error: Connection timed out
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,222,123)
[R] Opening data connection IP: PORT: 56955
[R] Data Socket Error: Connection timed out
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,240,165)
[R] Opening data connection IP: PORT: 61605
[R] Data Socket Error: Connection timed out
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,190,195)
[R] Opening data connection IP: PORT: 48835
[R] Data Socket Error: Connection timed out
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,128,70)
[R] Opening data connection IP: PORT: 32838
[R] Data Socket Error: Connection timed out
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,206,161)
[R] Opening data connection IP: 85.178.215.249 PORT: 52897
[R] Data Socket Error: Connection timed out
[R] Transfer Failed!
Transfer queue completed
1 File failed to transfer
[R] NOOP
[R] 200 NOOP ok.

I am desperate. Any idea?

Thanks
jekki is offline  
Old 01-11-2008, 02:08 PM   #4
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

https://oss.azurewebsites.net/forum/showthread.php?t=4275
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-11-2008, 02:46 PM   #5
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

The "Use 'Stat -L' to list directory" option doesn't use a separate data channel to get the directory listing, a data channel using PASV or PORT is required for file transfers.

I'm not sure if you've edited your ftp log or something is seriously wrong but normally when the PORT command is sent it includes an IP/PORT similar to this "PORT 10,1,1,10,29,91", without this information it's really hard to determine issues with PORT. if the only thing being displayed is PORT then I'd recommend you make sure you're using the latest version and re-install FlashFXP because something isn't right.
bigstar is offline  
Old 01-12-2008, 07:06 AM   #6
jekki
Junior Member
 
Join Date: Jan 2008
Posts: 4
Default

Good day bigstar,


Thanks again. Here is the log again (i only edited data about which i thought better not to make public), the stat L- option is not marked now.
-----------------------------------------------------------

v. 3.4.0 (build 1145), registered, WinXP pro, behind firm firewall server & personal firwall McAfee, antivirus McAfee, high speed network

-----------------------------------------------------------

LOG:

WinSock 2.0 -- OpenSSL 0.9.8b 04 May 2006
[R] Connecting to dream -> DNS=xxxxxxxx IP=xxxxxxxx PORT=1952
[R] Connection failed (Connection timed out)
[R] Delaying for 10 seconds before reconnect attempt #1
[R] Connecting to dream -> DNS=xxxxxxxx IP=xxxxxxxx PORT=1952 (attempt # 1)
[R] Connected to dream
[R] 220 Welcome to the OpenDreambox FTP service.
[R] USER root
[R] 331 Please specify the password.
[R] PASS (hidden)
[R] 230 Login successful.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Features:
[R] EPRT
[R] EPSV
[R] MDTM
[R] PASV
[R] REST STREAM
[R] SIZE
[R] TVFS
[R] 211 End
[R] PWD
[R] 257 "/"
[R] TYPE A
[R] 200 Switching to ASCII mode.
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,224,116)
[R] Opening data connection IP: xxxxxxxxx PORT: 57460
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,31,106)
[R] Opening data connection IP: xxxxxxxxxx PORT: 8042
[R] Data Socket Error: Connection timed out
[R] List Error
[R] PASV mode failed, trying PORT mode.
[R] Listening on PORT: 2137, Waiting for connection.
[R] PORT xxxxxxxxxx,8,89
[R] 200 PORT command successful. Consider using PASV.
[R] LIST -al
[R] 425 Failed to establish connection.
[R] List Error
[R] NOOP
[R] 200 NOOP ok.

Curious: using the same adresse in the home network what i use from the internet to reach the device it works without any problem.
jekki is offline  
Old 01-12-2008, 03:52 PM   #7
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

on your server's firewall, you need to forward 'data connection' port range.

in addition to opening port 21 to connect to the server, you also need to open data connection range to allow dir list and file trasnfers.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 01-12-2008, 03:54 PM   #8
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Now I could be wrong because it's really hard to determine these problems when the log is edited, ideally if you're concerned about showing the IP address these type of issues should be handled via our contact form.

But from what I can make out the ftp server is returning a local network ip for the PASV reply, it should be returning an Internet IP that can be reached outside of your local network.

Automatic support for handling this situation has been added in v3.6 (the current release is RC3) and you can download it at https://oss.azurewebsites.net/beta.php

As for PORT failing the client computer (the one running FlashFXP) probably doesn't have any rules setup to allow incoming connections, You can define the port range in FlashFXP and then these ports need to be allowed in your firewall.
bigstar is offline  
Old 01-13-2008, 05:17 AM   #9
jekki
Junior Member
 
Join Date: Jan 2008
Posts: 4
Default

Good morning,

I GOT IT. I can't explain but it is perhaps because of my router.
I have a D-Link router in my home network. You can define a privat port (80, 8080, 21... for the different protocols) and a public port which can be seen from the net. For FTP my privat port was 21 of course and i choose 1952 as for the public one. Now i change the ports back, i.e. i defined public=privat=21. On this way it works. Maybe my chosen port number 1952 was somehow not acceptible for the router. However i am now satisfied (altough only 99%), and thanks again for your help anyway.
Best regards
jekki is offline  
Closed Thread

Tags
error, expert, fxp, message, net

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:38 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)