Go Back   FlashFXP Forums > >

General Discussion Need help? Have a problem? Let us help you. Bug reports and feature requests should be made using the Bug Tracker or Feature Tracker

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 12-20-2006, 02:15 PM   #1
RobertSmith
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default Problems behind router

Hi, I have just installed FlashFXP and I have problem to transfer files from a SSL server. I have no problem when I don't use the router but behind I can't transfer files.

I know how to do the port forwarding for other programs but I can't find the information I need in the FlashFXP help file (or I don't understand it). Can u pls give me one example of whish port to forward and also what options (F6) I have to change when I’m behind the router?

Thx for a great product that I intend to buy as soon as i got it work

Last edited by RobertSmith; 12-20-2006 at 02:23 PM.
RobertSmith is offline  
Old 12-20-2006, 03:05 PM   #2
sarcon
Junior Member
 
Join Date: Dec 2006
Posts: 3
Default

Hi,
you must setup your router: Port 21 and 20 must to be open. You find it in your router under NAT (Network Adress Translation)
sarcon is offline  
Old 12-20-2006, 04:00 PM   #3
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

sarcon, that information is incorrect. please do not confuse people with instructions from ftp SERVERS.

RobertSmith, F6, Connection, Data Connection, "Limit Local Port Range", pick some unused port range..default 1024-2048 is sufficient but you can change it to any range between 1024 - 65535. and then forward the same port range in your router.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 12-21-2006, 11:12 AM   #4
RobertSmith
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Thx for your quick answers. Could it be so simple that this can't be done with my router D-LINK 624?

For other applications it is enough to do a port forward for only one port and that is done on "virtual server" se picture 1
http://img186.imageshack.us/img186/368/bild2hv6.jpg

I'm not sure if it is possible to forward a range of port, I have tried on "application" with no success
http://img241.imageshack.us/img241/4361/bild1vz9.jpg

This is my settings for options (F6)
http://img186.imageshack.us/my.php?image=bild3my2.jpg

These are the last rows from the status windows
[R] 200 PROT command successful.
[R] PASV
[R] 501 PASV not allowed.
[R] Lyssnar på PORT: 1027, Väntar på anslutning.
[R] PORT 192,168,0,100,4,3
[R] 200 Port command successful.
[R] LIST -al
[R] 425 Cannot open data connection.
[R] Listningsfel
RobertSmith is offline  
Old 12-21-2006, 12:29 PM   #5
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

Quote:
Originally Posted by RobertSmith
Thx for your quick answers. Could it be so simple that this can't be done with my router D-LINK 624?

For other applications it is enough to do a port forward for only one port and that is done on "virtual server" se picture 1
http://img186.imageshack.us/img186/368/bild2hv6.jpg
this is incorrect. what you configured is you allowed people to connect to YOUR port 21..unless you are running a server, you should remove that.

Quote:
I'm not sure if it is possible to forward a range of port, I have tried on "application" with no success
http://img241.imageshack.us/img241/4361/bild1vz9.jpg
this one looks more like what you need.. just change public port to 21...if sites you connect to use port 21, otherwise change it to whatever port they use

Quote:
This is my settings for options (F6)
http://img186.imageshack.us/my.php?image=bild3my2.jpg
enable checkbox under those ports "force active mode to use this ip address" and either enter your internet ip or use flashfxp's ip autodetection.
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 12-21-2006, 12:52 PM   #6
RobertSmith
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Quote:
YOUR port 21..unless you are running a server, you should remove that.
I have a server installed (but not in use so i can uncheck port 21)
Quote:
this one looks more like what you need.. just change public port to 21...if sites you connect to use port 21, otherwise change it to whatever port they use
The site i try to connect to use port 55800 so i changed the public port to 55800 (but i don't understand why i have spec. the other sites port here, i thought that was enough to do in flashFXP)
Quote:
enable checkbox under those ports "force active mode to use this ip address" and either enter your internet ip or use flashfxp's ip autodetection.
i´m now useing http://iplookup.inicom.net (i have dynamic IP)


But sorry to tell, same problem
RobertSmith is offline  
Old 12-21-2006, 01:22 PM   #7
MxxCon
Super Duper
FlashFXP Beta Tester
 
Join Date: Oct 2001
Location: Brooklyn, NY
Posts: 3,876
Default

post session log
__________________
[Sig removed by Administrator: Signature can not exceed 20GB]
MxxCon is offline  
Old 12-21-2006, 01:53 PM   #8
RobertSmith
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Quote:
Originally Posted by MxxCon
post session log
[R] Ansluter till 360 -> DNS=XXXX.myftp.org IP=83.XXX.XX.XXX PORT=55800
[R] Ansluten till 360
[R] 220 Gene6 FTP Server v3.8.0 (Build 34) ready...
[R] AUTH SSL
[R] 234 AUTH command ok; starting SSL connection.
[R] Ansluten. Handskakar SSL sessionen..
[R] SSL handskakning avklarad...
[R] SSL krypterad session med cipher AES256-SHA (256 bits)
[R] PBSZ 0
[R] 200 PBSZ=0
[R] USER XXXX
[R] 331 Password required for XXXX.
[R] PASS (hidden)
[R] 230 User XXXX logged in.
[R] SYST
[R] 215 UNIX Type: L8
[R] FEAT
[R] 211-Extensions supported:
[R] AUTH TLS
[R] CCC
[R] CLNT
[R] CPSV
[R] EPRT
[R] EPSV
[R] MDTM
[R] MFCT
[R] MFMT
[R] MLST type*;size*;create;modify*;
[R] MODE Z
[R] PASV
[R] PBSZ
[R] PROT
[R] REST STREAM
[R] SIZE
[R] SSCN
[R] TVFS
[R] UTF8
[R] XCRC "filename" SP EP
[R] XMD5 "filename" SP EP
[R] XSHA1 "filename" SP EP
[R] 211 End.
[R] CLNT FlashFXP 3.4.0.1145
[R] 200 Noted.
[R] CWD /
[R] 250 CWD command successful. "/" is current directory.
[R] PWD
[R] 257 "/" is current directory.
[R] TYPE A
[R] 200 Type set to A.
[R] MODE Z
[R] 200 Mode Z ok.
[R] PROT P
[R] 200 PROT command successful.
[R] PASV
[R] 501 PASV not allowed.
[R] Lyssnar på PORT: 2004, Väntar på anslutning.
[R] Begär IP Koll av http://iplookup.inicom.net
[R] Återvänt: 85.XXX.XX.XX
[R] PORT 85,XXX,XX,XX,7,212
[R] 200 Port command successful.
[R] LIST -al
[R] 425 Cannot open data connection.
[R] Listningsfel

Last edited by RobertSmith; 12-21-2006 at 06:42 PM.
RobertSmith is offline  
Old 12-21-2006, 06:41 PM   #9
RobertSmith
Junior Member
 
Join Date: Dec 2006
Posts: 5
Default

Eureka

Now it works, all i had to do was to put in the port range on the right TAB = Firewall TAB

Not the port for the site/server only the port range (same as in FlashFXP) se picture

It works without enable checkbox "force active mode to use this ip address"

http://img314.imageshack.us/img314/3161/bilduo7.jpg

Last edited by RobertSmith; 12-21-2006 at 06:51 PM.
RobertSmith is offline  
Closed Thread

Tags
files, flashfxp, port, problem, router

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:55 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)