Go Back   FlashFXP Forums > >

FlashFXP v5.x Public Beta Please direct all comments, suggestions, bug reports, and feedback for public beta releases to this forum.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 08-31-2013, 08:39 PM   #1
fei249
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2007
Posts: 9
Default Chinese language issue for "Preference" dialog

The "Preference" dialog cannot show Chinese normally.

And the Interface of FlashFXP is garbled after Import custom language file.
Attached Thumbnails
Chinese language issue for "Preference" dialog-snap1-png   Chinese language issue for "Preference" dialog-snap2-png   Chinese language issue for "Preference" dialog-snap3-png   Chinese language issue for "Preference" dialog-snap4-png   Chinese language issue for "Preference" dialog-snap5-png  

Chinese language issue for "Preference" dialog-snap7-png   Chinese language issue for "Preference" dialog-snap8-png   Chinese language issue for "Preference" dialog-snap10-png   Chinese language issue for "Preference" dialog-snap11-png   Chinese language issue for "Preference" dialog-snap12-png  

Chinese language issue for "Preference" dialog-snap14-png   Chinese language issue for "Preference" dialog-snap15-png   Chinese language issue for "Preference" dialog-snap17-png   Chinese language issue for "Preference" dialog-snap18-png  
Attached Files
File Type: ulf Chinese Traditional.ulf (36.7 KB, 2 views)
fei249 is offline  
Old 09-01-2013, 06:47 AM   #2
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Thank you for your bug report.

I have discovered a couple different issues.

Some of the languages files that were included in the FlashFXP v5 release have an extra CR/LF inserted before the [UTF8/MIXED] header, this unexpected CR/LF can cause the detection of the [UTF8/MIXED] header to fail and trigger a ANSI/Charset conversion from the current OS locale to UTF8 which could mangle the end result. This issue has been addressed to ensure that the language files included with FlashFXP do not contain this unnecessary CR/LF.

This issue also effected the language files downloaded by FlashFXP via (Languages > Download / Update Languages) and updates downloaded via the Translation Editor (Languages > Translate), it did not however effect language updates downloaded during a Live Update check.

While I am not 100% sure if these issues I found apply to the bug you reported above, they were discovered while investigating this issue.

I also found a couple problems with the "Chinese Traditional.ulf" file you included in your bug report.

Did you try to import a language file from FlashFXP v4.x into v5.x?
(for some multi-byte ANSI languages this may or may not work depending on several different factors.)

If not can you please explain where the original file that you tried to import came from?

The file you attached, I am assuming that this is the version of the file after import, is that correct?

Can you please attach a copy of the original file that you tried to import.

The problem I am seeing with this language file is that the file and the text within it are not UTF8 encoded and this is most likely causing most of the problems.

FlashFXP v5.x uses UTF-8 encoding everywhere and in many places it expects the text to be UTF-8 encoded text, While in some places ANSI multi-byte text might render correctly this is not correct and will cause many problems down the road.
bigstar is offline  
Old 09-01-2013, 07:41 AM   #3
fei249
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2007
Posts: 9
Default

1. To translate FlashFXP v5 via the Translation Editor and Save (Snap19.png)
2. To Export the language file to "Chinese Traditional.ulf" (Snap20.png & Snap21.png)
3. To select Options -> Language -> (user created) and FlashFXP v5 return to English (Snap22.png)
4. Try to select Options -> Language -> Import -> Chinese Traditional.ulf and then select the "Chinese Traditional (user created)" language (Snap23.png ~ Snap26.png)
Attached Thumbnails
Chinese language issue for "Preference" dialog-snap19-png   Chinese language issue for "Preference" dialog-snap20-png   Chinese language issue for "Preference" dialog-snap21-png   Chinese language issue for "Preference" dialog-snap22-png   Chinese language issue for "Preference" dialog-snap23-png  

Chinese language issue for "Preference" dialog-snap24-png   Chinese language issue for "Preference" dialog-snap25-png   Chinese language issue for "Preference" dialog-snap26-png  
Attached Files
File Type: dlf Chinese Traditional.dlf (45.4 KB, 5 views)
File Type: ulf Chinese Traditional.ulf (36.7 KB, 5 views)
File Type: ulf .ulf (46.1 KB, 3 views)
fei249 is offline  
Old 09-02-2013, 07:05 AM   #4
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

I am not sure whats going wrong with the Chinese Traditional.ulf

I regret that you might need to delete this file and start fresh by loading the default Chinese Traditional and then make any changes based on the current default, then when you save the changes it will create a new Chinese Traditional.ulf file and this new file should be correct, if not please let me know.
bigstar is offline  
Old 09-02-2013, 08:26 AM   #5
X3
Senior Member
FlashFXP Beta Tester
 
X3's Avatar
 
Join Date: Feb 2006
Location: location, location.
Posts: 324
Default

I was able to fix it at least for me.... IF this works for you guys here what it was.

1) Header in file, put the order same as in original , name, version, date etc (if it matters at all)
2) With notepad++ Menu - Encodings >converted to utf8 without bom

Saved file and loaded in Flashfxp all was ok.
Obviously I dont read or understand Chinese so please lookup to see if anything needs correcting.

By looking alone the "。"all look to me like "." < full stops and need replacing but I could be wrong....

See attached

Edit the last .ulf https://oss.azurewebsites.net/forum/attach...ce-dialog-.ulf attached by @fei249 seems to be ok so idk... I dont get any non display like in screenshots.

My about box has a few ???? ???? ???? using any of these which looking at the @fei249 screenshot it looks ok yet mine is not



The language I attach below is at best a hack to see what is what which works just as good as the one I mention above attached only as .ulf (nofilename)
Attached Files
File Type: ulf Chinese Traditional.ulf (45.5 KB, 3 views)
__________________
Regards

Last edited by X3; 09-02-2013 at 11:28 AM.
X3 is offline  
Old 09-09-2013, 01:49 PM   #6
libojun
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 19
Default

Well, it seems that the default character set and the environment of FlashFXP does not support or compliant with the Asian "Double Byte Character Set", and the FlashFXP Splited the "Full Double Byte Chinese Character" into two "Single Byte Characters", so it made the current version"Cannot show Chinese Correctly"!

And, I think the Japanese and Korean language would got the same problem because they use the "Double Byte Character Set" also!
libojun is offline  
Old 09-09-2013, 03:07 PM   #7
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Quote:
Originally Posted by libojun View Post
Well, it seems that the default character set and the environment of FlashFXP does not support or compliant with the Asian "Double Byte Character Set", and the FlashFXP Splited the "Full Double Byte Chinese Character" into two "Single Byte Characters", so it made the current version"Cannot show Chinese Correctly"!

And, I think the Japanese and Korean language would got the same problem because they use the "Double Byte Character Set" also!
What specifically are you referring to?

There were some issues with the rendering where the UTF8 text was rendered directly as Unicode (the conversion from UTF8 to Unicode was missing) and I believe all of these issues have since been resolved in the current build.

In the about box the issue related to the ??? was caused by the use of the wrong text control, the control wasn't updated to the newer Unicode version.
bigstar is offline  
Old 09-09-2013, 03:14 PM   #8
libojun
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2010
Posts: 19
Default

Quote:
Originally Posted by bigstar View Post
What specifically are you referring to?

There were some issues with the rendering where the UTF8 text was rendered directly as Unicode (the conversion from UTF8 to Unicode was missing) and I believe all of these issues have since been resolved in the current build.

In the about box the issue related to the ??? was caused by the use of the wrong text control, the control wasn't updated to the newer Unicode version.
I have post a list here https://oss.azurewebsites.net/forum/flashf...0-0-build.html

and updating the problems one by one, please wait for me.
libojun is offline  
Old 09-12-2013, 09:28 AM   #9
fei249
Junior Member
FlashFXP Registered User
 
Join Date: Dec 2007
Posts: 9
Default

The issues are fixed on build 3670
fei249 is offline  
Old 09-12-2013, 10:37 AM   #10
bigstar
FlashFXP Developer
FlashFXP Administrator
ioFTPD Beta Tester
 
bigstar's Avatar
 
Join Date: Oct 2001
Posts: 8,012
Default

Thank you very much for confirming that the issues are now resolved.
bigstar is offline  
Closed Thread

Tags
chinese, dialog, flashfxp, language, preference

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:39 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)