Go Back   FlashFXP Forums > >

Programming Need help with C/C++/Delphi? Ask here and make us all laugh.

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 09-29-2003, 09:33 PM   #1
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default WM_KILL on connection running script

What happens when u try to WM_KILL a connection that currently is running a script ?

I'm trying to see why when i try to kill all connections that are inside a specific dir on nuke, it sometimes says that it' can't kick all users from inside the dir (so ioA can't rename it)...
Mouton is offline  
Old 09-29-2003, 09:50 PM   #2
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

well, i tried to do a big rescan, and on nuke, the connection can't be WM_KILLed... it does nothing.

a site kick would kick the user once the script has finished running, but a kill won't do that.

I don't see how one could nuke correctly...

any thought ?
Mouton is offline  
Old 09-30-2003, 08:54 AM   #3
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

I think my best bet would be to loop that WM_KILL and sleep for like 1/4s between each try... for like 3s... or until all users are killed... should work.
Mouton is offline  
Old 09-30-2003, 09:30 AM   #4
Mouton
Posse Member
Ultimate Scripter
ioFTPD Administrator
 
Join Date: Dec 2002
Posts: 1,956
Default

i did some more tests......
now, WM_KILL returns 0 even if user is running a script, and his connection is forced closed when script is done... :|

[10:29:50] Error: 10054:Connection reset by peer
[10:29:50] Connection lost: 127.0.0.1
Mouton is offline  
Old 10-01-2003, 08:44 AM   #5
darkone
Disabled
FlashFXP Registered User
ioFTPD Administrator
 
darkone's Avatar
 
Join Date: Dec 2001
Posts: 2,230
Default

Yes, connection is closed after script finishes.. terminating script, wouldn't be very nice option
darkone is offline  
Closed Thread

Tags
connection, dir, running, script, wm_kill

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
why do i get this error ? twisted General Discussion 0 05-02-2005 11:25 PM
4.5.4 and pre error Borni2k Bug Reports 0 02-28-2003 09:57 AM


All times are GMT -5. The time now is 03:31 PM.

Parts of this site powered by vBulletin Mods & Addons from DragonByte Technologies Ltd. (Details)