View Full Version : Cant get it to work

07-08-2006, 01:55 PM
Hello , I just registered and installed IOFTPD today. But for some reason ioGUI 2.0.6 will not start at all when using ioFTPD 5.8.5r

it says:

[2] site ioGuiExt
[2] 200 ERROR: No command specified.

I tried both the exe and the script

ioGuiExt = EXEC C:\FtpMain\IOftpd\scripts\ioGUI\ioGuiext.exe

ioGuiExt = TCL C:\FtpMain\IOftpd\scripts\ioGUI\ioGuiExt.itcl

And added the level for use

ioGuiExt = M

all as told in the helpfile

I allso added the 2 ocx files from the dl section in the ioGUI dir


I can start ioGUI2 , it will log in, but it wont show any activity nor can I import users and groups

it just wont work, have you got any tips?

07-08-2006, 06:28 PM
[2] site ioGuiExt
[2] 200 ERROR: No command specified.
This is actually a good sign, the serverside script is working. Try "site ioGuiExt who" and your should see a list of online users.

Seeing that [2] prefix makes me assume that you ran the command in an FTP client. Try the same command in the "console" tab in ioGui and see what it outputs there. Are you logging in with a master account (flag +M) when using ioGui ?

07-09-2006, 03:01 AM
Hey TNX! :cool:

That who command for some reason did the trick. The only stuff it does not show now is stats, is that normal ?

other from that this makes this ftpd neat ! .. I have been using raiden for years , but this is kickass!

Got any tips what scripts could be useful ( I do not have an irc bot, and installed the ioBANANA package)

BTW, I just noticed one weird thing, when I run iogui under a master system account, my "normal" login which has logins set to -1 is only allowed to login 1x , at the second login I get this message:

[THUiS (LaME)] 220 FTP Server ready.
[THUiS (LaME)] 331 Password required for XXXXX.
[THUiS (LaME)] PASS (hidden)
[THUiS (LaME)] 530 Login failed: Maximum concurrent connections for single host reached.
[THUiS (LaME)] Retrying after 30 seconds for THUiS (LaME)

When I quit ioGUI this problem is gone

Regards, and thanks for the quick answer!

07-09-2006, 06:03 AM
Check the error message:
530 Login failed: Maximum concurrent connections for single host reached.

The first thing ioFTPD does, is check the connections per IP. For that, it uses \etc\Hosts.Rules. If the default policy is set to "POLICY ACCEPT 3" for example, it will only accept 3 connections per IP, even if they all login with an account that has unlimited logins. Most people will allow more connections for administrative use. For example:

ACCEPT I 127.0.0. ADMIN -1
ACCEPT I 192.168.0. ADMIN -1
ACCEPT I ADMIN -1This allows unlimited connections from the "ADMIN" class, in this example: localhost (127.*), LAN (192.168.*) and the fixed IP of an administrator.

07-21-2006, 06:55 AM
Hi Addict, I installed SSL on the server but there is no way ioGUI connects via SSL
I used winsslwrapper. The site is configged with ssl3 and implicit connections (I also tried explicit)
The site just wont accept TLS, is there any other way to config?