View Single Post
Old 04-18-2003, 08:45 PM  
Junior Member
Join Date: Apr 2003
Posts: 4
Default How I got FTP to work with Linksys

Linksys BEFSR41 Firemware version 1.44.2, Dec 13 2002

On the Router, under Forwarding, enter some port ranges like 40000-40020, label it FTP Client, TCP Prot checked, send it to your IP on your machine.

On your client, Under Options | Preferences | Proxy / Firewall / Ident tab set the following...
Proxy Server.... Type = 0, Check use Pasv Mode

Firewall..... Check Limit Local port range and set the numbers to 40000 min and 40020 max or what ever it was you set on the router. Check Bind Sockets to this port and enter your IP or get a free DNS name like I did and enter the name instead.

Ident Server.... Leave at default (Disabled)

With these settings, I am able to get to other sites using PASV and PORT modes (PASV is prefered as PORT mode can be hijacked, but sometimes only PORT will work if the site isn't setup for PASV). And most of these sites I go to have routers of the like.

According to LinkSys, they say this won't work. It's true with some other FTP clients like Cute, FTP Voyger, Bulletproof as they don't offer this port setting inside the client. But with Flash we got it made
estrait is offline