View Single Post
Old 10-20-2004, 07:11 PM  
Junior Member
Join Date: Oct 2004
Posts: 3
Default Having active connections problems

a friend of mine set up and ftp server but he can't get it to pasv... okay fine..lets do it active... except... everybody can login..except for me...

My settings are; speedtouch 510 modem with an E-Tech WLRT03 router... i have the firewall inside the speedtouch disabled and forwarded the ports 40000-40100 in the e-tech to my ip ( in WLAN).

When i try to connect to his FTP with pasv mode turned off i get;
[02:11:33] [L] Requesting IP Lookup from
[02:11:33] [L]         Returned:
[02:11:33] [L] PORT 83,118,77,74,156,73
[02:11:33] [L] 200 PORT Command successful.
[02:11:33] [L] LIST -al
[02:11:33] [L] 150 Opening ASCII mode data connection for /bin/ls.
[02:12:16] [L] 426 Data connection closed, transfer aborted.
[02:12:16] [L] List Complete: 0 bytes in 21,13 seconds (0,0 KB/s)
As you may see, I already checked the forum and tried some things that worked with other people.. like Limit Local Port Range To: 40000-40100 and Force Active Mode to use this IP: (which gets as a results..which is correct).
Switching the third function Use this IP only for non-port 21 and SSL/TLS connections makes no difference (as to be expected).

The port on which it tries to build an active connection is alread set correctly because it says 83,118,77,74,156,73.
The first 4 strings are the 4 numbers of my IP and the 5th and 6th numbers are the numbers of the port. Which is: 156 * 256 = 39936, plus 73 = 40009. I set my active port to 40000-40100 so that's correct.... but... it still doesn't work!
I tried checking and unchecking every option at 'Options' in the site manager but nothing seems to work...

Please help me out!!
pEeDy is offline