View Single Post
Old 01-19-2004, 04:25 PM  
Junior Member
Join Date: Jan 2003
Posts: 10
Default FXP tcp timeouts

Does your control connection to your ftp site die when you perform an FXP transfer? Personally I find that it dies after about 10 minutes or so. If the transfer takes any longer than that, then flashfxp just hangs there waiting for the transfer complete message, which it never gets. Sound familiar to any of you?

I last posted a thread about this more than a year ago I think, and was told it was a problem with my router. So fair enough I didnt think any more about it, and just decided to buy a better one at some point.

I have however found out how to fix it. You need to adjust (or even create) a windows registry setting which controls one of the tcp Keep Alive settings.

This setting is something an application has control over when it creates the socket, which I am presuming Flashfxp developers never bothered doing. The setting defaults to 2 hours on Windows 2003 server (and other OS's?), so even if they set the flag on the socket handle, it may still not have worked correctly if they didnt set the socket option value to a reasonably small value.

Luckily, the registry setting lets you override the application level settings on its socket, so you can force all sockets to 'KeepAlive'. I set mine to 5 minutes, AND IT WORKS GREAT!

On windows 2003 the setting is at;


and the value is called 'KeepAliveTime'. The setting might not actually be in the registry, so you might have to create it. I created mine, and set it to 300000 decimal which is in 5 minutes in milliseconds.

My problem occurs at around 10 minutes, so I figured 5 minutes was good. I have had no ill affects from setting this parameter, everything else works fine, and I seem to get the same bandwidth as before etc....

I just thought I would share this information with you guys and hope you find it useful. If, like me, this was really annoying, it needn't any more hopefully. I hope it works for you guys.


PS It should also work on non Windows 2003 machines, but the registry value might be in a different place. If youre particularly intersted in the relatively undocumented tcpip options of windows 2003 then go here for the info:

Edit: just wanted to say that you may need to reboot... I still had the problem until i rebooted.
bigbras36 is offline