View Single Post
Old 10-04-2013, 08:16 PM  
Too much time...
Join Date: May 2005
Posts: 1,194

Make sure ioftpd isn't already running, and start it manually and then start the bot manually. Let's just confirm that works first. If it doesn't then check that you have the default setting of "WindowName = ioFTPD::MessageWindow" in the ioFTPD.ini config file and that you haven't touched the similar setting in the bot. Sometimes a stray edit in the config file can mess things up...

My guess is that works fine though. I believe FireDaemon should work with the right settings, though it's been a long time since I've played with it. I remember using something like enable desktop integration, and configuring FireDaemon to run the services as a user instead of the local admin account. You might try that.

The other option I believe was provided by o_dog. There is a botcheck(?) command you can setup in ioNiNJA to start eggdrop. If you go that route you have ioFTPD started either manually or as a service, and then have a siteop issue that command once the server is up and ioFTPD starts the bot which means it's always run as the same user. I haven't tried that but it's worth a shot.
Yil is offline   Reply With Quote