View Single Post
Old 08-08-2013, 01:57 AM  
Junior Member
Join Date: Jun 2012
Posts: 1
Default sending commands on SFTP over SSH connections

* FlashFXP v[4].[25], build [1813], [x]registered, [ ]unregistered, [ ]pirated
* OS [x] Windows 8, [ ] Windows 7, [ ] WinXP, [ ] Other (specify)
* Running behind hardware router/firewall [x] Yes & Model [Fritz Box 6360], [ ] No, [ ] Not sure
* Running software firewall [ ] Yes, Name [ ], Ver. [ ], or [x] No
* Running Antivirus [ ] Yes, Name [ ] or [x] No
* Internet Connection [x] DSL, [ ] CABLE, [ ] Other(specify)


i'm using flasfxp to connect to various debian-servers using sftp over ssh. works like a charm so far.
today i tried to send chown as a raw command to the server to change ownership of a file.
only return i got in log window: [R] chown 1000 /var/www/filename.php

i googled und stumbled upon the SITE command and tried it. result:
[R] SITE chown 1000 /var/www/filename.php

i've also tried: SITE "chown 1000 /var/www/filename.php" which did not work either.

i then connected with my command line sftp-client and sent chown 1000 /var/www/filename.php which worked without any problem.

i might be blind, but i have not found any switch in any options pane, and did not succeed in sending the chown command with flashfxp. is there a special trick? or is it just not possible?

if it's not possible with the current version i would like to file a feature request. would that be ok?
garfield.catnet is offline