View Single Post
Old 02-04-2013, 12:03 PM  
Junior Member
Join Date: Jul 2005
Posts: 2
Default Cannot Connect via SSH

First - I love FlashFxp and have been using for quite a few years. I am an oldtimer and have always used FTP. I am being pressured by my peers to use SSH and have been trying to set it up with no luck.

I always get the following:
[L] Connected to XXXXXX - SSH
[L] Host key algorithm ssh-RSA, size 2048 bits.
[L] Fingerprint (MD5): c6:a4:23:14:2c:3a:4e:84:86:95:60:20:c7:ed:fa:eb
[L] Key exchange: diffie-hellman-group14-sha1. Session encryption: aes256-ctr, MAC: hmac-sha1, compression: none.
[L] Auth Type: Public Key
[L] Authentication failed [Public Key]
[L] Auth Type: Password
[L] Auth Type: Password
[L] Authentication failed [Invalid Password]
[L] SSH Error: failed to negotiate authentication method
[L] SSH Connection closed

Because I am not in familiar territory, I am not sure where the problem is. My host is Rochen and I am on a managed virtual server. Rochen has enable SSH. In cpanel under security/SSH/Shell access I have generated a public and private key and recorded the key name and password. I have tried 1024 and 2048 bits and RSA/DSA. I download the keys locally.

In the FlashFXP setup, I start with a working FTP profile, then change the connection type to SFTP over SSH. I leave the username, password and address the same. Then in connections I select the key manager and import both private and public keys, giving them the name that was assigned in cpanel and the password assigned in cpanel. I choose type RSA/DSA for SFTP.

I apply everything and then try to connect. I have tried many different permutations, but the results are always the same.

I am sure that I am missing something simple, but I dont see it. Please walk me through my error.
mike_36 is offline