View Single Post
Old 02-02-2013, 06:03 PM  
Junior Member
Join Date: Feb 2013
Posts: 2
Default Setting up knocking


I am having some problem with setting up knocking with ioFTPD correctly.

I have set:

Reject_Unknown_Ips = True

Knock_1 = 66788
Knock_2 = 66544
Knock_3 = 66700

If I try ioKnock and correctly knock there is a log entry in ioFTPD.log:

02-02-2013 23:52:51 KNOCK: ""

However, if I try to log on to the server there is still a login prompt, it just rejects my password:

[R] 530 Login failed: Invalid password.

As it claims my password is rejected it logs the following:

02-02-2013 23:52:58 Host '*@' (HOMECOMPUTER) did not match any of user 'admin' allowed hosts.

Also, with my IP added to the allowed hosts I cannot use the command "SITE KNOCK":

[R] 500 'SITE KNOCK': Command not understood.

The manual says that if knocking is not enabled, that command is also disabled.

Have I missed something? Am I supposed to enable knocking some other way except to reject unknown IPs and adding knock ports?

Help would be much appreciated.
Oipple is offline   Reply With Quote