View Single Post
Old 08-31-2002, 06:05 AM  
Junior Member
Join Date: Dec 2001
Posts: 8
Lightbulb Socks5 proxy bug

This is reproducable.

BPFTP 2.15, behind a hardware NAT router with port 1024>1060 open for passive FTP and port 21 open for active ftp.

Client: FlashFXP 2.0 rc8 build 862.

The problem is if i load FlashFXP and try to connect to the above server, i get a "socks error: connection refused". Wich i found sort of puzzling since everything worked fine with wincommander about 10 seconds earlier.

After trying different settings, i came to the conclusion, if i disable the socks5 option and just use my ordinary routed connection (in active mode) i can connect fine to the FTP.
The funny part is after i have made the connection i now can use socks5 both in active/passive, or just my routed connection in both active/passive.

So, everything seems fine right? No, after i restart FlashFXP i get the same error msg and i have to redo what i just wrote above. As i said, wincommander works fine, both active/passive with the socks5 server or just the routed (NAT) connection.

The error msg:

WinSock 2.0
Connecting to via Proxy
Connected to Proxy Port 1080
220 welcome
331 Password required for x.
PASS (hidden)
230 User x logged in.
215 UNIX Type: L8
REST 100
350 REST supported. Ready to resume at byte offset 100.
350 REST supported. Ready to resume at byte offset 0.
257 "/" is current directory.
200 Type set to A.
227 Entering Passive Mode (213,x,x,x,4,16).
SOCKS Error: Connection refused
mhe is offline