View Single Post
Old 04-22-2010, 04:04 AM  
Senior Member
Join Date: Feb 2006
Posts: 138

io 743 appears to work fine No broken transfers yet.

On a side note, preload is still strangly slow.. this is in io 743 with delay=true:

04-22-2010 09:30:16 PRELOAD: "begin" "../etc/default.vfs"
04-22-2010 09:34:47 PRELOAD: "points=13" "../etc/default.vfs"

After playing around some with it, I'm still confused as to how it's intended to work.

I tried creating ../etc/sections.vfs, and move some of the mountpoints in there, but they don't show up on site!

I also tried adding 1=/mydir/ for every single dir in the / mount, with it still taking equally long time to start up.

Then I have another site with atleast 100x the ammount of dirs and subdirs, which load in 0s

04-22-2010 10:21:20 PRELOAD: "begin" "../etc/sections.vfs"
04-22-2010 10:21:20 PRELOAD: "points=4" "../etc/sections.vfs"
04-22-2010 10:21:20 PRELOAD: "count=141" "../etc/sections.vfs"
04-22-2010 10:21:33 SSL: "Unable to locate default certificate" "name=ioFTPD" "Service=FTP_Service"
04-22-2010 10:21:33 START: "PID=2960" "CmdLine="

(assuming START is where users are able to log in)

in that sections.vfs file, some of the mountpoints are plainly copied from default.vfs

When going back to my trouble site, I attempted to only add 1 single (small) directory to sections.vfs, and leave a copy + rest of mounts in default.vfs:

04-22-2010 10:55:02 PRELOAD: "begin" "../etc/sections.vfs"
04-22-2010 10:55:15 PRELOAD: "points=1" "../etc/sections.vfs"
04-22-2010 11:00:45 SSL: "Found certificate" "name=abcd" "Service=FTP_Service" "(Certificate_name)"
04-22-2010 11:00:45 START: "PID=528" "CmdLine="
04-22-2010 11:00:47 LOGIN: "FTP_Service" "pion"

As you can see, it would appear as if preload finish in a timeframe that looks much more sane, but I still can't log in.

Anyway - I'm fairly confused as to how I'm suppose to use sections.vfs, and the preload settings.. maybe you could clarify? Like what is correct syntax to only go 1 subdir deep during preloading? And debug what directory/harddrive in particular that's causing this very long startup time?

*Edit: to top it off, I tried removing all but one of the mountpoints in default.vfs, then boot ftpd, and add the rest of dirs after. Relogin works instantly, listing all folders as it should instantly..

Last edited by pion; 04-22-2010 at 04:25 AM.
pion is offline   Reply With Quote