View Single Post
Old 09-15-2008, 11:40 PM  
Too much time...
Join Date: May 2005
Posts: 1,194

One rather critical issue is what your HOST= line is set to. There is essentially no way to get local FXP to work if you are talking to your server on a local IP only device configured in your ioFTPD.ini file. It must have a dynamic dns name or external IP. What does the pasv/port response show?

Depending on your home router, the solutions I think vary a bit. If you can talk to your other machine via your external IP because the router forwards the port correctly (and without loss, some suck at this) then all is good. I wouldn't expect this to just work for you...

If it doesn't, then you'll probably need 2 sites defined in flash or whatever. One using the local IP and turn on the pasv uses host address option or whatever so the client ignores the IP in the server response and you can use this for downloading locally from yourself. The other should connect on the local IP but not have that option defined and thus won't transfer locally, but should FXP fine...
Yil is offline   Reply With Quote