View Single Post
Old 07-27-2006, 03:58 AM  
Junior Member
Join Date: Jul 2006
Posts: 6
Default Problems with FXP behind D-Link Router

I'm attempting to do Server-to-Server FXP transfers (to and from the same server), and I am having limited success with FlashFXP from my home PC behind a D-Link DI-614+ Router.

My initial thought was that perhaps my FTP server (my web hosting company) didn't support FXP, however, their documentation says that they do.

So I fired up FlashFXP on my work computer (which is not behind a D-Link router), and it works like a charm.

I did some googling, and I found the suggestion to add the line, "FxpNatTrick=1" to the FlashFXP.ini file. Surprisingly enough, it worked right on my first try copying a file from 1 directory to another.

I tried queuing up a list of files, and it failed. FlashFXP would copy 1 or 2 files successfully, then the server would disconnect, with "Connection lost" and "Transfer Failed" lines in the FlashFXP log. There was nothing particularly interesting in the log that indicated any other sort of error. FlashFXP would reconnect to the disconnected server, and attempt to transfer again, failing.

After trying it a few times, I could find no real pattern, but it would always fail after at most 3 successfully transferred files, but most of the time failing without transferring a single file.

Is there anything else I can do besides chucking my router in the trash?

Coincidentally, I tried the same experiment between 2 local FTP servers, both behind the D-Link router, both running FileZilla, and had exactly the same results.

* FlashFXP v[3 ].[4 ], build [1145 ], [X ]registered, [ ]unregistered, [ ]pirated
* OS [X ] WinXP, [ ] Win2K, [ ] Win98, [ ] WinME, [ ] Other
* Running behind NAT/router [X ] Yes & Model [D-Link DI-614+ ], [ ] No, [ ] Not sure
* Running firewall [X ] Yes, Name [Windows Firewall ], Ver. [ ], or [ ] No
* Running Antivirus [X ] Yes, Name [AVG Free ] or [ ] No
* Network [ ] xDSL, [X ] CABLE, [ ] Dail-Up, [ ] Other

HoWheels is offline