View Single Post
Old 05-20-2006, 11:10 AM  
Senior Member
Join Date: Oct 2002
Posts: 703

Probably problem with settings in router and/or firewall. You should forward not only the port you connect to (ie. 9999) but also that port -1 (ie. 9998) for active transfers and also the dataports you've set up in ioFTPD.ini (default 1024-2048). Though I would recommend setting portnumbers above 5000. You should also make sure you've got enough dataports for the numbers of users that are logged in at one time. A rule of thumb is to let each user have between 10-100 ports available. So 10 simultaneous users would make at least 100 ports open or 1000 ports to make sure ioFTPD won't run out of ports ie. transfer of many small files that occupie one port each (and it takes N seconds before windows can close the port(s) and make it available for transfer again).

If your router does not support port forwarding it uses port triggering that is not as reliable. It can close a number of ports if the triggering ports haven't been used in some time, ie. during transfer of big files on not so fast network etc.

If your firewall does not allow ioFTPD to use ports like 9998,9999 + the dataports you might run into trouble. Make sure the ports you use are allowed and/or that windows firewall is disabled if you use a third-party firewall like kerio or norton or whatever.

If you are behind router/NAT don't forget to setup ioFTPD.ini properly ie.
Host = <external ip.. routers ip.. NOT internal ip>
Bind = <your local ip.. internal ip ie.>

Hope it helps
Zer0Racer is offline   Reply With Quote