View Single Post
Old 12-01-2005, 08:06 PM  
Senior Member
Join Date: Jun 2003
Posts: 100
Default SSL config problem


First of all i used search and read through the forum and the KB.

I installed SSL on different boxes without problems.
One box giving me headaches though, it's runing winXP ( like the others).

on Loggin i get
504 AUTH %s unsupported.
Failed SSL/TLS negotiation, disconnected

Q: What does "504 AUTH %s unsupported." mean ? Appears on login, when SSL is enabled.
A: This error means that ioFTPD SSL isn't configured correctly.

It can be for any of those reasons:
- You didn't install your SSL certificate correctly; you installed the certification in another user's than the one running ioFTPD; you imported in the wrong database; etc.
- You're using the wrong certificate name in ioFTPD.ini
- You're using an invalid setting for SSL Cipher_Strength or Protocol in ioFTPD.ini

Been over the last two and am sure they are ok.

I'm using ioftpd on ioservice and read about the two added things in .env and did all that.

When trying to run the ssl.bat script i get the following error:

200-Error: Can't create the key of the subject ('')

I also tried to use the rsa_keygen.bat and import the certificate into trusted root but that wont work either.

Delled all certificates entrys, tried different makecerts.

In older threads on the board i see some guys have the same issues and some links to solving it, but that are dead links refering to the old site.

I hope any1 has a new idea i can try to solve this issue, it's giving me headaches by now.

Greetz Coffee
Coffee is offline   Reply With Quote