Thread: SSL and ioFTPD
View Single Post
Old 11-03-2005, 01:35 AM  
dink-puller's Avatar
Join Date: Sep 2004
Posts: 58

Originally Posted by Diveflo

i did these steps (like often posted in these board):

1.) Killed ioFTPD
2.) Created certificate with makecrt etc.
3.) Checked with certmgr that localhost is located in my certificates and trusted root certificates.
4.) Starting ioFTPD

It is NOT installed as a service. I tried it at different drives (c:\, d:\, g:\). Local it works without Problems .

Thanks 4 Help!
Sorry for my english...I'm from Germany, I tried it in the International Board but nobody posted a working solutiong.

Just having been through the mill on this one myself, I can say you might have a problem with Step 3. First read the how-to in ioFTPD/Help/. Then make sure to add the -pe option to your makecert command line to make the certificate exportable. If you are successful in making and exporting it, makecert.exe will return "succeeded", and it will appear in the "personal" tab of your certificate store, not in "trusted root certificates", and "personal" is where ioFTPD looks for it. Also make sure that the same windows user that runs ioFTPD is the one making and exporting the certificate, otherwise, ioFTPD will look in the wrong user's certificate store. Full makecert commandline will be something like this:

makecert -r -pe -n "" -b 01/01/2000 -e 01/01/2036 -eku -ss my -sr CurrentUser -a md5 -sky exchange -sp "Microsoft RSA SChannel Cryptographic Provider" -sy 12 ioftpd.cer

Hope that helps. I had trouble finding enough documentation for this, but I finally worked it out using the kb and the how-to included with ioftpd. Of course it all went out the window when I installed io as a service, because surprise surprise, the certificates no longer work and you have to make them as explained in the kb. If you do that, don't bother using exec.bat, it didn't work for me, but putting EXEC C:\Windows\System32\CMD.EXE /c in the custom commands section did work.
dink-puller is offline   Reply With Quote